L4 won't index since last large update

Page 1 of 2 (40 items) 1 2 Next >
This post has 39 Replies | 3 Followers

Posts 94
Rob | Forum Activity | Posted: Wed, Dec 15 2010 9:15 AM
Logos automatically updated a while ago including a huge resource download. It then tried to index and works for a while and then stops and says the indexer won't work and wants to send an error report to Microsoft. It does this every time I start my computer as part of the startup routine. This has made it part of my start up routine to pause the indexer for 4 hours so it will run and crash when I am not working at my computer. It also means that all those updated books are not indexed into my library. Until the automatic update, things were working fine and it would index as needed with updated or new books. My computer is running Windows XP. Core 2 Duo, Centrino Duo. I would love to get Logos working again and am not sure what to do. (I believe I have figured out how to remove the indexer from the startup configuration, but will need to restart the computer to be sure.) Thank you for your help, Rob

www.3rdcultureliving.com - Simple Abundant Legacy

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Dec 15 2010 9:35 AM

Rob:
Logos automatically updated a while ago including a huge resource download. It then tried to index and works for a while and then stops and says the indexer won't work and wants to send an error report to Microsoft. It does this every time I start my computer as part of the startup routine. This has made it part of my start up routine to pause the indexer for 4 hours so it will run and crash when I am not working at my computer. It also means that all those updated books are not indexed into my library. Until the automatic update, things were working fine and it would index as needed with updated or new books. My computer is running Windows XP. Core 2 Duo, Centrino Duo. I would love to get Logos working again and am not sure what to do. (I believe I have figured out how to remove the indexer from the startup configuration, but will need to restart the computer to be sure.) Thank you for your help, Rob

Enable logging and follow the instructions on that wiki page to upload them here.

But you may want to try this solution that has worked for some with the indexing crash issue:

This issue has been seen many times, and is often due to an out of date resource. You may be able to solve it by pausing the indexing (as you've been doing), start L4 and type update resources in the command bar. This will check all your resources for possible updates and can take some time, depending on the size of your library. If any new resources download, restart Logos4 and let it do it's thing while it loads. After your homepage, or layout is finished loading, pause indexing again (if necessary), and type update resources a second time, to ensure that the first attempt didn't miss anything. If nothing new gets loaded, enable logging (see above) and restart your computer.

Report back if this doesn't fix it, and also post your logs.

 

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 94
Rob | Forum Activity | Replied: Wed, Dec 15 2010 1:12 PM

Hi Rich,

Thank you for the quick reply. I tried updating, but it still crashed. Here are my log reports.

Thank you so much for your help.

Rob

Note: I am not sure if I attached the log reports correctly. It is just showing up as a line of text http.... I will see what happens after I post.

 

6574.Logos4Indexer.log

8625.Logos4IndexerCrash.txt

7266.Logos4.log

 

 

 

 

www.3rdcultureliving.com - Simple Abundant Legacy

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Dec 15 2010 2:00 PM

Rob:

Hi Rich,

Thank you for the quick reply. I tried updating, but it still crashed. Here are my log reports.

Thank you so much for your help.

Rob

Note: I am not sure if I attached the log reports correctly. It is just showing up as a line of text http.... I will see what happens after I post.

They posted fine.

Your Logos4.log shows that there was stuff downloading when the log stopped recording, so there may still be items downloading. Let that finish (pause indexing, if you can pause it before it crashes). If you can do that, you may not have to do what I'm suggesting below.

I'm not the best at understanding these, but it looks to me like there's a problem with the LGNTI. One of the easiest ways to fix this is to remove the resource and have Logos re-download it. There are two ways to do that:

Method 1: Pause indexing again, open Logos4, open Program Settings from the Tools menu and "Hide" the LGNTI (you seem to have a lot of hidden resources, so I assume you know how to do this). Then close and reopen Logos4. The LGNTI should then be deleted. Double check your Library to make sure. If it's gone, unhide it and Logos should download a fresh copy for you.

Method 2: Pause indexing, close L4, navigate to your resources directory and delete LGNTI.Logos4. Then reopen Logos4 which should detect the missing resource and download a fresh copy for you. If it doesn't detect the missing resource, you'd need to type in update resources to force L4 to download it.)

Choose one method (not both) and report back. There are other things to try, including deleting your resource indexes, but I'm hoping that this will do it for you.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 24923
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 15 2010 2:04 PM

Rob:
Thank you for the quick reply. I tried updating, but it still crashed. Here are my log reports.

Try the command  update resources once more.

If that does not download any resources then try:

  • delete KJV1900.logos4, KJV1900NT.lbsrvi, & KJV1900OT.lbsrvi from C:\Documents and Settings\CRU User\Local Settings\Application Data\Logos4\Data\pjwzyd4w.ghp\ResourceManager\Resources  (use Folder Options in Control Panel to view hidden files and folders)
  • restart Logos4

This should download the resource causing the error (KJV1900) and start indexing.

EDIT: I see that Richard thinks the LGNTI is the problem, but that had indexed successfully.

Dave
===

Windows & Android

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Dec 15 2010 2:34 PM

Dave Hooton:

Rob:
Thank you for the quick reply. I tried updating, but it still crashed. Here are my log reports.

Try the command  update resources once more.

If that does not download any resources then try:

  • delete KJV1900.logos4, KJV1900NT.lbsrvi, & KJV1900OT.lbsrvi from C:\Documents and Settings\CRU User\Local Settings\Application Data\Logos4\Data\pjwzyd4w.ghp\ResourceManager\Resources  (use Folder Options in Control Panel to view hidden files and folders)
  • restart Logos4

This should download the resource causing the error (KJV1900) and start indexing.

EDIT: I see that Richard thinks the LGNTI is the problem, but that had indexed successfully.

I gotta ask, Dave. How do you conclude, by reading these log files, that the LGNTI finished and the KJV1900 is the problem? I'm not disputing you, but I just can't figure out how you conclude that by looking at the indexer log.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 24923
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 15 2010 2:53 PM

Richard DeRuiter:
but I just can't figure out how you conclude that by looking at the indexer log.

2010-12-15 15:57:35.4375    9    Info    BibleIndex    (Timed) Indexing LLS:KJV1900
...

2010-12-15 16:01:39.5937    7    Info    BibleIndex    (Timed) Indexing LLS:LGNTI
...

2010-12-15 16:03:55.4375    7    Info    BibleIndex    (2m 15.8s) Indexing LLS:LGNTI
2010-12-15 16:03:55.4375    7    Info    BibleIndex    (Timed) Indexing LLS:LLXXI
2010-12-15 16:04:17.4687    7    Info    WindowsIndexerProgress    30 of 148 resources indexed; total progress is 15.0%
2010-12-15 16:04:19.6875    9    Error    Program    Unhandled exception:

The error occurred on thread 9  and the last program that started (Timed) there was KJV1900. If it had finished there would be a time like (2m 15.8s), which is how I know that LGNTI finished.

Dave
===

Windows & Android

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Dec 15 2010 3:00 PM

Dave Hooton:

Richard DeRuiter:
but I just can't figure out how you conclude that by looking at the indexer log.

2010-12-15 15:57:35.4375    9    Info    BibleIndex    (Timed) Indexing LLS:KJV1900
...

2010-12-15 16:01:39.5937    7    Info    BibleIndex    (Timed) Indexing LLS:LGNTI
...

2010-12-15 16:03:55.4375    7    Info    BibleIndex    (2m 15.8s) Indexing LLS:LGNTI
2010-12-15 16:03:55.4375    7    Info    BibleIndex    (Timed) Indexing LLS:LLXXI
2010-12-15 16:04:17.4687    7    Info    WindowsIndexerProgress    30 of 148 resources indexed; total progress is 15.0%
2010-12-15 16:04:19.6875    9    Error    Program    Unhandled exception:

The error occurred on thread 9  and the last program that started (Timed) there was KJV1900. If it had finished there would be a time like (2m 15.8s), which is how I know that LGNTI finished.

Aha! I didn't realize those were thread designations (not that I had any other idea about what they were).

Thanks!

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 2
Curtis A. Tilton | Forum Activity | Replied: Fri, Dec 17 2010 9:31 AM

OK, I have the same problem as others.  Everytime I start Logos 4 it starts, but never completes, indexing.  I have tried the "update resources" and deleting the KJV1900 files mentioned above.  They do not re-download and I continue to not be able to complete the indexing process.

The crash text file shows an error, "Error ID: 7249
Error detail: IndexingException: No translation word for specified document position"

Can you help?

0815.Logos4.log

4456.Logos4Indexer.log

8666.Logos4IndexerCrash.txt

Thanks.

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Fri, Dec 17 2010 10:07 AM

Curtis A. Tilton:

OK, I have the same problem as others.  Everytime I start Logos 4 it starts, but never completes, indexing.  I have tried the "update resources" and deleting the KJV1900 files mentioned above.  They do not re-download and I continue to not be able to complete the indexing process.

The crash text file shows an error, "Error ID: 7249
Error detail: IndexingException: No translation word for specified document position"

Can you help?

Okay, following Dave's guidelines, it looks to me like the problem is with the NKJV (LLS:1.0.30). Try deleting that, as you did the KJV1900 and restart L4 to download it again.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Dec 17 2010 10:17 AM

Rich, I think the error is in thread 7 which is attempting to index  LLS:1.0.71 which is the NASB95. Otherwise I'd do as you said.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Fri, Dec 17 2010 10:20 AM

Mark A. Smith:

Rich, I think the error is in thread 7 which is attempting to index  LLS:1.0.71 which is the NASB95. Otherwise I'd do as you said.

AARRG! You're right! I must have been dislexic or something. Those two lines are one above the other. Yes, the NKJV finished. It then started the NASB95. [Heavy sigh -- I'll get it right yet.]

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 1134
Juanita | Forum Activity | Replied: Fri, Dec 17 2010 10:56 AM

So, Rich, Mark, or Dave,

What causes these resource files to make indexing not work as it is supposed to?  I'm no geek but would like to understand a little better.  Thanks!

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Dec 17 2010 11:01 AM

Joan Korte:
What causes these resource files to make indexing not work as it is supposed to?

I don't know. There must be a minor corruption in the file which doesn't affect its display or other use in Logos. Since the resources are tagged for certain things to be indexed it is probably something in that part of the data that gets messed up. Just guessing.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 1134
Juanita | Forum Activity | Replied: Fri, Dec 17 2010 11:10 AM

Maybe I am going to sound like the kid who keeps asking why? Angel so why would my files not be corrupt, too?

 

Posts 2
Curtis A. Tilton | Forum Activity | Replied: Fri, Dec 17 2010 12:17 PM

Thanks to all.  That seems to have fixed it.  I deleted NASB95, then typed, "update resources" in the command window.  It downloaded some updates and then I restarted Logos and got the reindexing message.  However, this time it seems to have finished and I restarted the program with no further indexing messages.  Thanks again.

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Dec 17 2010 12:57 PM

Joan Korte:
so why would my files not be corrupt, too?

Apparently it happens on individual hard drives, not with the resource from Logos. Something must cause a bit to get dropped some time on one's hard drive and that does it. Again, I'm making a guess, but I'm sure it does have to do with the locally stored resource or we'd all have the problem.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Dec 17 2010 12:58 PM

Curtis A. Tilton:
However, this time it seems to have finished and I restarted the program with no further indexing messages. 

Good. Thanks for getting back to us and affirming the solution worked.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 24923
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Dec 17 2010 4:22 PM

Mark A. Smith:
Apparently it happens on individual hard drives, not with the resource from Logos.

It only happens on Reverse Interlinears and the resource sometimes appears to finish indexing after the crash! I'm puzzled why everybody doesn't get it. Anyway, I created a wiki bug report to get Logos involved with this issue.

Dave
===

Windows & Android

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Dec 17 2010 8:34 PM

Dave Hooton:
It only happens on Reverse Interlinears

And hasn't it been mainly two of them: the 1900 KJV and the NASB95?

Pastor, North Park Baptist Church

Bridgeport, CT USA

Page 1 of 2 (40 items) 1 2 Next > | RSS