BUG: Text in resource disappears

Page 1 of 2 (27 items) 1 2 Next >
This post has 26 Replies | 4 Followers

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Posted: Thu, Feb 3 2011 5:46 PM | Locked

GNT Byz changed Scripture reference, and all text disappeared except a portion of the first line. If I switch to a different tab in the same panel and then switch back, the text usually reappears, but not always. In those cases when it does not, I switch to another linked pane and scroll down and back to the initial reference. All text reappears in Byz. This is a fairly consistent phenomenon.

4024.LogosLogs Jack Caviness 20110203-204615.gz

Posts 524
Stuart Robertson | Forum Activity | Replied: Fri, Feb 4 2011 6:24 AM | Locked

I've had the same problem on and off... thought I might have a hardware problem, so I'm glad to hear someone else has the same issue.  Incidentally, while running Beta 5 I've twice had my Macbook "hang" completely - both times after the text had disappeared in a resource (ESV, in my case)... I tried scrolling up and down, and then when I Cmd+Tabbed away from Logos the main screen's video was corrupted, following which the machine was completely hung -- Cmd+Opt+Esc did not work, etc.  Had to hold down power button to reboot.  This hasn't happened (so far) with Beta 6, but I have had the problem described above with beta 6

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Feb 4 2011 2:58 PM | Locked

Jack ~  I've submitted your report and log to development.

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Feb 4 2011 4:28 PM | Locked

Melissa Snyder:

Jack ~  I've submitted your report and log to development.

Thank you, kind lady. This has happened with other resources also. I have not determined a pattern as it seems rather random to me. Hope the logs provide some insight.

Posts 10
Steve Treichler | Forum Activity | Replied: Sat, Feb 5 2011 7:02 AM | Locked

Yes, this is happening to me ever since the newest Beta was downloaded this last week (Logos Bible Software 4.2a Beta 6 (4.21.4.9959)).  It is quite annoying, to be honest.  The text will disappear, but if I scroll down and then back up, it will reappear for awhile.  It happens in any resource (Bible, commentary, etc.).  I would love a fix on this, as it is making Logos 4 almost unusable for me.

Thanks,

Steve

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Feb 5 2011 7:43 AM | Locked

Steve Treichler:

Yes, this is happening to me ever since the newest Beta was downloaded this last week (Logos Bible Software 4.2a Beta 6 (4.21.4.9959)).  It is quite annoying, to be honest.  The text will disappear, but if I scroll down and then back up, it will reappear for awhile.  It happens in any resource (Bible, commentary, etc.).  I would love a fix on this, as it is making Logos 4 almost unusable for me.

Sounds like a repeatable condition - please restart Mac, then open Logos 4.2a Beta 6, repeat some annoying resource behavior, capture screen shot, close Logos, compress logs and post screen shot and log file archive.  Wiki has links for Logos Log scribe and screen shots  => http://wiki.logos.com/Mac_Troubleshooting#How_to_Report_Bugs_in_Logos_4_Mac

 

Apologies - unable to replicate - do have a visual filter turned on to highlight Greek morphology (e.g. display imperatives with fire - red text with yellow background).

 

Also noticed scrolling with filter on quite responsive on an older 2.4 GHz Intel Core 2 Duo iMac Geeked

Keep Smiling Smile

Posts 10
Steve Treichler | Forum Activity | Replied: Sat, Feb 5 2011 8:07 AM | Locked

Okay, so now it is not doing it at all!  I did a restart - a couple of them to be exact - just to clear things from memory.  I had tried this before to no avail.

I also emptied the trash, which had the old version of Logos in it.

For the life of me, I cannot get it to not work any more.  It was doing this "text disappear" not sporadically at all, but very, very regular.  However, it is now gone.

So, check your trash.  Is the old program in there?  Empty it.  Could that have fixed the issue?

Glad it works now!

Steve

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Sat, Feb 5 2011 11:27 AM | Locked

Steve Treichler:
So, check your trash.  Is the old program in there?  Empty it.  Could that have fixed the issue?

My trash stays empty. I don't like a messy-looking trash can—except the one sitting by my desk Geeked

I will try the restart, however.

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Sat, Feb 5 2011 12:03 PM | Locked

Jack Caviness:
I will try the restart, however.

After restart, the disappearing text occurred once in BDAG, but I did not see the blank area until I had double-clicked a word in the Greek Byzantine text which forced a redraw of the pane. I was working on a Sentence Diagram on the right-had display (Dual displays). When I shifted the cursor to the Greek text in the upper left of the Left-hand screen, I passed over BDAG. This apparently caused the text to disappear. This display fault is not consistent, nor can I cause it to happen at will. To me, this is just a minor annoyance which is quickly rectified by forcing a redraw of the affected pane. Hope the log will reveal something to the Dev Team.

8484.LogosLogs Jack Caviness 20110205-150036.gz

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Sun, Feb 6 2011 4:18 PM | Locked

This is beginning to become annoying. I was reading Jeremiah 36 from the ESV. My cursor was somewhere in the text I was reading. I moved the mouse slightly and all text in the ESV pane except the first line went blank.

2845.LogosLogs Jack Caviness 20110206-191342.gz

Posts 620
Jonathan | Forum Activity | Replied: Sun, Feb 6 2011 7:50 PM | Locked

Is this similar to your problem Jack? I am getting no text in my Anderson Forbes Hebrew Text. All i have are question marks appearing. See attached picture. 

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 10
Steve Treichler | Forum Activity | Replied: Sun, Feb 6 2011 8:27 PM | Locked

The problem is back for me again today as well.  Pretty annoying.  I'll try to send in screen shots and logs when I am able.

Steve

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Mon, Feb 7 2011 3:35 AM | Locked

Jonathan:
Is this similar to your problem Jack? I am getting no text in my Anderson Forbes Hebrew Text. All i have are question marks appearing.

It may be related, but the display is different. Could you post logs if it reappears. The first link in my signature contains instructions while the second link describes a utility that will automate much of the process.

Posts 620
Jonathan | Forum Activity | Replied: Mon, Feb 7 2011 5:32 AM | Locked

Well, I ran the Logos Log Script that you link to in your signature before I restarted Logos. After I restarted Logos I no longer experienced the missing text. However, I had restarted Logos multiple times yesterday and never got my text back. I'm not sure why its back this morning.

Since B6 I've had a lot of crashing while using note taking functions, syntax searches, opening various books. Almost every time I am doing something important it crashes.

Of course, I am new to the Mac and Mac Beta... I almost never experienced a crash or any problems with the PC Beta. Is the Mac Beta less stable or is it possible that my installation is somehow corrupt?

7384.LogosLogs Jonathan Wass 20110207-072522.gz

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Mon, Feb 7 2011 11:53 AM | Locked

Jonathan:
Is the Mac Beta less stable or is it possible that my installation is somehow corrupt?

The Mac beta 6 is rather stable for me. When you have a crash, it would be helpful if you reported it in a new thread along with your log files.

Posts 29
Michael Davis | Forum Activity | Replied: Thu, Feb 10 2011 1:33 PM | Locked

I hope someone at Logos is working on this problem because I haven't even been able to use the program due to the frustration it is causing me!???

Posts 10
Steve Treichler | Forum Activity | Replied: Sat, Feb 12 2011 7:23 PM | Locked

I have no idea how this can be possible, but the problem is worse and worse for me the more I use the new version.  I've tried restarts, empty trash, and many different 

Attached is a log.

Please fix!!  Hard to use it, as it is constantly erasing text!

 

Posts 10
Steve Treichler | Forum Activity | Replied: Sat, Feb 12 2011 7:25 PM | Locked

Oops, here's the screen shot and log:

5086.Logging.zip

Posts 4077
Melissa Snyder | Forum Activity | Replied: Thu, Feb 17 2011 11:19 AM | Locked

Michael Davis:

I hope someone at Logos is working on this problem because I haven't even been able to use the program due to the frustration it is causing me!???

Development is working on this.

Posts 10548
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Feb 17 2011 1:39 PM | Locked

Melissa Snyder:
Development is working on this.

Glad to hear that news. It's not a show-stopper, but it is annoying. I just click the scroll bar twice—once above and once below the current location. This forces a window redraw and leaves the resource in the same place. The text is then solid until I move in single line mode or scroll wheel.

Page 1 of 2 (27 items) 1 2 Next > | RSS