Printing Exporting Lexham Interlinear or Indented Outlines to Word

Page 1 of 1 (7 items)
This post has 6 Replies | 2 Followers

Posts 82
Joe | Forum Activity | Posted: Fri, Apr 8 2011 9:45 AM

Hi all,

I looked in the Wiki & Forums and saw all sorts of printing issues, but not this one - so sorry if I overlooked it somewhere but here's my problem.  Sad

When printing directly (CTRL+P then the Print button) a reverse interlinear (LGEINT) or clausal outline  (LCOGNT) there's no problem (other than the margin cutoff issue indicated by other posters). 

1.  However, when you go to the print/export menu (CTRL+P) and then try to (1) export it to a Word document or (2) copy to clipboard and then paste into a Word document etc...all of the INLINE display disappears and all you get, for example, is the Greek Text.  I'd like to export it to a Word document and keep the inline displays (i.e. english, lemma's, etc..) and proper indenting.

2.  Cut and paste: So, instead of going to the print/export menu (CTRL+P) I highlight, cut and paste it into Word but it loses all of its nice indentation which is important in Clausal Outlines.

Is there any way to print / export to Word all of the inline interlinear stuff and also keep the indentation?  Again, printing a page directly is no problem.  But I'd like to mark it up with some arrows, etc...for handouts.


Hope that all makes sense!

Joe

 

 

 

 

 

 

 

 

Posts 18867
Rosie Perera | Forum Activity | Replied: Sun, Apr 10 2011 11:50 PM

Sorry for the delay in response.

1) I confirmed that print/export then export to Word or copy to clipboard and then paste into Word removes all the inline display. This looks like a bug! I will report it.

2) However, I was able to select text in the resource and do a copy/paste from LGEINT to Word with no problem:

 

But you are right, this does not seem to work for Lexham Clausal Outlines. The layout into table rows is messed up (I've turned on table gridlines in Word so you can see the issue more clearly):

This is relatively easy to fix in Word:

A) To fix the first group of lines, first drag the right margin to resize the whole table width to give you more room to work in, then add a new column to the right of the rightmost  column by selecting it and choosing Insert Right from the Table > Layout panel in Word 2007+ (Or Table > Insert > Columns to Right if using older versions of Word). Then copy and paste the data from that extraneous column that wrapped around to a new line of the table into that new column you just created.

When you've done that, you can delete the extraneous wrapped bit by select it and doing Table > Layout > Delete > Delete Rows

B) To fix the indentation issues in subsequent groupings lines, just elect the entire table which is that grouping and press Ctrl+M to indent the whole kit and kaboodle:

Do a little more dragging around of column widths (left edge of second table block all the way to left to match up with the one above it, then next vertical bar over, then copy/past the text into the right cell so att ptc lines up. Then turn off gridlines and you've got it looking pretty much like it looked in Logos.

But...I concur that you shouldn't have to manually fix this up in Word afterward. Logos should get it right. I'll report this, too.

Posts 82
Joe | Forum Activity | Replied: Mon, Apr 11 2011 12:54 AM

Yup, that's what I got too...copy and pasting into Word works but I just have to manually adjust all the tabs etc...


Thanks for reporting this and looking into it!!

Much appreciated!  Smile

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Apr 11 2011 8:34 AM

Currently only manual copy and paste, print, and export to XPS are supported to get all the interlinear lines to display from an interlinear Bible. Export to RTF (to Word) will only bring over the surface text, and export to HTML will place all the lines all on one line. 

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Apr 11 2011 8:38 AM

Rosie Perera:
But...I concur that you shouldn't have to manually fix this up in Word afterward. Logos should get it right. I'll report this, too

I'll submit your report about the one table cell dropping to the next line.

Posts 82
Joe | Forum Activity | Replied: Mon, Apr 11 2011 9:52 AM

Melissa Snyder:

Currently only manual copy and paste, print, and export to XPS are supported to get all the interlinear lines to display from an interlinear Bible. Export to RTF (to Word) will only bring over the surface text, and export to HTML will place all the lines all on one line. 

Thank you.  Yes, on clausal outlines, the indentation is important so I thought I'd point that out.  It would be very helpful if inline displays could also be exported to RTF keeping the indentations....

Again, thanks!!

Joe

Posts 12
Germán Jabloñski | Forum Activity | Replied: Mon, May 11 2020 5:25 AM

Greetings, I would like to know what is the status of this error after 9 years. In html it continues to be exported, not as a table, but as a single line. And in word the long lines continue to be cut. Thank you!

Page 1 of 1 (7 items) | RSS