Libronix DLS\System\System\ActBar2.ocx

Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 24
James W Uhlmann | Forum Activity | Posted: Sun, May 8 2011 4:57 AM

Secunia Personal Software Inspector (PSI) 2.0 is reporting:

 

C:\Program Files\Libronix DLS\System\ActBar2.ocx, version 2.5.2.121

 

This program was detected as being End-of-Life, which means that the vendor no longer supports this program. It is strongly recommended that you upgrade to a newer version of this program or uninstall it from your PC.

 

  Is there an upgrade available? 

Jim 

 


Posts 5100
Forum MVP
Richard DeRuiter | Forum Activity | Replied: Sun, May 8 2011 8:14 AM

James W Uhlmann:
  Is there an upgrade available? 

If there is, you'd find it by running one of these scripts (not sure which ones). In fact, I'll give you all the scripts, since Libronix requires that you run them periodically to keep up to date. (Just change the "g" in "30gAutoUpdate" to the new letter, should a later release be offered.)

Update to latest version of LDLS (3.0g)
http://www.logos.com/media/update/30gAutoUpdate.lbxupd

Update LDLS Addins
http://www.logos.com/media/update/LogosAddinsAutoUpdate.lbxupd

Update LDLS DataFile types
http://www.logos.com/media/update/DataFilesAutoUpdate.lbxupd

Update LDLS Resources
http://www.logos.com/media/update/ResourceAutoUpdate.lbxupd

 Help links: WIKI;   Videos; Logos 5 FAQ (Phil. 2:14, NIV)

Posts 13194
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, May 8 2011 11:13 PM

Looking at my Libronix 3.0g configuration, noticed file version 2.5.2.121 in ActBar2.ocx properties.

Likewise noticed support for Active Bar 3.0 => http://www.datadynamics.com/Products/ProductOverview.aspx?Product=AB ended in 2009.

Keep Smiling Smile

Posts 3540
David Paul | Forum Activity | Replied: Mon, May 9 2011 10:09 AM

Richard DeRuiter:

James W Uhlmann:
  Is there an upgrade available? 

If there is, you'd find it by running one of these scripts (not sure which ones). In fact, I'll give you all the scripts, since Libronix requires that you run them periodically to keep up to date. (Just change the "g" in "30gAutoUpdate" to the new letter, should a later release be offered.)

Update to latest version of LDLS (3.0g)
http://www.logos.com/media/update/30gAutoUpdate.lbxupd

Update LDLS Addins
http://www.logos.com/media/update/LogosAddinsAutoUpdate.lbxupd

Update LDLS DataFile types
http://www.logos.com/media/update/DataFilesAutoUpdate.lbxupd

Update LDLS Resources
http://www.logos.com/media/update/ResourceAutoUpdate.lbxupd

Thanks for these links, Richard.

Posts 16732
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, May 9 2011 6:03 PM

James W Uhlmann:
  Is there an upgrade available? 

It is not necessary to seek an upgrade for a ocx or dll file as long as the program that uses them, Libronix, is still working. If you have v 3.0g and the fix for IE9 (see other threads on this topic) then you have the latest version of Libronix (because it is still supported).

Dave
===

Windows PC, Android phone

Posts 1
Gerry Fraser | Forum Activity | Replied: Thu, May 12 2011 3:22 PM
  1. According to the advisory the problem is with a third-party add-in to Libronix.  Libronix installs Active Bar 2.x by Data Dynamics.  The file in question is ActBar2.ocx found in the \Libronix DLS\System folder.
  2. Also according to the advisory the severity rating is at the lowest level (less critical).  I believe it's included because the vendor (Data Dynamics) long ago abandoned this product and it is listed as "end-of-life" which basically means it won't be updated.
Posts 24
James W Uhlmann | Forum Activity | Replied: Sat, May 14 2011 12:44 AM

Thank you one and all. I'll pass this on. Jim

Posts 84
George T. | Forum Activity | Replied: Mon, May 16 2011 9:31 AM

After reading the posts I set PSI to ignore ActBar2.ocx.  I guess it is either that or remove Libronix from my computer or continue to get an error.

God bless,
George T

Page 1 of 1 (8 items) | RSS