Free Tool: QuickLink

Page 4 of 5 (90 items) < Previous 1 2 3 4 5 Next >
This post has 89 Replies | 4 Followers

Posts 17
Rodger Allen Thompson | Forum Activity | Replied: Tue, Jun 7 2011 1:16 PM

Thanks for all your help!

Posts 1187
Ward Walker | Forum Activity | Replied: Tue, Jun 7 2011 2:35 PM

Interesting Mod!

Posts 17
Rodger Allen Thompson | Forum Activity | Replied: Wed, Jun 8 2011 8:50 AM

OK, this morning I am trying to use the Quick Link Helpers. I copied a panel to a new tab and it is unlinked I have a different panel linked to C. I clicked in the unlinked panel and then clicked the Helper C on my shortcut bar. Nothing happens. What am I doing wrong?

Posts 3578
steve clark | Forum Activity | Replied: Wed, Jun 8 2011 7:18 PM

Hi Rodger,

i have been out of town today and just got home. Could you look for the file QL_Logfile.txt in your Documents folder and attach it to a post here? That way i can get and idea of what was going on inside QL.

Thanks

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 3578
steve clark | Forum Activity | Replied: Thu, Jun 9 2011 7:54 AM

Hi Rodger,

There are 3 possible problems that come to mind. Please find the file i requested in the previous post and attach it to your reply. (you attach your file by clicking on the paperclip in the post editor).

Thanks

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 17
Rodger Allen Thompson | Forum Activity | Replied: Thu, Jun 9 2011 8:48 AM

Sorry it took me so long to get back to you. Here it is.1538.QL_Logfile.txt

 

Is this what you wanted?

 

Posts 3578
steve clark | Forum Activity | Replied: Thu, Jun 9 2011 9:52 AM

Rodger Allen Thompson:
Is this what you wanted?

Yes Sir this is exactly what i needed.

i see that when you had L4 up and clicked on the Helper App for C, that the book which L4 was linked with C was a dictionary or a book which uses Head Word. And the last unlinked book was the The Pillar New Testament Commentary: The Letter of James. Logos cannot link books with Head Words to books that use Bible scriptures. If you were to use Logos's link C to your Pillar's book, you would find that scrolling in either of the books will not produce scrolling in the other. This is a reasonable rule that Logos uses.

You can find out more by reading this short article in the wiki: What is Linking ?

So the short answer here is: QL Helper App was doing the best it could and realized that your unlinked book did not match the link type of the book which you had linked with C.

If you had double-clicked on the QL icon   you can see the status of the request made to QL as shown below.

 

Also something else you might want to understand about QL, is when using a commentary series (e.g. Pillars) that Logos for the time being does not support changing to other volumes via the API tools. In another words if you have a book linked with A and at Genesis 1:3 and your Pillar's volume is opened to James, then QL will be unable to reposition Pillar's to the volume on Genesis due to Logos not switching volumes when QL sends the navigation request to Logos.

EDIT: i have submitted a request to Logos for navigating within a series, see this post

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 17
Rodger Allen Thompson | Forum Activity | Replied: Thu, Jun 9 2011 1:54 PM

Thanks Steve. I obviously just need to get more experience with using this.

Posts 3578
steve clark | Forum Activity | Replied: Thu, Jun 9 2011 2:17 PM

Rodger,

Your are welcome Sir!

i hope that you find time to learn more about it and that it becomes useful to you. If you have other questions, feel free to add a reply and ask.

EDIT: for you and others, i have added a section to installing QuickLInk: Problems

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 140
Gerald Rodgers | Forum Activity | Replied: Wed, Aug 24 2011 6:02 AM

Hi Steve

It's me again. Have done a complete format of my HDD & installed Windows 7 Ultimate edition.

Tried to reinstall Quicklinks but to no avail/ Any ideas now as to what I might try? Thanks so much.

Gerald

Posts 3578
steve clark | Forum Activity | Replied: Wed, Aug 24 2011 3:13 PM

Hi Gerald,

No i don't have any new ideas. Did you install Logos4 fresh on your newly formatted drive? i would hope that a new install might resolve your conflict. To the best of my memory, on your system Logos4 is not starting the COM program which runs along with the normal Logos4 program. i never saw it loaded in Task Manager. Something is keeping L4 from starting that app.

 

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 140
Gerald Rodgers | Forum Activity | Replied: Thu, Aug 25 2011 3:50 AM

Hi Steve

Just to say I'm running the program on a brand new machine with Windows 7 so I would have thought the problems of the p0ast would have gone.

Have been trying your PBB  as well but running into problems too. Get to end of first section OK in that when I click on BibleVerse the dialog box opens. It's the second section where I can't get the to add the macros to the ribbon in Word 2010. Have followed instructions to letter but no success.

Kind regards

Gerald

Posts 140
Gerald Rodgers | Forum Activity | Replied: Thu, Aug 25 2011 10:45 AM

Hi Folks

Just to let you know Steve was able to help me get PBB & QL working on my new machine.

He's a genius! Thanks so much.

Gerald

Posts 3578
steve clark | Forum Activity | Replied: Thu, Aug 25 2011 2:10 PM

Thanks Gerald! i am not a genius just stubborn about getting things to work.

For those of you who are having problems with the QL Internet installation, i have added a Manual Installation section.

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 935
Rick Ausdahl | Forum Activity | Replied: Sat, Oct 1 2011 10:39 AM

I'm also having an install problem--similar to, but not quite the same as the problem posted by David Paul on May 31.  I tried without success to insert a copy of the error message window so have retyped the message.  It reads as follows:

Error:  Could NOT establish communications with Logos 4 COM.
Unable to cast COM object of type 'Logos4Lib.LogosLauncherClass' to interface
type 'Logos4Lib.ILogosLauncher'.  This operation failed because the
QueryInterface call on the COM component for the interface with IID
'{65E4082F-D64E-4566-876F-81AAAF44635D}' failed due to the following error:  No
such interface supported (Exception from HRESULT: 0x80004002
(E_NOINTERFACE)).

I've gotten the same error on two computers--a desktop running XP and a laptop running VISTA.  I get the error whether using the web install method or the manual install method and I get it whether Logos 4 is open or closed when doing the install.  I even uninstalled my firewall program on the VISTA laptop in an effort to rule out a conflict there.  The install module I'm using is L4 QuickLink.Application which I downloaded from the Quick Link web page Peter said should be used.

I never get a successful install message, but after attempting the install, there are entries for Quick Links in the Control Panel list of programs and in the Start Menu.  Just for kicks, I dragged the L4 QuickLinks shortcut from the start menu to the shortcut bar in Logos 4 and clicked on it from there, but got the same error message noted above when attempting the install.  If anyone else has encountered this error and found a solution, I'd love to hear about it.

Posts 3578
steve clark | Forum Activity | Replied: Sat, Oct 1 2011 11:30 AM

Hi RAusdahl,

Sorry to hear that you are experiencing this problem. As with those other few people who are having this problem, Logos4 is not starting it's other COM app. One of those who had the problem got a new laptop and installed Logos4 on it. Then he tried to install QuickLinks and it was successful. My guess is that there is something not properly installed in Logos4. The few users having this problem had different versions of windows, so the windows version is not the issue. i am guessing the re-installing Logos4 might resolve the problem, but this can be dangerous in that you might loose all your Notes/Clippings/Collections/etc. So i would Not encourage you to try this!

The way to tell if the COM app is running is to try and start QuickLinks and then look inside the TaskManager to see if the COM program for Logos is running beside the Logos.exe program.

My guess is that you will not find it running on your computer.

Again, sorry that QuickLinks is not working for you.

steve

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 935
Rick Ausdahl | Forum Activity | Replied: Sat, Oct 1 2011 7:37 PM

Hi, Steve.  Thanks for your reply.

I started Logos 4, clicked on the L4 QuickLinks shortcut there, and got the error message noted in my first post.  I then opened Task Manager and saw the same three QuickLinks and Logos 4 processes that I see in your post:  L4 QuickLink.exe, Logos4.exe, and LogosCom.exe.  When I close the QuickLinks error message window, the L4 QuickLink.exe process disappears, then a few seconds later the LogosCom.exe processe disappears.  So the Com process seems to be running at least while QuickLinks is active.

But please don't worry about it.  QuickLinks looks like a great little app add-on  for Logos 4, and I doubt it was your intention to spend all your free hours resolving user problems when you made it available to the community.   It is unfortunate I have the problem on both my machines, but such is life.  Perhaps the user requests for a similar feature in Logos itself will eventually get some attention.  If not, I guess I'll just have to try QuickLinks again when I'm able to upgrade my laptop.  Smile

Posts 3578
steve clark | Forum Activity | Replied: Sat, Oct 1 2011 7:54 PM

That is interesting.

Was Logos4 running and stable when you clicked on the QuickLinks shortcut to open it?

Or did you try to use QuickLinks to open Logos4?

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Posts 935
Rick Ausdahl | Forum Activity | Replied: Sat, Oct 1 2011 10:11 PM

Yes, Logos4 was running and stable when I clicked on the QuickLinks shortcut to open it.

i.e. I start Logos4.  It opens to my most recently used layout.  I can navigate and perform the normal functions without any trouble, I can go to the home page without any trouble, and I can access internet links from the home page without any trouble.  I had previously copied (dragged) the QuickLinks shortcut from the start menu to the shortcut area in Logos4, so I click on the shortcut from within Logos4.  If I open Task Manager before clicking on the QuickLinks shortcut, the only Logos/QuickLinks related process I see is Logos4.exe.  When clicking on the QuickLinks shortcut from within Logos, three things appear to happen at exactly the same time (i.e. I can't visually detect any chronological sequence to them).  The three things are:

  1. The error message window pops up.
  2. The L4 QuickLink.exe process appears in Task Manager.
  3. The LogosCom.exe process appears in Task Manager.

When I close the error message window (or click on OK button in the window), the L4 QuickLink.exe process disappears about the same time as the error window closes.  The LogosCom.exe process remains open for another 3-4 seconds, then it disappears.

Posts 3578
steve clark | Forum Activity | Replied: Sun, Oct 2 2011 12:30 PM

Well this is a new twist on QL not running properly. So now i have another mystery different than the others who cannot get QL to work....LOL. There is something in the OS or Logo4 which does not allow QL to connect with Logos's COM api.

i will have to think about this. Thanks for all the info that you have supplied!

QLinks, Bibl2, LLR, Macros
Dell Insp 17-5748, i5, 1.7 GHz, 8G RAM, win 8.1

Page 4 of 5 (90 items) < Previous 1 2 3 4 5 Next > | RSS
Copyright 1992-2015 Faithlife / Logos Bible Software.