L4 crashes when try to compile PBB resources

Page 1 of 1 (16 items)
This post has 15 Replies | 0 Followers

Posts 527
Ebbe Andréasson | Forum Activity | Posted: Wed, Jun 1 2011 3:26 AM | Locked

I've tried to compile PBBs from three different docx files. First one is saved as docx from LibreOffice and the two others is Word-files. Logos 4 crashes every time.

The docx file generated from LibreOffice seem to be compiled but it isn't:

Im running XP Prof SP3

Here is the log files: 3566.Logos4Crashes.zip

Posts 9147
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Jun 1 2011 7:12 AM | Locked

Hi Ebbe,

I think this is related to Rosie's post: CRASH: 4.3 Beta 6: Compiling PBB [with copyright symbol in the copyright line]; in both cases the metadata for the resource (author, title, copyright, etc.) contain Unicode characters. Please try spelling the words wrongly (in the PBB panel, not in the DOCX) by changing ä and å to a, etc., and see if that allows the resource to be compiled correctly.

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Wed, Jun 1 2011 8:08 AM | Locked

Bradley Grainger:
I think this is related to Rosie's post: CRASH: 4.3 Beta 6: Compiling PBB [with copyright symbol in the copyright line]; in both cases the metadata for the resource (author, title, copyright, etc.) contain Unicode characters.

I think I not have the same Error ID nr.

Bradley Grainger:
Please try spelling the words wrongly (in the PBB panel, not in the DOCX) by changing ä and å to a, etc., and see if that allows the resource to be compiled correctly.

I have tried this to. I have no unicode characters in the filename, path or in the metadata fields. But hav just produced a brand new crash: 4401.Logos4Crash.zip

Posts 2745
Bohuslav Wojnar | Forum Activity | Replied: Wed, Jun 1 2011 9:39 AM | Locked

I tried a few times and when I use the title etc. without the Non-English characters, it works well. With the proper Czech characters like ř č š, it crashes Logos.

Bohuslav

Posts 1660
SteveF | Forum Activity | Replied: Wed, Jun 1 2011 10:01 AM | Locked

Bradley Grainger:
contain Unicode characters

Has anyone determined whether using " " (quote marks" in the title is responsible for a crash?

7343.Logos4Crash.zip

after taking out Smart tags

after changing font to size 12

after taking quote marks out of title

after not putting in any copyright info at all

= still crashes.

7411.Logos4Crash (2).zip

EDIT Ihad missed one smart tag--after removing it there was my first successful compile. This is in Word 2007.

BUT: it removed all of my footnotes! [EDIT - this now appears in "known issues"]


I am now going to try to put back in the quotes and maybe change the font.

 

Regards, SteveF

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Wed, Jun 1 2011 1:43 PM | Locked

Bradley Grainger:
Please try spelling the words wrongly (in the PBB panel, not in the DOCX) by changing ä and å to a, etc., and see if that allows the resource to be compiled correctly.

Bradley. I don't know to try more regarding compiling PBBs. The only file displayed as "Last built Today" is the one with Unicode characters in the title.

My install path, data path and temp path contain the swedish special character ä. Could this cause the error?

Dump from crash log:

Install path: C:\Documents and Settings\Ebbe\Lokala inställningar\Application Data\Logos4\System\Logos4.exe
Data path: C:\Documents and Settings\Ebbe\Lokala inställningar\Application Data\Logos4\Data\pg5gqhgb.t1m
Free disk space: 260,817 MB
Temp path: C:\Documents and Settings\Ebbe\Lokala inställningar\Temp\

Posts 9147
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Jun 1 2011 2:14 PM | Locked

Ebbe Andréasson:

Bradley. I don't know to try more regarding compiling PBBs. The only file displayed as "Last built Today" is the one with Unicode characters in the title.

My install path, data path and temp path contain the swedish special character ä. Could this cause the error?

If you can compile some PBBs correctly, the problem seems likely to be with the specific DOCX files that are crashing.

To test if it is the metadata: "Edit" the PBB that does compile correctly, and use "Add File" to change its source document to the DOCX from one of the crashing PBBs. Compile it; does it work? If so, it's the metadata that's the problem; if not, it's the DOCX. If you're willing to share the document with us, that may help us reproduce the problem.

I'll let Tonya follow up with you regarding collecting the file and trying to reproduce the problem.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Wed, Jun 1 2011 2:20 PM | Locked

Bradley Grainger:
I'll let Tonya follow up with you regarding collecting the file and trying to reproduce the problem.

The best place to send your file (if you're willing to do so, of course) would be: logos4feedback@logos.com

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Wed, Jun 1 2011 10:52 PM | Locked

Bradley Grainger:
If you can compile some PBBs correctly

I can't compile any PBB correctly, Logos crashes every single time a try to compile. I have tried to compile different source files but no succed.

 

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Wed, Jun 1 2011 10:54 PM | Locked

Tonya J Ross:

Bradley Grainger:
I'll let Tonya follow up with you regarding collecting the file and trying to reproduce the problem.

The best place to send your file (if you're willing to do so, of course) would be: logos4feedback@logos.com

I have sent a bunch of files and some fresh crash logs. Wink

Posts 41
Thomas Arvidsson | Forum Activity | Replied: Thu, Jun 2 2011 12:20 AM | Locked

Ebbe!

I´m trying to figure out why It crasches. I have two files from an old book, it crasches with one of them and not with the other.  /Thomas

 

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Thu, Jun 2 2011 5:55 AM | Locked

Thomas Arvidsson:

Ebbe!

I´m trying to figure out why It crasches. I have two files from an old book, it crasches with one of them and not with the other.  /Thomas

Are you using åäö in the metadata fields? (title, author, copyright). You can only a-z A-Z. This is one of the known issues so far with PBB.

 

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Jun 2 2011 9:19 AM | Locked

Ebbe and Thomas,

I received the files you sent; thanks gents!  And I was able to successfully build books using all of them.

So, we'll take a look at your logs, Ebbe.  And if you could also post logs Thomas, then we can look at those as well.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Jun 2 2011 1:26 PM | Locked

Ebbe Andréasson:

My install path, data path and temp path contain the swedish special character ä. Could this cause the error?

Dump from crash log:

Install path: C:\Documents and Settings\Ebbe\Lokala inställningar\Application Data\Logos4\System\Logos4.exe
Data path: C:\Documents and Settings\Ebbe\Lokala inställningar\Application Data\Logos4\Data\pg5gqhgb.t1m
Free disk space: 260,817 MB
Temp path: C:\Documents and Settings\Ebbe\Lokala inställningar\Temp\

We've determined that this might be the issue.  You may want to try moving a document file to a location on your system that does not have any Unicode characters in the file path (like simply putting it right on the C:\ drive) and then seeing if that will allow you to successfully build a book.

That issue has already been resolved and the fix should be included in the next Beta update.  

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Thu, Jun 2 2011 2:38 PM | Locked

Tonya J Ross:
You may want to try moving a document file to a location on your system that does not have any Unicode characters in the file path (like simply putting it right on the C:\ drive) and then seeing if that will allow you to successfully build a book.

I've tried this earlier but with no success.

Tonya J Ross:
That issue has already been resolved and the fix should be included in the next Beta update.

Thanks!!! And next Beta update is two weeks away as usual?

Posts 527
Ebbe Andréasson | Forum Activity | Replied: Wed, Jun 8 2011 2:40 AM | Locked

Now I can compile PBBs without crashes but have got new problems: http://community.logos.com/forums/t/34237.aspx

Page 1 of 1 (16 items) | RSS