Bug/Error? Visual Filter Hebrew Characters changed to display '?' in a box.

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 159
Dennis Audet | Forum Activity | Posted: Thu, Jun 23 2011 10:35 AM

Here is my Visual Filter -

 This is the result I get applying a Visual Filter on the ESV for the word Lord using the Hebrew Lemma יהוה and the AFHM.

The Hebrew characters are changed to ? in a box. Psalm 24:3

 

I have tried various configuration of styles and the Hebrew letters are allways changed to a question mark in a box, one for each character.

I've tried doing a search in the Wiki and the forums for this issue with no joy.

My Hebrew characters display fine in my Hebrew text, Interlinears, and Reverse Interlinears.

Can anyone please assist me in resolving the Visual Filter display issue.

For the glory of God alone.

Thanks.....

Living in the Fruit of the Spirit! Big Smile

For the glory of God alone! Yes

Posts 5615
Todd Phillips | Forum Activity | Replied: Thu, Jun 23 2011 10:43 AM

Have you changed the default font to something other than the default?  If so, does changing it back help?

EDIT: I can reproduce your problem by selecting a different default font.  Some fonts will support the Hebrew characters and some won't.  Try using Arial if you want a sans-serif font--it worked for me (but the Arial Hebrew characters aren't that great).

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 159
Dennis Audet | Forum Activity | Replied: Thu, Jun 23 2011 11:01 AM

Todd,

The Font in the style is set to default. The size is at 100% and X2 superscript is selected. I get a similar result when superscript is deselected.

The Label Text BEFORE is default at 100% for the Hebrew characters.

My Program Settings wrt text follows:

 

Living in the Fruit of the Spirit! Big Smile

For the glory of God alone! Yes

Posts 5615
Todd Phillips | Forum Activity | Replied: Thu, Jun 23 2011 11:36 AM

The problem is that your Default Font is set to Calibri which doesn't support the character set.  Set it back to "Default" (or set it to Arial) and it should work.

EDIT.  I think the problem is that "Default" in the style just uses whatever you've set the Default to in the Program settings.  If you change the font in the style to one that supports Hebrew (like Arial or TimesNewRoman), then you can continue to use Calibri as the Program Settings default font.  I don't know how to force the style to use the Default-Default font (which is Athelas). Tongue Tied 

It would be nice if Athelas and Alber (the default sans-serif font) showed up in the Highlight style font chooser when you've chosen a different default font in the Program Settings.

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 159
Dennis Audet | Forum Activity | Replied: Thu, Jun 23 2011 12:45 PM

Todd,

Changing the Programs Settings Default Font to Default works, however it is a Serif font, I prefer a Sans Serif font. Fortunateky, there is a Default Sans Serif Font which also works. Ariel did work, however the rendition of the Hebrew characters was less than desirable.

Changing the Style font to Default Sans Serif and the Program Settings Default Font to Calibri did NOT work.

This is what I have now with a slightly different style:

with Program Settings:

 

Thanks for your help Todd!  Big Smile

Living in the Fruit of the Spirit! Big Smile

For the glory of God alone! Yes

Page 1 of 1 (5 items) | RSS