Logos 4 crashes when using the internet...

Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 6
Charls | Forum Activity | Posted: Fri, Jul 8 2011 5:57 PM

When I disable the option of using the internet, Logos is stable but as soon as I enable that option, give it less than a minute and it crashes. If I give it the comand 'Update Now'. It almost immediately crashes.

I am using a Laptop with 2Gb of memory.

 

I am using logos 4 4.0a SR-3 (4.01.3.5180)

 

Log files are attached below.

 

Kind regards

033755.Logos4.log

Posts 9138
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Jul 8 2011 7:47 PM

Charls,

The crash seems to occur during processing of metadata for a resource called RVI:LEBNT which I don't recognize but would guess has something to do with the Lexham English Bible. I wonder if you have just a Lexham English Bible New Testament only resource? Please check and get back. It might require we hide that resource and check Logos after that.

You do need to update to the latest version. Since you haven't been able to do it through updates I'd suggest you install the latest version directly. The link is below. Before you do that, please get back about the question above.

http://downloads.logos.com/LBS4/Installer/Logos4Setup.exe

 

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 25746
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jul 9 2011 3:38 AM

Mark Smith:
The crash seems to occur during processing of metadata for a resource called RVI:LEBNT which I don't recognize but would guess has something to do with the Lexham English Bible. I wonder if you have just a Lexham English Bible New Testament only resource?

The RVI is simply the Reverse Interlinear database for the NT of the LEB. I think the error will be corrected with the latest version of L4 (4.0a is 1.5 years old!) using the supplied link.

Charls,

It would also appear that Automatically Download Updates = NO as there would be a plethora of resource updates as well as a software update! You might want to consider allowing updates after updating the software, but be prepared for a download of 1 - 5 GB depending on your library.

Dave
===

Windows 10 & Android 8

Posts 8258
LogosEmployee

You're running Logos 4.0a, which was released 18 months ago. The bug that's causing the crash was fixed in 4.0b, so (as other posters have mentioned) you can fix this problem by updating to the latest version.

http://www.logos.com/downloads/logos4

Posts 6
Charls | Forum Activity | Replied: Sat, Jul 9 2011 2:31 PM

Will try running the installer at home. I am  at work and although I can access the internet from here I am behind a firewall so lots of my ports from work are disabled.

The reason I mention this is because if I run the Logos4setup.exe file [run as admin, of course], I get an error message saying that setup was unable to download a required file.

I will try to get the process started at home, give me another 24 hours for an update then I will tell you how I am progressing.

I also saw the problem that the log file had with my RVI:LEBNT.  That is not the only resource I have on Logos. I have lots of other books installed on here too.

 

 

Posts 25746
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jul 9 2011 3:11 PM

Charls:
The reason I mention this is because if I run the Logos4setup.exe file [run as admin, of course],

It does not require "Run as Administrator" even for a non-Admin Windows user account. If you used that for the initial installation, though, you might require it now.

Dave
===

Windows 10 & Android 8

Posts 6
Charls | Forum Activity | Replied: Sun, Jul 10 2011 11:28 AM

Just ran it as admin because if Logos does not work I'll try anything before I get hold of you guys.

I ran the Logos4setup at home and it works now. It updates correctly from home. Will still update my resources later on in the week and keep you guys up to date but so far it looks good. It does have the latest Logos 4 software engine and it did not crash on me. It automatically indexed my Logos library as well. That took another 3-4 hours. Logos did not crash after this though.

To get a bit technical this exercise made me realize that although you can download the Logos4setup file from the net from work behind a firewall [anything from port 80 which Internet explorer uses] the installation files are downloaded onto your PC without a problem. When it tries to install and download further setup files from the Logos server, they obviously dont send it via port 80 hence it being blocked by the firewall at work thats why I could not update Logos from work.

 

Thanks.

 

 

 

Posts 6
Charls | Forum Activity | Replied: Mon, Jul 11 2011 2:38 PM

The Logos4update did the trick and that resolved the crashing problem.

I managed to update as well and have no further problems with my package.

The Logos version now on my PC is Logos 4.2b SR-1 (4.22.5.1109).

 

Thanks everyone for you help.

 

Page 1 of 1 (8 items) | RSS