Reinstalled Logos 4 - Resources Downloading VERY slowly

Page 1 of 1 (11 items)
This post has 10 Replies | 0 Followers

Posts 14
Russ Troester | Forum Activity | Posted: Sun, Aug 28 2011 1:45 PM

I've just reformatted my new MacBook Pro 13" and installed Lion (updated to 10.7.1) and I've been trying for the past 2 days to download my library and it is completely crawling. I've got Charter Cable Internet @ ~ 12Mbps. Hours go by and it's only downloaded a fraction of my resources (I have the Gold Library). I've been looking around the forums and web and haven't really found any help. I've got the latest release of Logos 4 Mac too (4.3 SR-2 4.30.0.1572). Any help would be greatly appreciated.

Posts 28028
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Aug 28 2011 2:54 PM

Rev. Russel - 

The downloads do take a while, but that seems particularly slow. Is it possible that Charter is throttling your internet speed? What time of day are you trying [generally, night is best] ? Are you doing anything else at the same time?

 

OSX & iOS | Logs |  Install

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 4:08 PM

Total it's about 5 GB of data so I would expect it to take at least a few hours, perhaps even overnight. But this has been ongoing for a couple of days. 

I've been monitoring the speed and after just 50-100MB it seems to throttle way down. If I stop then start the download again, it starts out normal then slows way down again. I've thought that perhaps Charter might be throttling my speed - but everything else seems fine (iTunes downloads, surfing, etc.). I haven't checked the speed later at night. It's been running pretty much continually for the last 48-60 hours.

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 4:20 PM

Oh, and to answer your other question - I'm not doing anything while downloading the resources aside from minimal web surfing. Speeds start out at about 1MB/s and slow way down to around 1KB/s.

Posts 28028
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Aug 28 2011 4:24 PM

It may be that Charter is throttling your connection to Logos. This is hard to prove, and I am not technologically qualified to help you with it. I have read about ISP's targeting specific users and/or websites (such as Netflix). It would seem unlikely to be the case here, but you never know. Your case does seem to be unusual.

OSX & iOS | Logs |  Install

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 7:56 PM

I think I may have figured out the problem. You asked earlier if I was running anything else and I said no but I do have CrashPlan installed and running for offsite backup. I thought since it was only my upstream that it wouldn't affect my download. I paused the backup and now the download seems more consistent and is going much faster. Previously once I'd hit around 200MB or so is when it seemed to tank. Right now I have a little over 2GB left and it's already hit 20% in about 5min time so I think we're in business.

Thanks helping me to think through this a little more. 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Aug 28 2011 8:42 PM

Observation: CrashPlan can affect Logos 4 Mac responsiveness.

Wiki Mac Troubleshooting => Slow Performance section includes:

Time Machine Backup configuration can exclude indexes that Logos 4 can rebuild – helps avoid slowdown discussed in forum Time Machine and Logos indexer DO NOT like each other! (also applies to online “cloud” backup software)

Keep Smiling Smile

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 9:22 PM

Well, it seems to have helped significantly for the initial download but it still hasn't completely resolved the issue. I've still had to cancel and restart the download process multiple times after it's tanked below 1KBps and sometimes even stopped altogether. So it seems there is definitely some correlation between CrashPlan and the slow download but even with it paused, I'm still have the problem of the download "stalling out". 

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 9:29 PM

Keep Smiling 4 Jesus :):

Observation: CrashPlan can affect Logos 4 Mac responsiveness.

Wiki Mac Troubleshooting => Slow Performance section includes:

Time Machine Backup configuration can exclude indexes that Logos 4 can rebuild – helps avoid slowdown discussed in forum Time Machine and Logos indexer DO NOT like each other! (also applies to online “cloud” backup software)

Keep Smiling Smile

Just to be clear, the issue I'm having is NOT general lack of responsiveness with the program itself (which is what's addressed in the article you referenced - although very helpful so thank you for that). The issue is my initial download keeps stalling out and I have to restart it every so often. 

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Aug 28 2011 9:38 PM

Rev. Russel J. Troester:

The issue is my initial download keeps stalling out and I have to restart it every so often. 

Logos 4.3 on Mac has resource download timeouts so anticipating many restarts needed => 4.3 Beta 13 Resource downloading (needed 3 restarts for 84 MB)

After Logos 4 Mac restart, nominally have less to download.  Option: can always enable Mac Diagnostic Logging then open Indexer.log file to monitor download progress (by default, console utility scrolls Indexer.log file as new lines are written).

Keep Smiling Smile

Posts 14
Russ Troester | Forum Activity | Replied: Sun, Aug 28 2011 9:47 PM

Keep Smiling 4 Jesus :):

Logos 4.3 on Mac has resource download timeouts so anticipating many restarts needed => 4.3 Beta 13 Resource downloading (needed 3 restarts for 84 MB)

Thanks for the info. I assume this means that this is a bug that still hasn't been fixed since it's still happening in 4.3 SR-2. Hopefully they'll get it ironed out soon. At least I know I'm not alone :)

 

Page 1 of 1 (11 items) | RSS