Page 1 of 1 (8 items)
This post has 7 Replies | 0 Followers

Posts 61
Shmuel Birnbaum | Forum Activity | Posted: Sun, Jan 29 2012 10:31 AM

I just downloaded the I Pad update and now every time I open up my Logos app, it crashes almost immediately.

Are others having this problem and what is the answer?


Posts 2047
Kenneth Neighoff | Forum Activity | Replied: Sun, Jan 29 2012 10:34 AM

Some are and some are not having it on start up.  Many are having it crash with syncing/  Logos knows about it and is working on a fix.

Posts 28688
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Jan 29 2012 10:55 AM

Shmuel - If you want some things to try:

  1. Delete the app completely.
  2. Re-download the app, but do not open it.
  3. Do a hard shut down (press and hold both buttons, then use the slider).
  4. After a minute, restart the device.
  5. Open the app, but DO NOT allow it to download anything (i.e. it will ask you if you want to download your bible. click cancel)
  6. Try to just let the app sync for a while. You can keep an eye on the spinning wheel. 

NOTE: deleting the app completely will also delete any downloaded resources. This may be necessary anyway, as one of the known issues states:

Dave Dunkin:
Media resources that had been downloaded must be removed and redownloaded

OSX & iOS | Logs |  Install

Posts 1416
Wes Saad | Forum Activity | Replied: Sun, Jan 29 2012 12:17 PM

My app was working fine until just now. Even got it to sync properly. Used it this morning without issue. Went to fire it up just now, and it's crashing for me as well.

Someone else mentioned turning on Airplane mode on the iPad, and sure enough, it's working now without crashing - but then you're offline. I tried launching the app with airplane turned on then once it launched turning off airplane. So far it's working without crashing... so far.

Posts 17
Jack H. Hughes | Forum Activity | Replied: Tue, Jan 31 2012 7:05 AM

I was having the same problem with my Ipad crashing, followed the steps above, and yet it didn't fix the problem. I cannot open the Logos app without it crashing instantly. I will wait until the next update. I have uninstalled it and installed the app three times and tried various things with no positive results. I know you are working on this.



Posts 1416
Wes Saad | Forum Activity | Replied: Tue, Jan 31 2012 7:10 AM


It started crashing for me, even in airplane mode. I believe it was trying to access a book I had not downloaded. What I had to do was as soon as I fired up the app, frantically tap the Library tab at the bottom. The app crashed anyway, but when I fired it up the next time, it opened to the library and I was able to avoid the crash.

So start in Airplane mode, launch the app, tap Library quick as you can, even if it crashes try firing up the app again and see if it works. Once it is running, you can turn off Airplane mode - just be careful which book is open in the Reading pane when you are through using the app, or you may have to repeat the frantic Library taps next time. :)

Posts 2047
Kenneth Neighoff | Forum Activity | Replied: Tue, Jan 31 2012 7:41 AM

Opening Logos app in airplane mode and then turning off airplane mode does not work for me, it tries to sync and into about a minute or so, crashes.

I have a few books I am working on that hhave been downloaded, but am hesitant to work much in them, if the fix will require that previous downloaded material be deleted first. That is just wasted effort. I know that one of the know issues was media could cause a crash, but I have not downloaded any media.

Posts 17
Jack H. Hughes | Forum Activity | Replied: Tue, Jan 31 2012 8:18 AM

I tried what you suggested and it worked -- kind of :-). I turned on Airplane mode, started the Logos app, went to Library. No crashes. Went to settings, selected NASB 95 update as favorite bible. Went to Library found that book and uploaded it. All was fine. Was able to read the Bible -- an important task in my life. However, I shut down logos and tried opening up the app again and had the same problems, repetitious instant crashing. However, i know how to bypass it with airplane mode until they get the bug fixed. 


Page 1 of 1 (8 items) | RSS