Bug: Library Scrolling/Browsing Going Haywire

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 620
Jonathan | Forum Activity | Posted: Mon, Feb 6 2012 8:54 AM | Locked

This morning I was attempting to scroll through my library to see what I owned. As I was scrolling from A-Z I began to experience a weird display issue just as I was scrolling through books whose names started with a B.

Here's a pic of what is happening:

It looks like books starting with "A" are getting superimposed over the books I was scrolling through that started with a "Bu..."

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 29925
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Feb 6 2012 9:01 AM | Locked

Jonathan - This happens to me as well from time to time. I think it is a known issue, but not one I have followed up on. Hopefully someone else will know more. 

macOS, iOS & iPadOS | Logs |  Install

Posts 10850
Forum MVP
Jack Caviness | Forum Activity | Replied: Mon, Feb 6 2012 12:59 PM | Locked

Jonathan

I cannot reproduce your garbled display. In fact, I cannot display Library as a pane. I can only get it to open in a floating window. Strange, I though that previously it could open in either a floating window or a pane. Surprise

Posts 620
Jonathan | Forum Activity | Replied: Mon, Feb 6 2012 1:04 PM | Locked

Jack Caviness:

Jonathan

I cannot reproduce your garbled display. In fact, I cannot display Library as a pane. I can only get it to open in a floating window. Strange, I though that previously it could open in either a floating window or a pane. Surprise

Have you tried both secondary clicking and dragging the library icon to get it into a pane?

 

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 29925
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Feb 6 2012 1:13 PM | Locked

Sometimes dealing with the library window is more or less a pane.

macOS, iOS & iPadOS | Logs |  Install

Posts 10850
Forum MVP
Jack Caviness | Forum Activity | Replied: Mon, Feb 6 2012 1:29 PM | Locked

Jonathan:
Have you tried both secondary clicking and dragging the library icon to get it into a pane?

Had tried keyboard shortcuts and right-click on the Go menu—Completely forgot about the little book on the toolbar Embarrassed Now I can display Library as a pane. However, I still cannot reproduce your garbled display.

L4 M 4.5a Beta 4

Mac OS 10.5.8 (I know stuck in the Stone Age, but it still works well for me, so why upgrade?) Still using XP for Windows—when I need extra frustration in my life Big Smile

Posts 1416
Wes Saad | Forum Activity | Replied: Mon, Feb 6 2012 1:59 PM | Locked

I've had the garbled text display as well.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Feb 9 2012 1:42 PM | Locked

I am unable to reproduce the issue on my machine or the test machine we have.  I don't see an active case for this sort of display error for the Library panel, so I will create one.  However, it can be difficult for the developers to track down the problem with only a screenshot to go on.  It might be useful to know more of the specs for your machine.

Also, it would be helpful to know if you can consistently reproduce the issue or if it is contingent on other factors.

Posts 620
Jonathan | Forum Activity | Replied: Thu, Feb 9 2012 2:07 PM | Locked

Tonya J Ross:

I am unable to reproduce the issue on my machine or the test machine we have.  I don't see an active case for this sort of display error for the Library panel, so I will create one.  However, it can be difficult for the developers to track down the problem with only a screenshot to go on.  It might be useful to know more of the specs for your machine.

Also, it would be helpful to know if you can consistently reproduce the issue or if it is contingent on other factors.

Here's a screenshot of my Macbook Pro mid-2010 "About This Mac" panel.

I do consistently get this problem in a one of three ways:

1. If I scroll through my resources slowly with my magic mouse (as if I am looking for some resource that I know I have, but I don't remember the name of it) I will usually (though not always) produce the problem after a long while of scrolling (I have 5,360 resources).

2. If I page through the resources by clicking on the bottom of the scroll bar it will always produce the issue. Especially if I am clicking through at approximately one-click per 0.5 seconds. I usually will get this problem by the time I reach the end of the books starting with "B."

3. If I very quickly click on the scroll bar, so as to page through the resources again, it really bogs down and produces this issue much faster/sooner.

My suggestion would be to try performing method 3. I would be surprised if it doesn't happen for you. Try to click fast enough that Logos keeps going after you've stopped clicking. If you do, I think you will find that once you stop clicking (and Logos keeps scrolling) that it will eventually develop the problem.

Syntax Searching Group | Michigan Logos Users | L5 FAQ | OSX 10.10 | 2.4 GHz i5 | 8 GB Ram

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Feb 9 2012 4:41 PM | Locked

Thank you Jonathan; I'll add those details to the case.  I retested it on every Mac we have in QA (much to the annoyance of my coworkers Smile) and still couldn't reproduce the issue.  I wonder if the others who can reproduce the issue are also on laptops?

Posts 29925
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Feb 9 2012 5:25 PM | Locked

Tonya J Ross:
I wonder if the others who can reproduce the issue are also on laptops?

I know that it happens on my MacBook Pro; I don't use my iMac nearly as much, but if I see this behavior I will report it. 

macOS, iOS & iPadOS | Logs |  Install

Posts 1432
Tonya J Ross | Forum Activity | Replied: Tue, May 8 2012 5:52 PM | Locked

This issue should be fixed in 4.5c Beta 1.  Please let us know if you continue to experience the issue once you have updated to 4.5c.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, May 18 2012 7:34 PM | Locked

Tonya J Ross:
This issue should be fixed in 4.5c Beta 1.

Concur about this issue being fixed in Logos 4.5c Beta 1 since unable to replicate.

Keep Smiling Smile

Page 1 of 1 (13 items) | RSS