Bug: Collection name failing to display when narrowing search

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 2279
Andy | Forum Activity | Posted: Sat, Mar 10 2012 6:09 AM

I have a collection entitled, 'Library excluding Perseus, Bibles, Lexicons and Commentaries'. I have noticed that when I try and restrict the search to this collection, the name of the collection fails to display (as per screen shot),

 

I have another collection with a similarly long name which produces similar results. I expect, therefore, that collection names over a certain number of characters fail to display. I appreciate that the collection name could be more succinct, but, nonetheless, I would expect at least an abbreviation of the collection name to display. 

The collection name displays correctly on the PC side.

I appreciate that this is a minor issue in the scheme of things, but a quirk is a quirk. And I have an aversion to quirks. Big Smile

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Sat, Mar 10 2012 8:00 AM

Andy Evans:
I have another collection with a similarly long name which produces similar results

As I know almost nothing about Logos4 Mac, I can only guess, but, if I were to guess, it would be that the issue is the commas. Some program components, particularly databases and database components, don't do commas well (they can be interpreted as field markers)-- and these titles are stored in a Logos4 database.

As an experiment, go into your Windows version and rename your collection, removing the commas. Give Logos time to populate the 'cloud' side of this, and see what happens on your Mac machine.

If that doesn't work, continue the experiment shorting the name to something like "All but Per Bib Lex and Com" and see if that works. If it doesn't the issue may be with the rules for the collection formation. I wouldn't even venture a guess on what the problem might be there.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Mar 10 2012 4:40 PM

Andy Evans:
I appreciate that the collection name could be more succinct, but, nonetheless, I would expect at least an abbreviation of the collection name to display. 

Using Logos 4.5b Beta 2, shrinking search panel width shows some quirkiness: initially, grey example disappears, then collection disappears:

Note: the minimum search panel width for this collection on Mac always shows grey example.  Personally learned when the collection name is shorter than grey example text, the collection name stays.

In contrast, when reducing search panel width using Logos 4.5b Beta 2 on Windows, the collection name is truncated a bit (at the end), then grey example disappears.  The minimum search panel width shows first word in collection.

Suspect behaviour is due to user interface differences between Mac and Windows.

Keep Smiling Smile

Posts 2279
Andy | Forum Activity | Replied: Sat, Mar 10 2012 11:51 PM

Thanks, Richard and KS4J.

I appreciate this is not a huge issue, but wanted to make sure that the developers were aware as I presume they will want to eventually get around to addressing this.

Richard, I tried your suggestion (changing the syntax), but it appears that this issue is related to the length of the collection name (as indicated by KS4J).

I will try shortening the collection name wherever possible, but this is not a huge inconvenience in any regard.

Thank you again for your kind responses.

Posts 1432
Tonya J Ross | Forum Activity | Replied: Mon, Mar 19 2012 4:35 PM

I am able to reproduce the issue and will make sure it has been reported to Development.  Thanks!

Posts 2279
Andy | Forum Activity | Replied: Tue, Mar 20 2012 12:03 AM

Thanks again, Tonya!

Posts 19176
Rosie Perera | Forum Activity | Replied: Tue, Mar 20 2012 12:11 AM

Andy Evans:
...a quirk is a quirk. And I have an aversion to quirks.

Great quote. I'm with you!

Page 1 of 1 (7 items) | RSS