Serious Bug: Logos 4.6 Beta 5 - app crashes when running textual searches from BWS

Page 1 of 1 (13 items)
This post has 12 Replies | 0 Followers

Posts 1880
Philana Crouch | Forum Activity | Posted: Thu, Aug 23 2012 3:21 PM

I am currently doing a study on gossip/slander. From 2 Corinthians 12:20 I ran a Bible Word Study on the lemma καταλαλιά it runs fine. I also ran a Bible Word Study on the lemma ψιθυρισμός. Both words are uses rarely in the New Testament and in the case of ψιθυρισμός only once.

When trying to run the textual searches from the bottom of the page the app crashes.

  • NT - Works fine
  • LXX - app crashes 
  • Pseudepigrapha - app crashes
  • Philo- no occurrences 
  • Apostolic Fathers - app crashes
  • Perseus Classics - app crashes 

Tried to search using just the search panel and still app crashes when searching the above works. I also tried on other Greek lemmas and the same pattern occurs. 

I am not sure what is causing this. 

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Thu, Aug 23 2012 3:41 PM

Philana Crouch:

I am currently doing a study on gossip/slander. From 2 Corinthians 12:20 I ran a Bible Word Study on the lemma καταλαλιά it runs fine. I also ran a Bible Word Study on the lemma ψιθυρισμός. Both words are uses rarely in the New Testament and in the case of ψιθυρισμός only once.

When trying to run the textual searches from the bottom of the page the app crashes.

 

  • NT - Works fine
  • LXX - app crashes 
  • Pseudepigrapha - app crashes
  • Philo- no occurrences 
  • Apostolic Fathers - app crashes
  • Perseus Classics - app crashes 

 

Tried to search using just the search panel and still app crashes when searching the above works. I also tried on other Greek lemmas and the same pattern occurs. 

I am not sure what is causing this. 

Searching ψιθυρισμός from the BWS panel works for me for LXX, Apostolic Fathers & Classics (using 4.6b5). (I don't have the Pseudepigrapha.)

Just to clarify: you can search via the BWS for the other term above, right?

It might be helpful to see some logs, to further diagnose, but I would suspect a corrupt index.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 1880
Philana Crouch | Forum Activity | Replied: Thu, Aug 23 2012 3:45 PM

I wondered, I will rebuild the index and see if that works.

Posts 1880
Philana Crouch | Forum Activity | Replied: Fri, Aug 24 2012 1:06 PM

I let L4 rebuild the entire index all night and it still crashes.

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Fri, Aug 24 2012 2:07 PM
Please enable logging by carefully following all the instructions in the link below: http://wiki.logos.com/Diagnostic_Logging Then run Logos and repeat the steps that caused the crash. Make sure to post all the log and txt files here for review. Here are the Wiki instructions for how to upload logs. http://wiki.logos.com/Uploading_Logs

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 1880
Philana Crouch | Forum Activity | Replied: Fri, Aug 24 2012 3:02 PM

Here are my logs. Hope they can help in troubleshooting.

6837.Logos Logs.zip

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Fri, Aug 24 2012 3:22 PM

Ah, you're using a Mac.

The log's are very difficult to read as compared to PC logs, but I note that the Logos4Crash.TXT is dated 7/29/12, which means something is crashing Logos without outputting the error code to the crash reporting system within Logos. What it looks to me like may be happening is the Logos is crashing while trying to write to the search pane, or when trying to update the layout. But I can only guess. Either way, what is being shown looks like a program issue (i.e. a bug), not an indexing issue.

Maybe someone with more experience working with Mac's can give a better answer.

BTW, since both Mac and Windows machines are posting to the same forum, it might be good to include "MAC" in the subject line, or at least in the body of the post. That way we can make sure we get the best people looking at the issue earlier.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 1880
Philana Crouch | Forum Activity | Replied: Sat, Aug 25 2012 7:14 AM

Thanks...yeah, I think it is a bug. It goes from the BWS opens the textual search in a search pane and then tries to search and crashes.

Posts 1880
Philana Crouch | Forum Activity | Replied: Mon, Aug 27 2012 1:54 PM

Bump

Posts 1880
Philana Crouch | Forum Activity | Replied: Tue, Aug 28 2012 8:42 AM

If any developers have a chance too look at my logs...is this a bug? Or do I need to reinstall Logos?

Posts 687
Jon | Forum Activity | Replied: Tue, Aug 28 2012 9:05 AM

I can replicate your crashes so it's presumably a bug rather than a problem with your installation.

I would also point out that the crashes aren't confined to searches run from Bible Word Study; I'm finding that opening a search window and running a Morphological search on a text other than the NT is crashing.

7446.Logging.zip

Posts 1432
Tonya J Ross | Forum Activity | Replied: Tue, Aug 28 2012 9:16 AM

Apologies! A case has already been created for this issue.  Martin was asking me about it yesterday, but I didn't realize no one has posted a response here yet.  
This issue should  be fixed in the next update.

Posts 1880
Philana Crouch | Forum Activity | Replied: Tue, Aug 28 2012 12:01 PM

Thanks...I just happened to be checking out two words that were used only once or twice in NT and wanted to check them out. I really appreciate the value of the various textual searches. I did notice that the textual searches in the BWS gave a count number, but crashed when opening. Also it did seem to work with the LXX but not the others...which was weird.

Page 1 of 1 (13 items) | RSS