Several BUGs in 4.6 RC1 "Import Word Lists" feature

Page 1 of 1 (20 items)
This post has 19 Replies | 0 Followers

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Posted: Thu, Aug 30 2012 3:47 AM

Here in Rosie's thread we discussed the meaning of the different fields, which is a design thing. However, it seems there are implementation bugs as well. To not confuse this, here a new thread with just the bugs I encountered:   

  • The command will import one or two L3 Vocabulary Lists, but not all (at least it didn't work for me). More specifically, it imported the ones I had made myself from L3 Word Lists or by simply entering words, but not the ones I imported from the Logos page some time back. 
    There's a workaround: make a meaningless edit to the L3 Voc list & rename it (maybe one of these or either will do, I did both to force L3 to a file save that tells L4 there's something new), close L3, do "Import Word Lists" again will bring the recently edited list. 
  • The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.
  • The imported lists get a "1" in the Count column instead of the number that was in the L3 list. This again needs to be fixed.

See the screenshot below, showing the vocabulary list for BBG after I "workarounded" it into L4, noting:

 

  • L3 displays the "display" column, not the lemma (which exists in the background), L3 has word frequency counts and sometimes several glosses per word, 
  • L4 gives lemma and display (the latter not for Vocab cards, see Rosie's thread), only one gloss and a count of 1.

 

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 23603
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Aug 30 2012 5:34 PM

NB.Mick:

  • The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.
  • The imported lists get a "1" in the Count column instead of the number that was in the L3 list. This again needs to be fixed.

Logos are all over the place when importing both Word Lists and Vocab Lists. I've made a couple of reports about other issues.

NB.Mick:
The command will import one or two L3 Vocabulary Lists, but not all (at least it didn't work for me). More specifically, it imported the ones I had made myself from L3 Word Lists or by simply entering words, but not the ones I imported from the Logos page some time back. 

I hadn't observed that. You should provide examples (I understand that you downloaded them from the Libronix page).

Dave
===

Windows & Android

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Thu, Aug 30 2012 11:18 PM

Dave Hooton:

NB.Mick:
The command will import one or two L3 Vocabulary Lists, but not all (at least it didn't work for me). More specifically, it imported the ones I had made myself from L3 Word Lists or by simply entering words, but not the ones I imported from the Logos page some time back. 

I hadn't observed that. You should provide examples (I understand that you downloaded them from the Libronix page).

Yes. I downloaded all the Greek ones some time ago and imported to L3. Now L4 upon "Import Word Lists" took all L3 Vocabulary Lists except those.

I made it import the "Basics of Biblical Greek" list by changing the name in the L3 list properties popup (took (Mounce) out) and the same workaround was needed for the "Now you can..." list, by taking "Vine's" from the title.

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 4800
doc | Forum Activity | Replied: Fri, Aug 31 2012 5:26 AM

These lists can be downloaded from here: http://www.logos.com/support/lbs/vocabularylists

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Aug 31 2012 6:11 AM

Andrew Mckenzie:

These lists can be downloaded from here: http://www.logos.com/support/lbs/vocabularylists

Yes. Since Rosie pointed to this site in her initial post in the linked thread, I didn't think of linking it again here, but it may help those who want to play with the Import Word List feature. I hope, Logos will update their import routine to get this right.

Right now I'm contemplating building a workaround. 

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 1432
Tonya J Ross | Forum Activity | Replied: Fri, Aug 31 2012 4:27 PM

NB.Mick:
The command will import one or two L3 Vocabulary Lists, but not all (at least it didn't work for me). More specifically, it imported the ones I had made myself from L3 Word Lists or by simply entering words, but not the ones I imported from the Logos page some time back. 
There's a workaround: make a meaningless edit to the L3 Voc list & rename it (maybe one of these or either will do, I did both to force L3 to a file save that tells L4 there's something new), close L3, do "Import Word Lists" again will bring the recently edited list. 

I have not experienced this issue either.  Given your workaround I'm not sure this is the issue for you, but it may still be worth noting that the 'Import Word Lists' command will import word lists from the Libronix DLS/WordLists folder and vocabulary lists from the Libronix DLS/VocabularyLists folder.  If you somehow get a word list file in the VocabularyLists folder it will not be imported, and vice versa.

NB.Mick:
The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.

I will make sure a case for this issue has been created.

NB.Mick:
The imported lists get a "1" in the Count column instead of the number that was in the L3 list. This again needs to be fixed.

I will make sure this issue has also been reported.

Thanks!

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Aug 31 2012 4:42 PM

Tonya J Ross:

NB.Mick:
The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.

I will make sure a case for this issue has been created.

NB.Mick:
The imported lists get a "1" in the Count column instead of the number that was in the L3 list. This again needs to be fixed.

I will make sure this issue has also been reported.

Thanks you!

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 186
Robert G. Mettler | Forum Activity | Replied: Sat, Sep 1 2012 5:38 PM

NB.Mick:

Dave Hooton:

NB.Mick:
The command will import one or two L3 Vocabulary Lists, but not all (at least it didn't work for me). More specifically, it imported the ones I had made myself from L3 Word Lists or by simply entering words, but not the ones I imported from the Logos page some time back. 

I hadn't observed that. You should provide examples (I understand that you downloaded them from the Libronix page).

Yes. I downloaded all the Greek ones some time ago and imported to L3. Now L4 upon "Import Word Lists" took all L3 Vocabulary Lists except those.

I made it import the "Basics of Biblical Greek" list by changing the name in the L3 list properties popup (took (Mounce) out) and the same workaround was needed for the "Now you can..." list, by taking "Vine's" from the title.

 

This is a also a bug in the latest stable release. I also had to rename the file in Libronix to get it to import into Logos 4. What a hassle.

EDIT: The rename changes  the file extension to a .lbxvl extension from .xml. This makes Logos 4 happy.

Posts 2862
Whyndell Grizzard | Forum Activity | Replied: Tue, Sep 4 2012 8:18 AM

Running Win 7 with latest release- cannot get "import word list" to work at all with any of the vocab list at http://www.logos.com/training/vocabularylists

I have managed to create other word list within L4- but none from L3 vocab list or word list

 

Posts 23603
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Sep 4 2012 4:15 PM

Whyndell Grizzard:
Running Win 7 with latest release- cannot get "import word list" to work at all with any of the vocab list at http://www.logos.com/training/vocabularylists

Command is import word lists

Have you followed the instructions for saving them in section 5?  You have to create the folders if necessary (note where there are spaces and NOT spaces).

Dave
===

Windows & Android

Posts 2862
Whyndell Grizzard | Forum Activity | Replied: Tue, Sep 4 2012 6:53 PM

Yes used plural 'lists'- and created folders- still no luck.

Posts 186
Robert G. Mettler | Forum Activity | Replied: Tue, Sep 4 2012 9:51 PM

Whyndell Grizzard:

Yes used plural 'lists'- and created folders- still no luck.

Whyndell,

Go to the folder where you downloaded the files and change the file extension from .xml to .lbxvl

or copy, or rename  the file with a .lbxvl file extension and try the import again. Logos is looking for that file extension not the .xml that is the downloaded files extension..

Robert

Posts 2862
Whyndell Grizzard | Forum Activity | Replied: Wed, Sep 5 2012 5:40 AM

Where do you change the file extension?

*** never mind took a little- but finally remembered how to do it- getting oldIndifferent

 

Posts 2862
Whyndell Grizzard | Forum Activity | Replied: Wed, Sep 5 2012 7:41 AM

I have the files in L4 now from http://www.logos.com/training/vocabularylists, but I do notice they have no audio available with them, if I copy the xml file to clipboard and then use WL-add-clipboard, they come up with audio, is this due to the difference between the xml and lbxvl file extensions?

 

Posts 186
Robert G. Mettler | Forum Activity | Replied: Wed, Sep 5 2012 12:49 PM

Whyndell Grizzard:
is this due to the difference between the xml and lbxvl file extensions?

 

I don't think so. I think it is the way that imports differ from the way that Logos 4 generates word lists from other sources and adds the audio to them.

The audio is not embedded in the .xml code.

You might also note that audio is not available in hebrew lists, since that audio has not been implemented in Logos4.

Robert

Posts 1432
Tonya J Ross | Forum Activity | Replied: Fri, Sep 7 2012 2:10 PM

Tonya J Ross:

NB.Mick:
The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.

I will make sure a case for this issue has been created.

This issue should be fixed in 4.6 SR-1.  I will add it to the release notes.

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Sep 7 2012 2:43 PM

Tonya J Ross:

Tonya J Ross:

NB.Mick:
The resulting L4 Word Lists contain only the first gloss instead of all of them - this may come from L3 separating with comma, L4 with semicolon - at least that's how I get it displayed. This needs to be fixed.

I will make sure a case for this issue has been created.

This issue should be fixed in 4.6 SR-1.  I will add it to the release notes.

I can confirm this is fixed. The word lists I imported in 4.6 SR-1 had the available glosses, as far as I can see (they still didn't have the count numbers - which you didn't promise, but this is probably the same section of code)

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 1432
Tonya J Ross | Forum Activity | Replied: Wed, Sep 19 2012 3:50 PM

Tonya J Ross:

NB.Mick:
The imported lists get a "1" in the Count column instead of the number that was in the L3 list. This again needs to be fixed.

I will make sure this issue has also been reported.

This issue should be fixed in 4.6a Beta 1.

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Sep 19 2012 4:03 PM

Tonya J Ross:
This issue should be fixed in 4.6a Beta 1.

Thanks a lot, looking forward to it!

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 9204
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Sep 21 2012 1:18 AM

NB.Mick:

Tonya J Ross:
This issue should be fixed in 4.6a Beta 1.

Thanks a lot, looking forward to it!

Update: can confirm this is fixed (using 4.6a Beta 2 as I didn't load Beta 1). Thanks!

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Page 1 of 1 (20 items) | RSS