Logos 4 crashes on startup in Mountain Lion

Page 1 of 2 (30 items) 1 2 Next >
This post has 29 Replies | 3 Followers

Posts 19
Vickie Weers | Forum Activity | Posted: Mon, Sep 3 2012 7:49 PM

when starting up, logos just crashes with a kernel exception.  353267.Archive.zip

Posts 1432
Tonya J Ross | Forum Activity | Replied: Wed, Sep 5 2012 7:35 PM

Vickie, all I see in your log is the stacktrace.  Do you have diagnostic logging enabled?  http://wiki.logos.com/Diagnostic_logging

Posts 19
Vickie Weers | Forum Activity | Replied: Wed, Sep 5 2012 7:51 PM

Yes, Logging is enabled.  It crashes immediately upon the icon bouncing in the tray, so I don't think it's even getting to a place where it would normally log something useful.  the sequence is click the icon, watch it bounce once and poof the crash screen. 

in the stack trace it appears there is a kernel exception seemingly thrown by mono when it tries to load a module of some kind.  i did a fresh download from the web site and told it to replace the app in the Applications folder, which usually replaces the whole package with downloaded files, but it still has the problem.

so, in my mind it seems one of the companion libraries is damaged, but i can't find which one it is and don't know how to get a fresh replacement even still.  it could also be some sort of damaged configuration of logos on my mac but again, not sure how to tell if the configuration is damaged.

thanks

Posts 19
Vickie Weers | Forum Activity | Replied: Wed, Sep 5 2012 8:19 PM

Here's the information from the popup (or the first half.  the second half looks like checksums of binary images...

 

Process:         Logos Bible Software 4 [17903]

Path:            /Applications/Logos Bible Software 4.app/Contents/MacOS/Logos Bible Software 4

Identifier:      com.logos.Logos_Bible_Software_4

Version:         4.60.2972 (61460.11.156)

Code Type:       X86 (Native)

Parent Process:  launchd [144]

User ID:         501

 

Date/Time:       2012-09-05 21:16:10.499 -0600

OS Version:      Mac OS X 10.8.1 (12B19)

Report Version:  10

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

Exception Type:  EXC_BAD_ACCESS (SIGABRT)

Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000ac801000

 

VM Regions Near 0xac801000:

    __OBJC                 00000000ac800000-00000000ac801000 [    4K] rw-/rwx SM=COW  /usr/lib/libobjc.A.dylib

--> Submap                 00000000ac801000-00000000ac802000          r-x/rwx process-only submap

    __IMPORT               00000000ac801000-00000000ac802000 [    4K] rw-/rw- SM=COW  /usr/lib/libobjc.A.dylib

 

Application Specific Information:

abort() called

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   libsystem_kernel.dylib         0x98fd8a6a __pthread_kill + 10

1   libsystem_c.dylib             0x9052bacf pthread_kill + 101

2   libsystem_c.dylib             0x90562508 abort + 168

3   libmono-2.0.1.dylib           0x00bde0cc mono_handle_native_sigsegv + 908

4   libmono-2.0.1.dylib           0x00b0ea5f mono_sigsegv_signal_handler + 351

5   libsystem_c.dylib             0x9051686b _sigtramp + 43

6   ???                           0xffffffff 0 + 4294967295

7   libmono-2.0.1.dylib           0x00b0e900 mono_sigill_signal_handler + 96

8   libobjc.A.dylib               0x952e0bda object_setInstanceVariable + 80

9   com.apple.AppKit               0x9681d461 -[NSNibOutletConnector establishConnection] + 486

10  com.apple.AppKit               0x967ef15f -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1002

11  com.apple.AppKit               0x967cd762 loadNib + 373

12  com.apple.AppKit               0x967ccb3a +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 233

13  com.apple.AppKit               0x9691d774 +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 154

14  com.apple.AppKit               0x967cc80f +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 709

15  com.apple.AppKit               0x967c8688 NSApplicationMain + 447

16  com.logos.Logos_Bible_Software_4 0x0000d40a start + 54

 

Thread 1:

0   libsystem_kernel.dylib         0x98fd90ee __workq_kernreturn + 10

1   libsystem_c.dylib             0x9052d04c _pthread_workq_return + 45

2   libsystem_c.dylib             0x9052ce19 _pthread_wqthread + 448

3   libsystem_c.dylib             0x90514cca start_wqthread + 30

 

Thread 2:: Dispatch queue: com.apple.libdispatch-manager

0   libsystem_kernel.dylib         0x98fd99ae kevent + 10

1   libdispatch.dylib             0x97ff5cc5 _dispatch_mgr_invoke + 993

2   libdispatch.dylib             0x97ff57fd _dispatch_mgr_thread + 53

 

Thread 3:

0   libsystem_kernel.dylib         0x98fd90ee __workq_kernreturn + 10

1   libsystem_c.dylib             0x9052d04c _pthread_workq_return + 45

2   libsystem_c.dylib             0x9052ce19 _pthread_wqthread + 448

3   libsystem_c.dylib             0x90514cca start_wqthread + 30

 

Thread 4:

0   libsystem_kernel.dylib         0x98fd90ee __workq_kernreturn + 10

1   libsystem_c.dylib             0x9052d04c _pthread_workq_return + 45

2   libsystem_c.dylib             0x9052ce19 _pthread_wqthread + 448

3   libsystem_c.dylib             0x90514cca start_wqthread + 30

 

Thread 5:

0   libsystem_kernel.dylib         0x98fd67d2 mach_msg_trap + 10

1   libsystem_kernel.dylib         0x98fd5cb0 mach_msg + 68

2   libmono-2.0.1.dylib           0x00c4f471 mach_exception_thread + 97

3   libmono-2.0.1.dylib           0x00de8808 GC_start_routine + 120

4   libsystem_c.dylib             0x9052a557 _pthread_start + 344

5   libsystem_c.dylib             0x90514cee thread_start + 34

 

Thread 6:

0   libsystem_kernel.dylib         0x98fd8c72 __semwait_signal + 10

1   libsystem_c.dylib             0x905b4a6d nanosleep$UNIX2003 + 189

2   libmono-2.0.1.dylib           0x00d897c8 collection_thread + 56

3   libsystem_c.dylib             0x9052a557 _pthread_start + 344

4   libsystem_c.dylib             0x90514cee thread_start + 34

 

Thread 7:

0   libsystem_kernel.dylib         0x98fd680e semaphore_wait_trap + 10

1   libmono-2.0.1.dylib           0x00dbc1d2 mono_sem_wait + 50

2   libmono-2.0.1.dylib           0x00c9a5a2 finalizer_thread + 114

3   libmono-2.0.1.dylib           0x00d64291 start_wrapper_internal + 641

4   libmono-2.0.1.dylib           0x00d64387 start_wrapper + 23

5   libmono-2.0.1.dylib           0x00dab05e thread_start_routine + 206

6   libmono-2.0.1.dylib           0x00de8808 GC_start_routine + 120

7   libsystem_c.dylib             0x9052a557 _pthread_start + 344

8   libsystem_c.dylib             0x90514cee thread_start + 34

 

Thread 0 crashed with X86 Thread State (32-bit):

  eax: 0x00000000  ebx: 0x9051684e  ecx: 0xbffff08c  edx: 0x98fd8a6a

  edi: 0xac09ba28  esi: 0x00000006  ebp: 0xbffff0a8  esp: 0xbffff08c

   ss: 0x00000023  efl: 0x00000206  eip: 0x98fd8a6a   cs: 0x0000000b

   ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f

  cr2: 0xac096144

Logical CPU: 0

 

Posts 28363
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Sep 6 2012 5:03 AM

Vickie Weers:
Yes, Logging is enabled.  It crashes immediately upon the icon bouncing in the tray, so I don't think it's even getting to a place where it would normally log something useful.

Vickie - Have you updated to 10.8.1? Also, have you tried to download the mac engine and reinstall a new copy over Logos (not an uninstall!)? You can download the engine here: Logos 4 Mac Installer

OSX & iOS | Logs |  Install

Posts 19
Vickie Weers | Forum Activity | Replied: Thu, Sep 6 2012 5:49 AM

My previous reply before the error message, I had said that I had the most recent update to Mountain Iion and had tried a fresh reinstall on my Logos.   

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Sep 6 2012 12:20 PM

Vickie, I showed your logs to a Dev and the problem isn't super obvious based on your logs.  I've asked Tech to have someone contact you to investigate the issue further.

Posts 19
Vickie Weers | Forum Activity | Replied: Thu, Sep 6 2012 3:31 PM

Okay, by phone or email?

Posts 1
Tiago Lopes | Forum Activity | Replied: Sun, Sep 9 2012 3:17 PM

Hi, I am having this same problem too. I already tried installing over the app, and tried uninstall and install next too. Still having those crashes.
I am leaving here my logging folder with the files, if you would be so kind to help.

Thank you.5582.Logging (Logos).zip 

Posts 3171
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Sep 11 2012 3:27 PM

Hello Tiago,

I will contact you offline about this. 

 

Posts 64
Sam Pedigo | Forum Activity | Replied: Thu, Sep 13 2012 12:01 PM

Not sure if this is the same problem but I can't open Logos either.  im on 10.8.1.   it was working fine then I did a shut down by holding down the power button.  after restart I can't get it to do anything.  just get a message that it shut down improperly last time.

Posts 64
Sam Pedigo | Forum Activity | Replied: Thu, Sep 13 2012 12:06 PM

what exactly does the reinstall do?

 

Posts 28363
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Sep 13 2012 1:25 PM

Sam Pedigo:
Not sure if this is the same problem but I can't open Logos either.  im on 10.8.1.

You need to post logs to find out. Wink

http://wiki.logos.com/Diagnostic_Logging#Mac

OSX & iOS | Logs |  Install

Posts 64
Sam Pedigo | Forum Activity | Replied: Thu, Sep 13 2012 1:48 PM

56422.Logging.zip

Posts 64
Sam Pedigo | Forum Activity | Replied: Thu, Sep 13 2012 2:28 PM

I went ahead and called in.  somehow my data got corrupted by shutting down while it was updating.  Anyway, he worked on it for a bit now am waiting for fresh download and indexing to finish.  I guess God wants me to watch LOST today and not work on sermon.  sweet.

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Sat, Sep 15 2012 9:20 AM

This appears to be a problem with 10.8.1; there are reports of Apple's own applications failing to launch in the same manner after installing 10.8.1. People have found success in getting their application to launch again by:

 

  1. Open Terminal
  2. Type sudo update_dyld_shared_cache -force
  3. Enter your password
  4. Reboot your machine

 

Mac Developer
Faithlife

Posts 13
Robert Davis | Forum Activity | Replied: Wed, Feb 20 2013 4:20 PM

I'm having the same problem here it looks like.  I upgraded to Mountain lion and now Logos 4 doesn't work.  I tried downloading the engine mentioned earlier in this feed but I still can't get logos 4 to open.  It crashes every time.

Posts 3171
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Feb 20 2013 4:29 PM

Can you get logs please?

http://wiki.logos.com/Diagnostic_Logging#Mac

 

Posts 28363
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Feb 20 2013 6:11 PM

Robert - Did you enable logging? Your logs are all old. Also, we need to see the logos.log

FYI - Logging isn't enabled by default. 

OSX & iOS | Logs |  Install

Page 1 of 2 (30 items) 1 2 Next > | RSS