Cannot Open Logos From Desktop Shortcut

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 4
Lee Parish | Forum Activity | Posted: Tue, Sep 11 2012 5:01 PM

Hello All,

I wish that my first message wasn't a cry for help, but so it is. I use Logos every day, but this morning I tried to open it and received this message: "the item logos4.exe that this shortcut refers to has been changed or moved." Logos worked perfectly yesterday so I tried a system restore to two days ago, no luck same message. I tried other means but no dice. To make a long story short, I am trying to fix this without a re-installation. Perhaps someone on here can tell me if that is possible. 

If you need any more information I will be happy to tell you as much as I know. I am far from a computer person though, so it might be limited by my ignorance. Anything you can tell me would be much appreciated!

Thank you so much,

Lee

Here is a Log File:

 

1447.Logos4Error.log

 

Posts 11076
Denise | Forum Activity | Replied: Tue, Sep 11 2012 5:11 PM

Lee ... your log file is from almost a year ago but appreciate it. And welcome to the forums.

To avoid a re-install as you say, first check what happened to your icon pathing.

On your PC using your file explorer, go to C:\Users\Lee\AppData\Local\Logos4\System\Logos4.exe and click on that and see if it runs. If it does, then you just need to delete the your desktop icon and copy / paste the shortcut from here to your desktop.

But I suspect you're missing the 'exe' program?

"I didn't know God made honky tonk angels."

Posts 4
Lee Parish | Forum Activity | Replied: Wed, Sep 12 2012 2:37 AM

Thanks for the reply DMB!

The pertinent Logs are at the end from 2012-9-11. I  tried going to C:\Users\Lee\AppData\Local\Logos4\System\Logos4.exe but it tells me that there is a problem opening Logos. I suppose that there has to be a corruption somewhere. I did not delete anything. I had to force restart my computer on Monday (9-10-12), and Logos was running then. I suspect that whatever happened, happened then. 

As to the 'exe' program - when I search C:\Users\Lee\AppData\Local\Logos4\System\Logos4.exe - it brings up Logos4.exe.config - If I click on it, "Logos4 has stopped working, Windows is checking for a solution to the problem"

I will upload the latest log file - Scroll down to the end and you will get stuff from yesterday and today. 

 

Thanks so much!

Lee

6740.Logos4Error.log

Posts 11076
Denise | Forum Activity | Replied: Wed, Sep 12 2012 6:45 AM

Lee ... looking at your file, I'm guessing you do not have the latest version of Logos4? It's saying your database version is newer than your software. Without the other log files I can't see which version you're on.

And since you can't start, you probably can't easily check.

In any event, your next best step would be:  http://downloads.logos.com/LBS4/Installer/Logos4Setup.exe and trying updating. Given your hard re-boot, after you update you might also re-boot again though not likely necessary.

Absent that, the forum experts will likely need you to do a formal logging (more files).

By the way I should have scrolled down the first file you uploaded! My non-thinking.

"I didn't know God made honky tonk angels."

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Sep 12 2012 6:53 AM

DMB:
Lee ... looking at your file, I'm guessing you do not have the latest version of Logos4?

Actually, go down to the last crash report and you'll see the version is the current version (4.60.0.2972).

DMB:
It's saying your database version is newer than your software. Without the other log files I can't see which version you're on.

I believe this often signals a corrupt database either on the local system or at the Logos server. In either case, this issue needs Logos customer support. Contact Customer Support at (800) 875-6467 (best, if an option) or by email: customerservice@logos.com

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 11076
Denise | Forum Activity | Replied: Wed, Sep 12 2012 7:00 AM

Thank you Richard!

"I didn't know God made honky tonk angels."

Posts 4
Lee Parish | Forum Activity | Replied: Wed, Sep 12 2012 7:10 AM

Thank you, Richard and DMB!

The first thing I did was send in a report to Logos Customer Service via email. I know that they are busy so I thought that I would see if anyone here could help me. I am awaiting a response from Customer Service and may call if necessary, but I do not want to be a pain and contact them twice. I am in the midst of a study that requires Logos so I hope that I can get this corrected in the next day or so, or else my research and my presentation will be less than it would be. 

Thank you both!

-Lee

Posts 8574
LogosEmployee

Richard DeRuiter:

DMB:
It's saying your database version is newer than your software. Without the other log files I can't see which version you're on.

I believe this often signals a corrupt database either on the local system or at the Logos server.

This specific message usually means that a more recent version of Logos has been run on this computer, then downgraded to an older version. This is not supported.

The most likely fix is to update to the latest version, Logos 4.6 SR-1: http://downloads.logos.com/LBS4/LDLS4Installer/Logos4Setup.exe

Posts 8574
LogosEmployee

Bradley Grainger (Logos):

This specific message usually means that a more recent version of Logos has been run on this computer, then downgraded to an older version. This is not supported.

And Logos 4 usually detects this at startup and displays a friendly error message telling you what to do (instead of crashing). I'm not sure why that didn't happen in this case.

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Sep 12 2012 8:10 AM

Bradley Grainger (Logos):
This specific message usually means that a more recent version of Logos has been run on this computer, then downgraded to an older version.

But, doesn't his log say he is running the latest version? Is there a new beta out I'm not aware of?

[Just trying to learn how to be helpful here. Not challenging your assessment.]

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 10771
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Sep 12 2012 8:21 AM

Lee Parish:
I use Logos every day, but this morning I tried to open it and received this message: "the item logos4.exe that this shortcut refers to has been changed or moved."

When I read this, I assumed Lee is one of the unhappy users of a buggy antivirus software that choose to flag Logos as malware these days (see a number of other threads).

The log entry with the corrupt db seems not to fit, but maybe the manual steps such as

Lee Parish:
I tried a system restore to two days ago, no luck same message. I tried other means but no dice. To make a long story short, I am trying to fix this without a re-installation.... I am far from a computer person though, so it might be limited by my ignorance.

corrupted the installation to a point where program and db are dis-associated.

Running Logos 8 latest beta version on Win 10

Posts 4
Lee Parish | Forum Activity | Replied: Wed, Sep 12 2012 8:55 AM

Bradley Grainger (Logos):

This specific message usually means that a more recent version of Logos has been run on this computer, then downgraded to an older version. This is not supported.

The most likely fix is to update to the latest version, Logos 4.6 SR-1: http://downloads.logos.com/LBS4/LDLS4Installer/Logos4Setup.exe

Bradley,

Not sure what the issue was or how it came to be, but this fixed it! - I am back up and running. Thanks so much!

I have run Logos for a year and this is the very first problem that I have had. You guys are great! Thank you for all your help.

-Lee

Posts 6613
Forum MVP
Lynden Williams | Forum Activity | Replied: Wed, Sep 12 2012 9:05 AM

Glad you're a happy camper once again Lee.

Lynden Williams Communications https://www.lyndenwilliams.net 

Posts 8574
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Sep 12 2012 12:22 PM

Richard DeRuiter:

But, doesn't his log say he is running the latest version?

His log said he was running 4.6. The latest version is 4.6 SR-1 (which introduced the DB change that was causing this crash at startup). It's atypical for a SR to change DB versions, but it did happen this time.

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Wed, Sep 12 2012 1:29 PM

Bradley Grainger (Logos):

Richard DeRuiter:

But, doesn't his log say he is running the latest version?

His log said he was running 4.6. The latest version is 4.6 SR-1 (which introduced the DB change that was causing this crash at startup). It's atypical for a SR to change DB versions, but it did happen this time.

My surprise is that my Logos install didn't update to SR-1. I tried "update now" and that didn't work. Then I tried "Set Update Channel to Default" and it updated. Interesting that it didn't update before, as I believe the update channel was set to default (though I might have set it to "stable" instead - could that account for it?).

EDIT: no update channel notification appeared on my "About" page.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Page 1 of 1 (15 items) | RSS