Personal Books crashing

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 203
Jackie Watts | Forum Activity | Posted: Sat, Nov 24 2012 8:46 AM

Every personal book I have is crashing in Logos (program closes). The only fix seems to be when I rebuilt the book,  But this means that my highlights are gone. Any ideas? (Using latest Logos 4 before moving to Logos 5 - on Mac 10.8.2 with 8GB of Ram)

Posts 10132
Forum MVP
NB.Mick | Forum Activity | Replied: Sat, Nov 24 2012 8:52 AM

Jackie Watts:
Every personal book I have is crashing in Logos (program closes).

This is strange. Can you enable Diagnostic Logging and post some logs here?

Jackie Watts:
The only fix seems to be when I rebuilt the book,  But this means that my highlights are gone.

This shouldn't be the case - the highlights should be retained through rebuilding the book.

Running Logos 8 latest beta version on Win 10

Posts 203
Jackie Watts | Forum Activity | Replied: Sat, Nov 24 2012 12:18 PM

HERE is the most recent crash.

 

Program Version: 5.0a (5.0.1.0220)

Time: 2012-11-24 15:16:33 -05:00 (2012-11-24T20:16:33Z)

Error building request (POST https://services.logos.com/v1/LicenseService.svc/compatibility).

System.Net.WebException: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Bad record MAC

  at Mono.Security.Protocol.Tls.RecordProtocol.decryptRecordFragment (ContentType contentType, System.Byte[] fragment) [0x00000] in <filename unknown>:0 

  at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 

  --- End of inner exception stack trace ---

  at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 

  --- End of inner exception stack trace ---

  at System.Net.HttpWebRequest.EndGetRequestStream (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 

  at System.Net.HttpWebRequest.GetRequestStream () [0x00000] in <filename unknown>:0 

  at Libronix.Utility.Net.WebServiceRequestBase`1[System.Xml.Linq.XElement].WriteRequestContentSync (System.Net.HttpWebRequest webRequest, IWorkState state) [0x00000] in <filename unknown>:0 

Posts 10132
Forum MVP
NB.Mick | Forum Activity | Replied: Sat, Nov 24 2012 12:40 PM

Unless some Mac wizards see the issue from your OS logs (maybe an access rights problem?), it may help if you'd follow the steps at http://wiki.logos.com/Diagnostic_Logging#Mac and upload the detailed Logos logs that really give a detailed record of what's going on.

Running Logos 8 latest beta version on Win 10

Page 1 of 1 (4 items) | RSS