Unable to install L4 - cannot access https://www.logos.com/login

Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 524
Stuart Robertson | Forum Activity | Posted: Mon, Nov 30 2009 1:57 AM

I apologize for cross-posting but I am somewhat desperate.  I am unable to install L4 on my home PC due to networking problems accessing logos.com via https (hence cannot log in).  I am open to any and all suggestions at present.  Below is my original post (posted to the 'General' forum):

------------------------------

I am at my wits end, having spent many hours over the last 2 weeks with my ISP and VOIP-provider trying to find out why I cannot log into logos.com from my home network - using either a browser (Firefox 3, Chrome 4 and Internet Explorer 6) and/or Logos v4.

The background to the situation is as follows:

  • From either my home network or office network I can access http://www.logos.com just fine (using browsers and Logos v4).
  • From my office network I can access https://www.logos.com/login fine, and thus browsers and L4 can log in.
  • From my home network all attempts to reach https://www.logos.com/login time out (neither browsers nor L4 can "reach" said URL but time out).

My ISP and VOIP provider (two separate companies) have had me disconnect both my home's wireless router and VOIP router and connect my PC directly to the ISP's cable modem and try all sorts of combinations.

Finally, after connecting my PC directly to the cable modem (with no routers between my PC and the cable modem), voila, I can access logos.com via https

The moment either one or both of the routers (wireless and/or VOIP) are between my computer and the cable modem I can no longer reach logos.com via https.  Interestingly, I can always access all manner of other sites (such as gmail, internet banking, etc.) via https with any network configuration - it's only www.logos.com that times out.

I know its a long shot but I have to ask... is there anything special about www.logos.com's HTTPS server that might cause this problem?

The only observation I've been able to come up with is that being behind a NAT (Network Address Translation) router might be making logos.com "unhappy".

Has anyone else run into this?  And can anyone from Logos comment and provide possible insight? 

It is truly strange that it is only logos.com that I cannot access via https (as I said, all other sites seem to work just fine using either http and https while I can only access logos.com using http when at home).

Hopefully,
Stuart.

Posts 24701
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Nov 30 2009 3:49 AM

A NAT router is no obstacle to HTTPS connections unless the router has some specific rule that effectively blocks that port. I work behind a cable modem and a NAT wireless router. Does it establish the correct protocols to connect to your ISP? Have you looked at the router's rules? Have you substituted another router for yours - it might be the best way to go after all the time you have invested in this.

Dave
===

Windows & Android

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Nov 30 2009 5:14 AM

Good suggestions... I have done the following:

  • Tried two different routers (DLink and Linksys WRT54)
  • Checked the routers' routing tables and filtering, with nothing out of the ordinary showing up and no filtering in place

As for 'does it establish correct protocols to connect to your ISP", I believe so.  Everything works correctly except connecting to https://www.logos.com.  I can connect to online banking, etc. using https and normal browsing is fine.  It is also not my laptop setup as L4 can log in when I'm on another network (such as office network or at Starbucks).

What has me scratching my head is that https works just fine except for logos.com.

It might be time to borrow a router from a friend and try again on another device.

I'm assuming from the lack of comments that no-one else has had any difficulty getting L4 to "log in"?

Posts 32
Pastor Johnny | Forum Activity | Replied: Mon, Nov 30 2009 5:55 AM

Having a NAT router should be no problem at all. I have been using such a configuration at my home for years with no problems reaching anything at the Logos site.

 

joh

Posts 8601
TCBlack | Forum Activity | Replied: Mon, Nov 30 2009 6:07 AM

Stuart, your situation is perplexing.  I've not suffered that problem however, I wonder if it's an issue with whatever DNS settings you are using at home vs work.

May I suggest a few experiments?

Problems like this with other addresses have lead me to DNS issues.

Test

This is more of a test than an experiment but....

open a command prompt (START>RUN type CMD and hit enter) on the troubled computer and  type:

tracert www.logos.com

That will let you see where the hangup is.  Of course the results are only useful if you understand the way the internet works - but once you start seeing bellingham routers show up  you know you're getting close.  When I ran this I saw cel1-xlink-to-pe2.bellingham.fibercloud.net...  that at least let's me know I'm getting to the neighborhood.

Experiment 1:

  1. Open a command prompt (START>RUN.  Type: CMD and hit enter)
  2. type the following without quotes:   "ipconfig /flushdns"  and hit OK.
  3. See if this corrects the login issues.  If not proceed to the second experiment.

Experiment 2:

Navigate to http://opendns.com There you will find directions for changing the DNS settings on your troubled system(s).  change your DNS settings appropriately in your router, flush the dns as above in your computer and then have another go using the OpenDNS DNS servers instead of your ISP DNS settings. 

Don't worry about OpenDNS, I've been using them for years now without a hitch - and better results than my local ISP as well.

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 170
Bob | Forum Activity | Replied: Mon, Nov 30 2009 6:16 AM

Again, I use a double NATed setup (router and nat inside of my MAC from windows via Parallel) and have no problems.  

 

My first inclination is to think that the link you are using is wrong.   If you get to the https: site via a bookmark the bookmark could be wrong (perhaps with an invisible embedded character or two).   

 

Are we talking about two different computers or are you bringing your laptop home?

Bob - 17" MBP quad 2.3GHz 4GB  and iMAC

Posts 687
Jon | Forum Activity | Replied: Mon, Nov 30 2009 6:42 AM

Hey Thomas, I was thinking DNS too, but he can access www.logos.com in a browser; my understanding is that that address should resolve to the same IP address whichever protocol is used? (and then is picked up by a different port...)

 

My only suggestion to add would be to set up a DMZ (demilitarized zone) for your computer in the router's settings; if that fixes the problem then its definitely something weird going on with NAT/filtering...

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Nov 30 2009 7:27 AM

Hi Thomas,

Yeah, I traced the route last night using tracert.  It doesn't appear to be DNS-related since I can reach http://www.logos.com okay (that is, www.logos.com resolves correctly (to 216.57.209.226).  And I don't the issue is a space in the link, because I first noticed when L4 couldn't log in at startup so I just ended up working offline thinking perhaps logos.com was stressed with the L4 release+download strain.

If I browse to www.logos.com that works fine (plain http).  Then, clicking on the Sign In link at the top right (which uses https) works fine from the office network and times out from my home network.

This happens using the same laptop (carried between work and home).

I'll try the OpenDNS suggestion (along with ipconfig /flushdns) this evening when I get back home.

 

Thank you all for the suggestions.

 

Posts 524
Stuart Robertson | Forum Activity | Replied: Fri, Dec 4 2009 1:43 AM

Interestingly enough, last night (without any changes to my home network setup at all) L4 was suddenly able to sign-in to logos.com (as was my browser).  All I can guess is that either something has changed with my ISP or with logos.com.  Anyway, I'm happily downloading and getting excited to see my workspace synchronize between my laptop and home computer.

Page 1 of 1 (9 items) | RSS