BUG: 5.0b RC-1: Footnotes not showing up on bottom of page for this resource

Page 1 of 1 (3 items)
This post has 2 Replies | 2 Followers

Posts 18672
Rosie Perera | Forum Activity | Posted: Tue, Jan 29 2013 2:41 PM

Open The Works of Reverend John Howe, Volume 1; go to page xv where there are some footnotes marked by a * and a †. You can hover over them and see the footnotes pop up, but if you turn on "Show footnotes on page" and go into paged view (1 column or more) the footnotes do not appear on the bottom of the page. Similarly, if you go into Print/Export you cannot see the footnotes on the bottom of the page in the print preview window, and they do not print or export.

One user reported this problem on UserVoice and thought it was because these footnote markers were not numerical. But I have a PB with non-numerical footnote markers and they export and print fine and show up on the bottom of the page in paged view. So it must be an issue with the tagging in this particular resource.

Posts 8022
LogosEmployee

I can reproduce this and have filed a bug.

Posts 576
LogosEmployee
Alan Palmer (Faithlife) | Forum Activity | Replied: Tue, Jan 29 2013 3:40 PM

The heuristic used to determine which footnotes are applicable to put in the on-page footnote currently is:

  1. superscript
  2. popup link to content in the same book
  3. not marked as a cross reference
  4. not marked as an abbreviation
  5. not already referenced in the on-page footnotes (prevent duplicates)

Interestingly enough, if the link in question meets #2-5 but not #1, you could try applying a visual filter to super script the character and it might then accept it as an on-page footnote.

 

Page 1 of 1 (3 items) | RSS