Logos 5 keeps crashing on my MAC

Page 1 of 2 (26 items) 1 2 Next >
This post has 25 Replies | 0 Followers

Posts 0
Jeff Lee | Forum Activity | Posted: Wed, Feb 27 2013 1:19 PM

Dear Logos,

Dont know what the problem is but every time I try to open Logos 5 it crashes and will not open.  I need this fixed ASAP as I am working on major Seminary papers right now.  Thank you for any help you can give!!!!

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 1:26 PM

Jeff - You have a couple of choices. You can call Logos customer service, or you can enable and post logs. Here is a link to the wiki: http://wiki.logos.com/Diagnostic_Logging

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 1:29 PM

If you decide to post logs, please use the paperclip icon to attach them. Let us know if you have troubles. 

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 6:26 PM

8468.CrashreportMac10.8.2.rtf

I dont know if this helps?  7824.CrashreportMac10.8.2.rtf

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 6:27 PM

Any help would be great, working on exegetical paper and need logos up and running quickly!  Thanks!!!  

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 6:31 PM

It will open up to the start page, but as soon as I do a search the whole program crashings and ends.  Sad

Posts 16644
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Feb 27 2013 6:48 PM

Jeff Lee:

Mac reports don't help. Please read http://wiki.logos.com/Diagnostic_Logging#Logos_5_for_OS_X  carefully and submit Logos logs.

Dave
===

Windows PC, Android phone

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 6:51 PM

Jeff - You will need to enable logging. The crash log you provided is from Apple… we need you to enable logging and provide Logos logs. The wiki link above explains how this is done… Let me give you the short version.

  1. Start Logos and immediately press and hold the command key. This will bring up the sign in box and enable logging for one session.
  2. One "trick" which can help in some situations (but probably not yours) is to check the "open to blank layout" box. 
  3. Allow Logos to crash. Grab the logs before you restart Logos.

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 13138
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Feb 27 2013 7:18 PM

Jeff Lee:

Any help would be great, working on exegetical paper and need logos up and running quickly!  Thanks!!!  

Tha Apple crash report shows current stable Logos 5.0b SR-1 version so have option to contact Logos.

Wonder if ~/Library/Application Support/Logos4/Logging folder has LogosError.log file ?

Note: ~ is an alias for your Library folder, which OS X has hidden by default => http://www.macworld.com/article/161156/2011/07/view_library_folder_in_lion.html

Keep Smiling Smile

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 7:25 PM

Took a look for the ~/Library/Application Support/Logos4 file is not in my library from what I can see.  Is this a problem? None programmer here lol!

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 7:33 PM

0143.LogosError.logAh!  Found it thanks!  Here are the Logos crash reports!  See what you think...8512.LogosCrash.txt

4760.LogosError-2.log

4137.Indexer.log

Posts 13138
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Feb 27 2013 7:34 PM

Jeff Lee:

Took a look for the ~/Library/Application Support/Logos4 file is not in my library from what I can see.  Is this a problem? None programmer here lol!

When Apple released Mountain Lion, the default visibility for ~/Library folder became hidden (to keep unfortunate surprises from happening since deleting OR changing stuff in ~/Library can be a bit problematic)

In Finder, can click Go menu => Go To Folder then Go To folder ~/Library/Application Support/Logos4

Link with Finder screen shots, which is the first way => http://www.macworld.com/article/161156/2011/07/view_library_folder_in_lion.html

Keep Smiling Smile

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 7:34 PM
  1. With the finder "go" menu selected, press and hold the option key. 
  2. The library, normally hidden, will appear. Select it. 
  3. Navigate to: Application Support / Logos4 / Logging
  4. Drag the logos.log to your desktop
  5. In a new post, attach the logos.log via the paperclip icon

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 7:35 PM

Jeff Lee:
Ah!  Found it thanks!  Here are the Logos crash reports!

Yes, but the most important is the logos.log. If there isnt one, its [edit: likely] because logging wasnt enabled.

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 7:39 PM

4705.Logos.log

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 7:43 PM

Good Jeff! SmileYes

It looks like you have a malformed database, but I am unsure about which one. Maybe KS4J will know more.

Libronix.Utility.Threading.AsyncWorkException: Unhandled exception in asynchronous work. ---> System.Data.SQLite.SQLiteException: The database disk image is malformed

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 7:51 PM

Thanks for the getting to this point with me alabama24!  I have to go to bed now (3:50am) here, hopefully get it working tomorrow.  Thanks so much!!!

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 7:53 PM

Glad to "help." Most likely you will need to delete a database file and let the software rebuild it. This could be a 2 minute fix, or a much longer one if it is your index database file. 

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 0
Jeff Lee | Forum Activity | Replied: Wed, Feb 27 2013 7:55 PM

I did try deleting logos 5 and then reinstalling, but it did not work.  Looks like I may have to do a full delete and full reinstall.  Just dont know how to delete the whole program.  

Posts 15918
Forum MVP
alabama24 | Forum Activity | Replied: Wed, Feb 27 2013 8:00 PM

Jeff Lee:
Looks like I may have to do a full delete and full reinstall.

Dont do that! Deleting the app from the applications folder is no big deal... 122 MB download. If you delete the rest of it, you will have to redownload all of your resources & do a full indexing all over. As I said in my last post, this could be a pretty simple fix... I just dont know which .db file to tell you to delete. 

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Page 1 of 2 (26 items) 1 2 Next > | RSS