Update Error!

Page 2 of 2 (35 items) < Previous 1 2
This post has 34 Replies | 2 Followers

Posts 2774
J.R. Miller | Forum Activity | Replied: Fri, Dec 18 2009 11:41 AM

Welcome Lloyd,

The best place to start is in the thread at the top of the forum that says, "Start Here"

The link is in my signature.

My Books in Logos & FREE Training

Posts 10
Tim Norman | Forum Activity | Replied: Sat, Dec 19 2009 1:35 AM

Ok - the logs should be here now

Sorry if they weren't attached before

 

1460.Archive.zip

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 9:41 AM

Is there a fix for this? The Bible Knowledge Commentary is missing from my Library (and probably some other resources). Have tried reindexing. Have tried the update resources command and experienced the same thing as Jack. Still missing the resource in my library6712.Archive.zip

Posts 698
LogosEmployee
Cameron Watters (Faithlife) | Forum Activity | Replied: Tue, Dec 22 2009 10:46 AM

Al Christopherson:
Have tried the update resources command and experienced the same thing as Jack.

After discussing it with Jack in another thread (the link escapes me at the moment) I think we established that if you do the following, all of the commands work correctly:

  1. type the command (e.g. "update resources", omitting the quotes, of course)
  2. wait for the list of suggestions to generate and then, click the suggestion

Pressing return will usually result in a search for the text you typed, which isn't what you want.

Director of Engineering for Enterprise and Operations

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 10:57 AM

Thanks. That is what I did...clicked the suggestion...however it did not appear to do anything and I still do not have the resource in my library.

Posts 698
LogosEmployee
Cameron Watters (Faithlife) | Forum Activity | Replied: Tue, Dec 22 2009 11:11 AM

Al Christopherson:

Thanks. That is what I did...clicked the suggestion...however it did not appear to do anything and I still do not have the resource in my library.

Give it a bit. It's going to verify that the resources installed on your machine match the latest versions you're licensed for. It sometimes takes a few minutes, and there isn't much, if any, feedback. After a minute or two, though, the little blue icon for the indexer (which actually does the work, if any needs to be done) should've appeared.

If it appears nothing at all has happened after 10 or 15 minutes, upload your logs. NOTE: don't restart the app multiple times after typing "update resources". If you do, your logs will be of little use.

Director of Engineering for Enterprise and Operations

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 11:47 AM

Selected "Update resources" at 1:25 my time...it is now approximately 20 minutes later...resource still missing. Didn't see any activity, but I don't really know how to read the logs. If I need to do something different, just let me know. Thanks.

 

2134.Archive.zip

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 2:43 PM

Tried it again...selected "Update resources" around 3:52 p.m. CST. No Bible Knowledge Commentary 50 minutes later. I don't believe the "Update resources" command is actually doing anything. I have the Bible Study Library. Here are the log files:

 

8400.Archive.zip

Posts 698
LogosEmployee

Al Christopherson:
I don't believe the "Update resources" command is actually doing anything.

It is. Unfortunately, it's not downloading the resource in question. Looking at the logs, there are a number of resource files (roughly 30) that appear to be corrupted in some fashion.

The good news is, we'll go through the logs and post a list here of the corrupted files and you can remove them. Then, running "update resources" will cause them to re-download, and you should be set. (NOTE: I wouldn't recommend removing all of your resources at this point, as that will result in a lot of needless download time for you.

The resource files that should be removed can be found in /Users/<your username>/Library/Application Support/Logos4/Data/<some random string>/ResourceManager/Resources

Here's the list:

  • ANCEGYPTNS01.logos4
  • AV1873NT.lbsrvi
  • AV1873OT.lbsrvi
  • BKC.logos4
  • BLINT01.logos4
  • BLINT02.logos4
  • BLINT03A.logos4
  • EASYFORUSAY.logos4
  • ESVOT.lbsrvi
  • HLMNCHRTSMAPS.logos4
  • HLMNILLBBLDICT.logos4
  • NASBOT.lbsrvi
  • NRSVOT.lbsrvi
  • NKJVNT.lbsrvi
  • 1000BBLIMG.logos4
  • BBLSTRY01.logos4
  • BBLSTRY04.logos4
  • BBLSTRY09.logos4
  • BRC.logos4
  • LBSINFOGRPHX.logos4
  • LBXHYMNMR.logos4
  • LIONINTNT.logos4
  • SCRTHOLY.logos4
  • ILLBBLTREAS.logos4
  • PPLBBLENCYC.logos4

If you'd be willing, too, could you upload your copy of SCRTHOLY.logos4 to this forum thread before you delete it?

Director of Engineering for Enterprise and Operations

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 3:11 PM

Thank you!

Posts 698
LogosEmployee

I've posted the list in my previous post, so you should be all set. Let me know if you have any other questions.

Director of Engineering for Enterprise and Operations

Posts 7
Al Christopherson | Forum Activity | Replied: Tue, Dec 22 2009 4:11 PM

Probably not what you want to hear but the file you asked me to upload was not in the Resources directory...neither were most of the files on your list (including the Bible Knowledge Commentary). After deleting the few that were in the list I opened Logos. When I selected "Update Resources" the blue icon appeared unlike the previous times and said it was download 78Mb. After the download completed I restarted Logos, it updated the library, but still no Bible Knowledge Commentary. It might be easier to start from scratch? If so, can you point me to the instructions for this? Thanks for your help.

 

Logs:  8867.Archive.zip

Posts 35
Lloyd Lee | Forum Activity | Replied: Tue, Dec 22 2009 9:06 PM

I've just tried what has been suggested to Al about clicking and leaving the command "Update resources" but have had no joy...

Now when I attempt to update the new updates to Logos 4, instead of just being told: "Update Error! An error occurred while extracting the archive. Please try again later", I am now additionally told "Update Error! Operation could not be completed. Bad address" before the previous update error alert. So now I have 2 error alerts when trying to update.

Any suggestions / solutions would be much appreciated!

Many thanks.

[View:http://community.logos.com/cfs-file.ashx/__key/CommunityServer.Discussions.Components.Files/75/3554.Archive.zip:550:0]

Posts 10
Oran Denton | Forum Activity | Replied: Thu, Jan 20 2011 1:18 PM

If you look at the icon for Logos in the dock (on the Mac) and see a lock, you will get the Update Error when you try to update the application. To fix this, go to Finder, go into applications, select Logos and then Get Info, select unlock, and then back out. Relaunch Logos and the lock in the dock will be gone, and so will the Update Error. Hope this helps!

Page 2 of 2 (35 items) < Previous 1 2 | RSS