BUG: Logos 5.1b (and earlier) doesn't respect language setting

Page 1 of 1 (5 items)
This post has 4 Replies | 2 Followers

Posts 275
Greg F | Forum Activity | Posted: Tue, Sep 24 2013 12:00 AM

Something that has been bugging me since the last couple of updates: I have "English" selected as my Language in the program settings, but all my menus continue to be in French.

I'm on a French computer, so I'm assuming Logos is using the default language of the operating system rather than the user defined setting (?), but I'd rather have my Logos menus in English.

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Wed, Sep 25 2013 11:35 AM

I am unable to reproduce this issue. What operating system are you using? Could you attach logs? See my signature if you need to enable logging.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 195
LogosEmployee
Seth Copeland | Forum Activity | Replied: Wed, Sep 25 2013 2:24 PM

Greg F:

Something that has been bugging me since the last couple of updates: I have "English" selected as my Language in the program settings, but all my menus continue to be in French.

I'm on a French computer, so I'm assuming Logos is using the default language of the operating system rather than the user defined setting (?), but I'd rather have my Logos menus in English.



If you're running in windows. I might know the cause of this issue. Something that you might try, is; from Windows Start Menu go to Control Panel > Clock, Language, and Region > Region and Language > Formats, and then see if the language format is set to english. If it is, try setting it to french, or another language, and relaunch the app.

If that fixes it we have a case that should prevent this problem in 5.2. If that doesn't we will probably need to see logs as suggested by Dylan.

Regards,

Seth Copeland

Logos SW Development

Posts 275
Greg F | Forum Activity | Replied: Wed, Sep 25 2013 2:39 PM

Just checked, my default language was set to English (US) in Windows. I tried switching it to French and voila, I got my English menus back in Logos. However, switching my Windows system default back to English brought back the French menus in Logos! ;)

English system = French menus in Logos.

French system = English menus in Logos.

I guess I'll send you guys the log files. ;)

Posts 195
LogosEmployee
Seth Copeland | Forum Activity | Replied: Wed, Sep 25 2013 4:43 PM

Greg F:
Just checked, my default language was set to English (US) in Windows. I tried switching it to French and voila, I got my English menus back in Logos. However, switching my Windows system default back to English brought back the French menus in Logos! ;)

Thanks for checking that, we've identified the problem and just committed a fix that will fix it for 5.2 beta 1.

For now as a workaround, you can leave your format in french, or if you launch logos from the command line (see this post http://community.logos.com/forums/p/74424/519918.aspx#519918), you can specify the language as en, and it should force it to work when launched in that way. If you don't want to have to launch from the command line every time, you could go into the registry, and change the key for specifying the language (see this post http://community.logos.com/forums/p/74424/519831.aspx#519831 right above the previous one), and change it from en, to some garbage language code (say, "qq", which isn't a valid language code, this registry setting would get overwritten if you re-set the language from the program settings menu).

-Seth

Page 1 of 1 (5 items) | RSS