Help! Installation of Verbum lost 65 of my Personal Books?

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 2830
Don Awalt | Forum Activity | Posted: Tue, Dec 3 2013 7:21 AM

Over the weekend I installed a fresh copy of Verbum, Scanned my Logos 5 resource folder, reindexed, and was on the air. Today, I was adding a personal book, and I noticed 65 of my 231 Personal Books were grayed out - apparently the file was gone in some cases, in others the meta data is gone! I have included a picture of a Jane Austin book, the left picture is Verbum, the right picture is a virtual PC window of another computer running Logos 5

Luckily it has not killed the Personal books in the Logos install yet

Help! How do I restore my Personal Books, and why is Syncing not working in this case? Something I did?

Have others lost personal books? The compiled image is still there, look into your Tools/Personal Books, where you would add a new Personal Book.

Thanks!

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 7:25 AM

Forgot to say - source files are in drop box. This may be just metadata gone, I am not sure yet. In the Jane Austin book case, the resource is still there on both computers.

Posts 29807
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Dec 3 2013 7:53 AM

Don Awalt:
How do I restore my Personal Books, and why is Syncing not working in this case? Something I did?

For clarification: Only metadata syncs. The resources themselves don't sync. 

I wonder if the issue is related to you switching to Verbum from Logos 5? Is there a Verbum forum for these kinds of questions?

macOS, iOS & iPadOS | Logs |  Install

Posts 1852
Ken McGuire | Forum Activity | Replied: Tue, Dec 3 2013 8:12 AM

Via dropbox I have transferred the compiled files successfully from one  computer to another - include for a few books for which the metadata had somehow gone bye-bye.  Just Scan the directory....

Hope this works for you.

The Gospel is not ... a "new law," on the contrary, ... a "new life." - William Julius Mann

L8 Anglican, Lutheran and Orthodox Silver, Reformed Starter, Academic Essentials

L7 Lutheran Gold, Anglican Bronze

Posts 13420
Mark Barnes | Forum Activity | Replied: Tue, Dec 3 2013 9:18 AM

I would guess that if you SCANed your resources folder before the Personal Books metadata finished syncing, then those resources wouldn't be picked up. It's possible (I haven't tried it) that if you reSCANned that folder, then the books would be copied over.

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 12:57 PM

Luckily I have a backup folder of the compiled images (lbxpbb files), so I scanned that and it made no difference.

But I think the prob lem is different - as you see from the graphic, I have no metadata showing from within Tools/Personal Books. The Jane Austen book I showed in the image, for example, IS in my library - and I can bring it up - which means the resource binary is there and indexed. I just have no metadata, and as is I am unable to edit or recompile the personal book. Make sense?

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 1:00 PM

Here is another picture. Note no image file, no source file, no description- the only metadata that exists is name and author! And it's for about 60+ resources.

Doesn't this appear there is a problem that PB info is not syncing with Verbum? If this data exists on another install with Logos 5, why isn't it here?

Posts 1852
Ken McGuire | Forum Activity | Replied: Tue, Dec 3 2013 1:02 PM

Don Awalt:
But I think the prob lem is different - as you see from the graphic, I have no metadata showing from within Tools/Personal Books. The Jane Austen book I showed in the image, for example, IS in my library - and I can bring it up - which means the resource binary is there and indexed. I just have no metadata, and as is I am unable to edit or recompile the personal book. Make sense?

I had this problem with Logos4.  I am not aware of any solution.

The Gospel is not ... a "new law," on the contrary, ... a "new life." - William Julius Mann

L8 Anglican, Lutheran and Orthodox Silver, Reformed Starter, Academic Essentials

L7 Lutheran Gold, Anglican Bronze

Posts 33475
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Dec 3 2013 1:10 PM

I just double checked - mine are all there with their metadata

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 1:36 PM

Thanks MJ for checking. I may have to go back to Logos 5 and uninstall Verbum. Without hearing from Bradley or anyone, I can't trust that syncing is not trustworthy in Verbum. Even if I manually re-add all 60+ PBs in again, which I sure don't want to do, are they syncing with Logos 5?

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 1:52 PM

Here's some more info - this is really messed up! Note graphic below - I have two versions of this resource. This does not exist under the Logos install.

I have also discovered, if I just recompile the PB on the Logos install, the metadata comes across. So I am doing that for all 60+ just to get the Verbum side stable.

I still think I should uninstall it, what do you think? Would you trust it?

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 1:58 PM

I can confirm there are at least some PBs in the Verbum version that I had deleted and removed from my system. and do not exist in Logos. They are there just title and author in Verbum.

Posts 33475
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Dec 3 2013 2:29 PM

Don Awalt:
I still think I should uninstall it, what do you think? Would you trust it?

If you can afford the time, I'd hold off and keep the installation so that Bradley can see what went wrong before other people have the same problems.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 13420
Mark Barnes | Forum Activity | Replied: Tue, Dec 3 2013 3:45 PM

Don Awalt:

I have also discovered, if I just recompile the PB on the Logos install, the metadata comes across. So I am doing that for all 60+ just to get the Verbum side stable.

I still think I should uninstall it, what do you think

It sounds as thought the problem might even be with the Logos side of the installation not syncing properly to the cloud. I'd do a sync repair with Logos, and wait for that to finish, then do a sync now in Verbum (and if that still doesn't work, a sync repair in Verbum).

(By sync repair, I mean type sync repair into the Command box.)

Posts 2830
Don Awalt | Forum Activity | Replied: Tue, Dec 3 2013 7:19 PM

Thanks Mark, I did the Sync Repair and Sync Now on Verbum, no change to the missing metadata :-(

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Dec 3 2013 7:24 PM

Don Awalt:
Have others lost personal books?

Apologies: no.  Personally used a variation of Method 3 so could offline scan Logos 5 library into Verbum, which included compiled personal books.

Keep Smiling Smile

Posts 2830
Don Awalt | Forum Activity | Replied: Wed, Dec 4 2013 3:19 AM

Should I delete everything and re-install using Method 3 (which is what I used before)?

I wish Logos would chime in with some guidance, this seems like a serious issue - installs out of sync that do not correct is a huge data integrity issue IMHO. I still don't know if this is a glitch, and re-compiling my PBs I will then move onward with no issues, or is there possibly something wrong and syncing will break again in Verbum. It's hard to trust it at this point without some statement on this, don't you think? I have never seen anything like this ...

Posts 2964
tom | Forum Activity | Replied: Wed, Dec 4 2013 3:26 AM

Don Awalt:

Over the weekend I installed a fresh copy of Verbum, Scanned my Logos 5 resource folder, reindexed, and was on the air. Today, I was adding a personal book, and I noticed 65 of my 231 Personal Books were grayed out - apparently the file was gone in some cases, in others the meta data is gone! I have included a picture of a Jane Austin book, the left picture is Verbum, the right picture is a virtual PC window of another computer running Logos 5

Luckily it has not killed the Personal books in the Logos install yet

Help! How do I restore my Personal Books, and why is Syncing not working in this case? Something I did?

Have others lost personal books? The compiled image is still there, look into your Tools/Personal Books, where you would add a new Personal Book.

Thanks!

I have the same issue.  For me, the issue came when I replaced my PC.  After syncing everything, I copied the compiled books and scanned them into L5.  All the books are there, but not the metadata.

Posts 27053
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 4 2013 4:23 AM

Don Awalt:
Should I delete everything and re-install using Method 3 (which is what I used before)?

This was the fresh install mentioned in your original post? But was there a previous installation of Logos that you uninstalled? If so, it does not remove the Documents folder because Logos regard that as a backup. In theory, then, you should not lose any documents (PB's, etc). If you do, it is clearly a Sync problem and reinstalling will not correct it.

An old trick is to make a minor change to the document (PB) in the other system to force the sync of missing items (or recompile the PB's as you found).

Dave
===

Windows 10 & Android 8

Posts 2830
Don Awalt | Forum Activity | Replied: Wed, Dec 4 2013 5:44 AM

Dave Hooton:

Don Awalt:
Should I delete everything and re-install using Method 3 (which is what I used before)?

This was the fresh install mentioned in your original post? But was there a previous installation of Logos that you uninstalled? If so, it does not remove the Documents folder because Logos regard that as a backup. In theory, then, you should not lose any documents (PB's, etc). If you do, it is clearly a Sync problem and reinstalling will not correct it.

An old trick is to make a minor change to the document (PB) in the other system to force the sync of missing items (or recompile the PB's as you found).

That's what I am doing, I am actually recompiling the lost PBs on my Logos install - luckily I have a work laptop with Logos 5 installed on it, I had not converted it to the Verbum app yet (and now I never will Big Smile - just in case).

Yes, I did a fresh install of Verbum, method 3. Once it appears to be complete and stable (didn't look at the Tools/PB list though at the time, just Notes, visual filters, i.e. all the documents), I uninstalled Logos 5 and deleted the folder tree since it was about 70GB for me.

I agree with you, this is most definitely a sync problem. Even Mark's suggestion of sync repair didn't fix it. I have seen 2 others that have reported the same issue on the forums.

Page 1 of 1 (20 items) | RSS