Page 1 of 1 (16 items)
This post has 15 Replies | 1 Follower

Posts 2766
Erwin Stull, Sr. | Forum Activity | Posted: Sat, Jan 25 2014 12:41 PM

LEB (not LEB Audio) crashes upon opening in Logos Bible Software 5.2a Beta 3 (5.2.1.0036) Windows 7 Platform. This error occurs consistently on Windows 7 Ultimate desktop as well as on Windows 7 Professional netbook.

This is what I have done so far:

1. Verified that the same issue occurs on both desktop and netbook.

2. Checked forum messages for same issue (last post was on 12/6/2013 by Lynden Williams)

3. Checked if the error occurs on Android mobile devices (it doesn't).

4. Hide the resource on the desktop in an attempt to redownload (just in case it may be a corrupt file)

5. Performed a repair install of .NET

6. Called into Logos support.

Any help and assistance is greatly appreciated.

Thank you

Posts 25741
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jan 25 2014 2:42 PM

Please provide logs of the crash (upload the log files folder). Also describe the circumstances e.g. opening from Command box, startup layout, library, etc.

Dave
===

Windows 10 & Android 8

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sat, Jan 25 2014 4:03 PM

Dave Hooton:

Please provide logs of the crash (upload the log files folder). Also describe the circumstances e.g. opening from Command box, startup layout, library, etc.

Thanks Dave; Here are the log files. The same crash occurs when I open the LEB from library, command box, home page.

1323.LogosLogFiles201401251853.zip

Posts 8245
LogosEmployee

I think this may be a bug in the 5.2a beta; I experienced something similar on Friday (but it required clicking a footnote, not just opening the resource). I'll file a bug report.

It may be triggered by opening to a particular location in the resource. It looks like you might have been opening to Genesis, so try entering the following in the command box: open LEB to Matt 1:1

This may allow you to successfully open the LEB to a different location.

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sat, Jan 25 2014 5:54 PM

Bradley Grainger (Logos):

It may be triggered by opening to a particular location in the resource. It looks like you might have been opening to Genesis, so try entering the following in the command box: open LEB to Matt 1:1

Thanks Bradley; It worked. Smile

Once I initially opened the LEB directly to the Scripture reference as you suggested, I was able to jump to several random Scripture references in both the OT and NT without a crash. Closed the LEB and reopened several times without a crash.

The crash appears to have something to do with non Scripture references/content. Once I attempted to select Title, Contents, Acknowledgements, and Preface, Logos immediately crashed. Also, attempting to scroll up from the top of Genesis resulted in a crash.

Posts 8245
LogosEmployee

Erwin Stull, Sr.:
The crash appears to have something to do with non Scripture references/content. Once I attempted to select Title, Contents, Acknowledgements, and Preface, Logos immediately crashed. Also, attempting to scroll up from the top of Genesis resulted in a crash.

Thanks for the update; this should make it easier to diagnose and fix the bug.

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Sun, Jan 26 2014 3:01 AM

Erwin Stull, Sr.:
The crash appears to have something to do with non Scripture references/content. Once I attempted to select Title, Contents, Acknowledgements, and Preface, Logos immediately crashed. Also, attempting to scroll up from the top of Genesis resulted in a crash.

Tried several different scenarios, but could not make this resource crash 5.2a Beta 3 Mac. Must be a Windows bug.

Posts 10683
Forum MVP
NB.Mick | Forum Activity | Replied: Sun, Jan 26 2014 3:32 AM

Erwin Stull, Sr.:
The crash appears to have something to do with non Scripture references/content. Once I attempted to select Title, Contents, Acknowledgements, and Preface, Logos immediately crashed. Also, attempting to scroll up from the top of Genesis resulted in a crash.

I can confirm the bug on Windows.

Opened LEB from Command prompt, it went to Galatians. I manouvered to Genesis and then tried to scroll up: Crash.

Logs are attached: 1778.Logos Log Files.zip

Running Logos 8 latest beta version on Win 10

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sun, Jan 26 2014 11:28 AM

Jack Caviness:

Tried several different scenarios, but could not make this resource crash 5.2a Beta 3 Mac. Must be a Windows bug.

Hi Jack; If it's not crashing when you attempt to go to any location above Genesis, it may be isolated to just Windows use of the LEB.

Initially, it would crash every time I attempted to open it. Since it was the 1st time I had opened the LEB (that I remember), it probably defaulted to opening the title page, which crashed. Once I opened it as Bradley had instructed, it has opened consistently since. The only time that it crashes now is when I attempt to view anything above Genesis.

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sun, Jan 26 2014 11:42 AM

NB.Mick:

I can confirm the bug on Windows.

I'm thinking that, if Jack is not experiencing the same issue, that it may be isolated to just the Windows platform. Unfortunately, I don't have a MAC platform to test it on. My daughter has one, but trying to pry that from her for a few hours is like asking her to sell her car. Smile

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Sun, Jan 26 2014 11:55 AM

Erwin Stull, Sr.:
I'm thinking that, if Jack is not experiencing the same issue, that it may be isolated to just the Windows platform.

That is my conclusion.

Erwin Stull, Sr.:
Unfortunately, I don't have a MAC platform to test it on. My daughter has one, but trying to pry that from her for a few hours is like asking her to sell her car.

You can buy my pickup, but leave my iMac alone Cool

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sun, Jan 26 2014 12:07 PM

Jack Caviness:

You can buy my pickup, but leave my iMac alone Cool

Smile That's funny.

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Sun, Jan 26 2014 12:10 PM

Bradley Grainger (Logos):

I think this may be a bug in the 5.2a beta; I experienced something similar on Friday (but it required clicking a footnote, not just opening the resource). I'll file a bug report.

I tested this on my system and found the same to be true. Clicking any footnote results in a crash.

5126.LogosLogFiles201401261454.zip

Posts 8245
LogosEmployee

This will be fixed in Beta 4.

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Mon, Jan 27 2014 7:53 AM

Bradley Grainger (Logos):

This will be fixed in Beta 4.

Great. Thanks. Big Smile

Posts 2766
Erwin Stull, Sr. | Forum Activity | Replied: Wed, Feb 12 2014 2:08 PM

For anyone interested, I have confirmed that this has been fixed in Beta 4. I did not see the fix stated in the release notes though.

Thanks. Big Smile

Page 1 of 1 (16 items) | RSS