5.2a B3 - some Library comments

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 22843
Forum MVP
Graham Criddle | Forum Activity | Posted: Tue, Jan 28 2014 12:29 AM

(Running on Windows 8.1 and Logos 5.2a B3)

1) It looks as though the previously reported performance issues in adding tags have been resolved - thanks for that

2) There is still an issue with ratings not showing in the library window after they have been updated.

In the screenshot below look at the entry for "Revealing Jesus". I have just added two stars in the editor but it doesn't show in the main window

Closing the Library window and reopening it causes the information to be displayed correctly.

(I believe I flagged this earlier and haven't seen anything in the release notes to indicate it is fixed so this may be a superfluous report but wanted to flag it was still an issue)

3) When I am tagging a book I normally apply the tags I want and then assign a rating. 

However, when I do that now - and click the rating immediately after setting the tags - the rating doesn't "take". I need to click it again for it to be accepted.

If I just click the rating without assigning tags it seems to work first time.

Graham

Posts 10737
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Jan 28 2014 3:13 AM

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This no longer seems to be a problem with 5.2a Beta 3 Mac. Have experience no problems with applying ratings to new resources or with changing the rating of existing ones.

Posts 1471
Angela Murashov | Forum Activity | Replied: Tue, Jan 28 2014 8:23 AM

Graham Criddle:
1) It looks as though the previously reported performance issues in adding tags have been resolved - thanks for that

You're welcome Smile

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This will be fixed in 5.2a Beta 4.

But I found another bug when looking into this one. When changing an existing rating, it will not update as well so I will create a case for that.

Graham Criddle:
However, when I do that now - and click the rating immediately after setting the tags - the rating doesn't "take". I need to click it again for it to be accepted

I can reproduce this, and I will create a case for Development.

Posts 1471
Angela Murashov | Forum Activity | Replied: Tue, Jan 28 2014 8:26 AM

Jack Caviness:

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This no longer seems to be a problem with 5.2a Beta 3 Mac. Have experience no problems with applying ratings to new resources or with changing the rating of existing ones.

Correct, the bugs that Graham mentioned are only for Windows. 

Posts 22843
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jan 28 2014 8:35 AM

Angela Murashov:

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This will be fixed in 5.2a Beta 4.

Thanks

Angela Murashov:
But I found another bug when looking into this one. When changing an existing rating, it will not update as well so I will create a case for that.

Well spottedSmile

Angela Murashov:

Graham Criddle:
However, when I do that now - and click the rating immediately after setting the tags - the rating doesn't "take". I need to click it again for it to be accepted

I can reproduce this, and I will create a case for Development.

Thanks Angela.

I had seen this last one since the beta started but never really been able to work out exactly when it occurred. Glad you can reproduce it

Graham 

Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, Jan 29 2014 9:12 AM

Angela Murashov:

Graham Criddle:
However, when I do that now - and click the rating immediately after setting the tags - the rating doesn't "take". I need to click it again for it to be accepted

I can reproduce this, and I will create a case for Development.

This has been resolved as by design since the first click is to close the edit box for the tag and then the second click changes the rating. 

Posts 22843
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Jan 29 2014 11:29 PM

Hi Angela

Angela Murashov:
This has been resolved as by design since the first click is to close the edit box for the tag and then the second click changes the rating.

Thanks for the response - it explains what I am seeing but I am not convinced that it is a good design and think it is probable going to cause confusion.

After the "first click" I have:

after the second click I have

While the visuals do indicate a different state it is not at all clear when using the editor that the action shown in the first picture doesn't indicate a completed activity

Graham

Posts 25741
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 30 2014 2:00 PM

Graham Criddle:
While the visuals do indicate a different state it is not at all clear when using the editor that the action shown in the first picture doesn't indicate a completed activity

It's an awkward design seemingly predicated on the ability to click the tag and filter the Library AND easily add more tags (hence the empty box that has to be dismissed). I'll devote some time to the feature in the next Beta.

Dave
===

Windows 10 & Android 8

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Wed, Feb 12 2014 11:47 AM

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This should be fixed in 5.2a Beta 4.   

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 22843
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Feb 12 2014 11:07 PM

Dylan Rondeau:

Graham Criddle:
2) There is still an issue with ratings not showing in the library window after they have been updated.

This should be fixed in 5.2a Beta 4.   

And it looks as though it is

Thanks

Page 1 of 1 (10 items) | RSS