BUG: 5.2a B4 WIN7: Library filter results change when a resource is dragged from the results list

Page 1 of 1 (7 items)
This post has 6 Replies | 2 Followers

Posts 811
Tim Hensler | Forum Activity | Posted: Thu, Feb 13 2014 5:47 AM

The results from applying a filter in the Library changes when one of the resources is opened by dragging it from the results list to the top of the same tile.  See attached video example (explained in the replication steps below).

Replication:

  1. Layout Logos with one tile containing only the Library (this happens even with multiple tiles, but to make it simple I'm using one).
  2. Filter using a mytag value (in my case, "mytag:youth" had 8 results - the behavior is the same with other mytag values).
  3. Click and hold on the "type" of a resource (in this case, "Monograph") lower on the list and drag it up to open it as another pane in the same tile (I dragged "That's My Teenage Son...")
  4. "Fresh Ideas for Families..." opened in a new tab in the same tile instead of the resource I dragged to open. 
  5. Click on the library tab - the filter box still shows 8 results, but there are only 5 resources listed with the one that did open highlighted/selected in the list.
  6. Click in filter box to edit value, click at the end of the text to place the curser at the end of the text in the box, backspace to remove the "h"  (no change in results)
  7. Add the "h" and press Enter (results return to show all 8 resources)

Observations:

  • It seems to open the first title that the cursor touches while dragging my selected resource upward (hence different results when replicating this bug)
  • If I click and hold on the "type" of a resource and drag upward without crossing over a title, no resource opens (I expect to be able to open a resource by dragging it from any column).
  • Also, if a resources is selected/highlighted in the results list, and I click in the filter box (to give the filter box focus instead of the highlighted resource in the list) then press enter to refresh the list, the resource highlighted in the list opens and the list is not refreshed.

Posts 1471
Angela Murashov | Forum Activity | Replied: Thu, Feb 13 2014 8:01 AM

Tim Hensler:
The results from applying a filter in the Library changes when one of the resources is opened by dragging it from the results list to the top of the same

Thank you so much for the detailed steps, observations and screencast.Big Smile I was able to reproduce this only Windows and I will create a case for Development. 

Tim Hensler:
If I click and hold on the "type" of a resource and drag upward without crossing over a title, no resource opens (I expect to be able to open a resource by dragging it from any column).

Tim Hensler:
Also, if a resources is selected/highlighted in the results list, and I click in the filter box (to give the filter box focus instead of the highlighted resource in the list) then press enter to refresh the list, the resource highlighted in the list opens and the list is not refreshed.

I can also reproduce both of these bugs only on Windows and I will create a case for Development to investigate. 

Posts 811
Tim Hensler | Forum Activity | Replied: Thu, Feb 13 2014 3:23 PM

Thank you, Angela.

Posts 1471
Angela Murashov | Forum Activity | Replied: Fri, Feb 14 2014 10:10 AM

Angela Murashov:
Tim Hensler:
Also, if a resources is selected/highlighted in the results list, and I click in the filter box (to give the filter box focus instead of the highlighted resource in the list) then press enter to refresh the list, the resource highlighted in the list opens and the list is not refreshed.

This has been resolved by design since this is the same behavior that is currently on stable (5.2 SR5).

"On stable, you can open the library (focus goes to the filter box), type "ESV", press the arrow keys to navigate up and down in the result list, then press Enter to open the selected resource. This is a useful workflow and we shouldn't break it."

Posts 811
Tim Hensler | Forum Activity | Replied: Sat, Feb 15 2014 1:03 PM

That makes sense.  Thank you, Angela.

Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, Feb 26 2014 3:34 PM

Angela Murashov:

Tim Hensler:
The results from applying a filter in the Library changes when one of the resources is opened by dragging it from the results list to the top of the same

Thank you so much for the detailed steps, observations and screencast.Big Smile I was able to reproduce this only Windows and I will create a case for Development. 

Tim Hensler:
If I click and hold on the "type" of a resource and drag upward without crossing over a title, no resource opens (I expect to be able to open a resource by dragging it from any column).

Both of these bugs should be fixed in 5.2a Beta 5. Smile

Posts 811
Tim Hensler | Forum Activity | Replied: Wed, Feb 26 2014 7:00 PM

Thank you Angela and team Logos.

Page 1 of 1 (7 items) | RSS