Logos Library Reporter

Page 8 of 8 (151 items) « First ... < Previous 4 5 6 7 8
This post has 150 Replies | 9 Followers

Posts 18
Franck | Forum Activity | Replied: Sat, Aug 4 2018 10:09 AM

Hi Graham,

I am so sorry. Thank you for letting me know.

I am one of the lucky beneficiaries of Steve Clark's work.

Thank you Graham.

Posts 25403
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Aug 6 2018 6:49 PM

It is inevitable that Faithlife will change database schema, and LLR will be incompatible. The current version is 2.5 years old and I doubt that it can be fixed, even though the web site is still running. However, I sent an email to its Admin address, so I'll see what eventuates.

Dave
===

Windows 10 & Android 8

Posts 18
Franck | Forum Activity | Replied: Tue, Aug 7 2018 12:51 AM

Hello Dave,

I already sent two emails to the Admin address but I did not get an answer. That's why I posted my question here.

But, given Steve's departure, I prefer not to go further and not insist, by delicacy towards his family.

I thank you Dave for your understanding and for your answer.

Regards,

Posts 25403
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Aug 7 2018 6:11 AM

Dave Hooton:
I sent an email to its Admin address, so I'll see what eventuates.

The reply from Josh Clark stated "...After my Dad’s passing in 2016, the code was frozen. I am saddened to hear that it no longer works."

Dave
===

Windows 10 & Android 8

Posts 10430
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Aug 7 2018 8:25 AM

Dave Hooton:

Dave Hooton:
I sent an email to its Admin address, so I'll see what eventuates.

The reply from Josh Clark stated "...After my Dad’s passing in 2016, the code was frozen. I am saddened to hear that it no longer works."

Dave & all,

just to verify (I think I used LLR a looooong time ago, and I think on another machine), I installed the exact C++ runtime version needed for Win10 you linked to in your post on the other thread  and installed LLR from the website. Installation went fine.

Trying to read the Logos library directly from the DB did not work (Logos 7.17 Beta 3) and gave an error message much like Franck's above. However, using the second option Steve built into LLR, namely exporting the library as an XML and reading that file worked without a problem. I had it produce some reports, no issue (except that it will find zero hidden books using this method, since they are not shown in the library and thus are not part of the XML export)

So it seems, the tool still works for the time being:

The XML file needed for this can be easily build - it is called library.XML and LLR will import it and work - at least on my machine.

Running Logos 8 latest beta version on Win 10

Posts 18
Franck | Forum Activity | Replied: Tue, Aug 7 2018 12:40 PM

Hi NB Mick,

I thank you for taking part in the conversation. Your solution works well but I do not have access to book covers and this is my big need. Indeed, the software explains to the tab "Book Covers": "Book Cover report can only be built from a Catalog.db, not XMLs".

But let's stay there. This will force me to focus more on the subtleties of the library option in the Logos 7 software itself.

Best regards,

Posts 10430
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Aug 7 2018 2:05 PM

Franck:

thank you for taking part in the conversation. Your solution works well but I do not have access to book covers and this is my big need. Indeed, the software explains to the tab "Book Covers": "Book Cover report can only be built from a Catalog.db, not XMLs".

But let's stay there. This will force me to focus more on the subtleties of the library option in the Logos 7 software itself.

Franck,

Great to hear it helps you a bit,

Mick

Running Logos 8 latest beta version on Win 10

Posts 130
Pete De Bonte | Forum Activity | Replied: Sun, Mar 22 2020 2:26 PM

Anybody have LLR working with 8? I tried to read a Library XML file exported from Verbum 8.12 today, and LLR said:

Error: could not find an expected RootName in the XML file.

  • Anyone having the same problem, or is it just me?
  • Might anyone out there still have a Library XML file from 7 to compare vs 8, to see if the format has changed? If the XML format has changed between 7 and 8, I wonder if 8's format could be easily edited so that LLR would accept it.

Thanks,
-Pete  

Posts 10430
Forum MVP
NB.Mick | Forum Activity | Replied: Sun, Mar 22 2020 2:59 PM

Pete De Bonte:
Anybody have LLR working with 8?

yes. I just now read the exported library xml from Logos 8.12 into LLR, worked fine.

Running Logos 8 latest beta version on Win 10

Posts 130
Pete De Bonte | Forum Activity | Replied: Sun, Mar 22 2020 7:02 PM

Thanks NB Mick! Your success encouraged me to retry it, and I've discovered that "Error: could not find an expected RootName in the XML file." occurs if I (accidentally) export as "Spreadsheet (Excel, etc.)" rather than XML.

It's confusing, because the two options are close together (can easily miss and click the wrong one), and moreover, the filename is still "Library.xml" even for the "Spreadsheet (Excel, etc.)" option, which is probably why I didn't realize I'd clicked the wrong option.

Maybe Faithlife should change it to have more distinctive filenames. *shrug*
-Pete

Posts 10430
Forum MVP
NB.Mick | Forum Activity | Replied: Mon, Mar 23 2020 2:12 AM

Pete De Bonte:
Thanks NB Mick! Your success encouraged me to retry it

Good to hear it's working now for you!

Running Logos 8 latest beta version on Win 10

Page 8 of 8 (151 items) « First ... < Previous 4 5 6 7 8 | RSS