Bug: No BWS elements with "worm" from Psalm 22 and a rightclick

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 4508
Robert Pavich | Forum Activity | Posted: Sat, Jan 9 2010 12:25 PM

Posted by David:

So I was working through Psalm 22 and came to an interesting word in v7,

תוֹלע, "Worm" and wanted to do a quick run-down using the Bible Word Study guide.  Why does it not return a report on translation, example uses, grammatical relationships, propositional use, etc?   It found 39 uses in the BHS 4.2, but none of the other stuff that makes the BWS report so nice.

I checked and this also happens with the BHS with WERKGROEP MORPHOLOGY

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 5337
Kevin Becker | Forum Activity | Replied: Sat, Jan 9 2010 12:33 PM

4.2 and WIVU point this lemma whereas the reverse interlinears and Anderson-Forbes do not (you can launch a BWS from these). This is the source of the problem. Interestingly enough, sympathetic highlighting works between the ESV and 4.2 on this word.

Posts 433
Vincent Setterholm | Forum Activity | Replied: Sat, Jan 9 2010 1:04 PM

This bug is corrected in 4.0b Beta 2. It was to do with WPF introducing a new normalization order for Hebrew marks which wasn't being used everywhere in the application. So one might search for a word that has a dagesh before a tsere when the index stored the tsere before the dagesh and thus 0 hits would be returned.

Sympathetic highlighting works in 4.0a (and for that matter, KeyLinking to lexicons works as well) because it is based on an internal indexing system that is independent of the lemma spelling.

Posts 7
David J. Roseland | Forum Activity | Replied: Sat, Jan 9 2010 1:16 PM

שׂפה, "lip," does it too in v8--BHS4.2 and BHS/WIVU give you a dead BWS, but the A-F text produces a good BWS, and strangely, it tells the right number of hits in the BHS (textual search), unlike with תוֹלע.  At least I know to keep A-F open.

 

Posts 4508
Robert Pavich | Forum Activity | Replied: Sat, Jan 9 2010 1:16 PM

Vincent,

I'm using 4.0b Beta 2 and have this problem.

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 5337
Kevin Becker | Forum Activity | Replied: Sat, Jan 9 2010 1:24 PM

VincentSetterholm:

This bug is corrected in 4.0b Beta 2. It was to do with WPF introducing a new normalization order for Hebrew marks which wasn't being used everywhere in the application. So one might search for a word that has a dagesh before a tsere when the index stored the tsere before the dagesh and thus 0 hits would be returned.

Sympathetic highlighting works in 4.0a (and for that matter, KeyLinking to lexicons works as well) because it is based on an internal indexing system that is independent of the lemma spelling.

Vincent, I was able to reproduce this problem using 4.0b Beta 2! Whatever you did to fix the Hebrew bug in WPF didn't work here.

EDIT: Robert beats me to the punch... serves me right for leaving the edit window open while taking a phone call Smile.

Posts 433
Vincent Setterholm | Forum Activity | Replied: Sat, Jan 9 2010 3:02 PM

Ah, I should have read the problem description more carefully. There is something peculiar with this particular word.

There is an index that takes words from the Westminster database and finds the equivalent in the Andersen-Forbes database in order to populate the translation ring and the grammatical relationships sections. It's not finding a match on this particular word, so those sections are blank. We'll look into it. Thanks!

Page 1 of 1 (7 items) | RSS