Possible fix for Yosemite/L6 users with download woes

Page 1 of 2 (28 items) 1 2 Next >
This post has 27 Replies | 3 Followers

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Posted: Wed, Nov 19 2014 3:26 PM

This has been mentioned on a couple of threads, but I wanted to make it more obvious.

Logos 6.0a has a possible fix for Yosemite download problems. It should download automatically - but if you're having download problems, that's not going to work.

To try the fix, you'll need to:

  1. Download and install the update from the bottom of one of these pages: Logos or Verbum (you'll need to be logged in, and have purchased L6).
  2. After it's installed, type into OSX's Terminal, one of the following, as appropriate.
    • defaults write com.logos.Logos UseURLSession -bool YES.
    • defaults write com.logos.Verbum UseURLSession -bool YES
    • defaults write com.logos.Noet UseURLSession -bool YES
  3. Restart Logos and the indexer for good measure.

Downloads should now run smoothly. If it works (or if it doesn't), come back and let us know.

Posts 8893
fgh | Forum Activity | Replied: Wed, Nov 19 2014 6:28 PM

Mark Barnes:

To try the fix, you'll need to:

  1. Install the RC, by typing set update channel to beta in the L6 command bar.
  2. After it's installed, type defaults write com.logos.Logos UseURLSession -bool YES into OSX's Terminal.
  3. Restart Logos and the indexer for good measure.

4.  Type set update channel to default (or stable) in the L6 command bar.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 27679
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Nov 19 2014 7:07 PM

Good call fgh. 

The problem with this solution at present is that those effected don't have a way to actually download the beta.

OSX & iOS | Logs |  Install

Posts 16
Gavin Anthony | Forum Activity | Replied: Thu, Nov 20 2014 1:17 AM

Yes, if we could have a direct link to download the beta, this could work--but not if we only try and do it within Logos.

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Thu, Nov 20 2014 1:44 AM

fgh:
4.  Type set update channel to default (or stable) in the L6 command bar.

Thanks. I've added it.

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Thu, Nov 20 2014 1:53 AM

Gavin Anthony:
Yes, if we could have a direct link to download the beta, this could work--but not if we only try and do it within Logos.

6.0a is due to be released today, I think. Once it is released, you'll be able to download it from your order receipt.

Posts 5613
Todd Phillips | Forum Activity | Replied: Thu, Nov 20 2014 6:28 AM

Mark Barnes:
6.0a is due to be released today, I think. Once it is released, you'll be able to download it from your order receipt.

Or from this page (towards the bottom):  https://www.logos.com/product/46767/logos-6-core-engine

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Thu, Nov 20 2014 5:36 PM

Now that 6.0a is released, I've updated the post to reflect that.

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Thu, Nov 20 2014 5:39 PM

Can a Mac user confirm whether or not the link on the product pages has been updated to 6.0a yet? I've just noticed the Windows version isn't up-to-date.

Posts 3
Timothy Peace | Forum Activity | Replied: Thu, Nov 20 2014 5:47 PM

I have a Macbook Air with OS X Yosemite 10.10.1. The link does not seem to be 6.0a. 

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Thu, Nov 20 2014 8:01 PM

Mark Barnes:

To try the fix, you'll need to:

  1. Download and install the update from the bottom of one of these pages: Logos or Verbum (you'll need to be logged in, and have purchased L6).
  2. After it's installed, type defaults write com.logos.Logos UseURLSession -bool YES into OSX's Terminal.
  3. Restart Logos and the indexer for good measure.

Thanks for posting these instructions. For users of the branded products, they will need to use the appropriate domain for the preference.

For Verbum:

defaults write com.logos.Verbum UseURLSession -bool YES

and Noet:

defaults write com.logos.Noet UseURLSession -bool YES

Mac Developer
Faithlife

Posts 8893
fgh | Forum Activity | Replied: Thu, Nov 20 2014 8:15 PM

Note: Mark has updated the instructions in the OP, which means that my number 4) is no longer relevant.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 5
Joshua Hargrave | Forum Activity | Replied: Thu, Nov 20 2014 10:28 PM

Mark Barnes:

Can a Mac user confirm whether or not the link on the product pages has been updated to 6.0a yet? I've just noticed the Windows version isn't up-to-date.

It is not 6.0a. Still the same as it was before.

Posts 5
Joshua Hargrave | Forum Activity | Replied: Fri, Nov 21 2014 11:39 AM

Joshua Hargrave:

Mark Barnes:

Can a Mac user confirm whether or not the link on the product pages has been updated to 6.0a yet? I've just noticed the Windows version isn't up-to-date.

It is not 6.0a. Still the same as it was before.

Link is now officially 6.0a.

I also want to add that the update seems to have fixed the DL problem for Mac, at least for me.  I have downloaded 30% of a 6 GB+ update in about two hours, which is huge progress.  And LogosIndexer is only taking up 10-50% usage, compared to 110-170% before. 

Posts 20
Big Tex | Forum Activity | Replied: Thu, Nov 27 2014 2:53 PM

I am really struggling to understand the process that Logos uses for updating content and the system.

I got tired of waiting for it to download Logos 6 via Logos 5 as my email told me to do when I purchased 6.  So i just downloaded 6 straight from the website and ran the dmg there.  It downloaded super fast and upgraded me no problems.  Now it is trying to download 1.67GB of new content (yay like new content) but for the last hour and a half it has been at 4%.  I do not like that.

I also ran the terminal command as noted above.  It does not seem to have helped.

Now not to be funny, but I also use Accordance.  They just upgraded and i upgraded too.  Found it straight-forward the new content downloads fast as well.  So I am not sure what is up with Logos... but I am very disappointed with the content process.  I would almost rather pay money to get a dvd and update things the old-fashioned way.  

Please, please, PLEASE look at the technology you are using for updates.  Something is not right.

Posts 27679
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Nov 27 2014 3:11 PM

Welcome Tex. The issue exists as a bug between Yosemite and Logos. Did you try the suggestion listed in the first post?

OSX & iOS | Logs |  Install

Posts 20
Big Tex | Forum Activity | Replied: Fri, Nov 28 2014 6:48 PM

Yes I have.  I also read several other posts. And followed all of them, including changing (or more or less deleting) wifi configurations on my Mac.  Things went a little faster, but it is still a kluge way of doing things.  I have also run into another issue in that several of my titles that i originally had are no longer in my library.  I have another post about this.

I will work through it, but it is frustrating to me.

Posts 27679
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Nov 28 2014 9:29 PM

Big Tex:
Yes I have.

Can you confirm that you are using 6.0a?

OSX & iOS | Logs |  Install

Posts 21
Robert Carter | Forum Activity | Replied: Mon, Dec 1 2014 12:56 PM

Hi Mark.

Thanks for the info.

I can find Terminal OK but am not sure what to do with your information.

If I click on the link at the bottom of the page, it downloads the core engine but I wonder if I will still have all the drama of all those updates.
I canceled the current update and found that resources were added and L6 started indexing. I am reluctant to install the new dmg if I have to start again it it overwrites the existing app.

Simultaneously a further 2.16 GB of updates were made available.

I found Terminal OK but where do I really type in the code. Is the full code defaults write com.logos.Logos UseURLSession -bool YES or simply com.logos.Logos UseURLSession -bool YES.

What appears in my terminal is 

Last login: Tue Dec  2 06:39:08 on ttys001

Roberts-iMac:~ BashanMinistries$ 

Robert

Posts 27679
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 1 2014 9:22 PM

Robert Carter:

I can find Terminal OK but am not sure what to do with your information.

If I click on the link at the bottom of the page, it downloads the core engine but I wonder if I will still have all the drama of all those updates.
I canceled the current update and found that resources were added and L6 started indexing. I am reluctant to install the new dmg if I have to start again it it overwrites the existing app.

No worries. When you download and install a new engine, it overwrites the OLD engine ONLY. The data files are left in place. This will not add to your download woes. 

Robert Carter:
Is the full code defaults write com.logos.Logos UseURLSession -bool YES or simply com.logos.Logos UseURLSession -bool YES.

The former. You need the full thing: defaults write com.logos.Logos UseURLSession -bool YES 

(NOTE: that line is for "Logos" rather than Noet or Verbum.)

OSX & iOS | Logs |  Install

Page 1 of 2 (28 items) 1 2 Next > | RSS