Search

Search in sorted by
  • Re: Logos 6 is Slow

    That's not a particularly powerful CPU, but it should be adequate enough to run Logos. Slow application performance is a classic symptom of a machine that is infected with one or more viruses. The first thing I would do is have someone knowledgeable check out your computer to make sure it's clean and that there's nothing else interfering with it.
    Posted to Logos 6 by Ken J on Mon, Apr 6 2015
  • Re: Logos 6 Startup Time

    4657.Logos Log Files.zip
    Posted to Logos 6 by Ken J on Sat, Jan 24 2015
  • Re: Logos 6 is Slow

    Mea Culpa. Posted to the other thread.
    Posted to Logos 6 by Ken J on Sat, Jan 24 2015
  • Re: Logos 6 is Slow

    Not really. Even with latest version the splash screen shows up for 20-30 seconds and the sync windows follows with another 20 seconds. Compared to the delay issues others are having with synchronized datasets, it's pretty minor though. I was told in the other thread that Faithlife is look at startup speed, it may improve in the future.
    Posted to Logos 6 by Ken J on Sat, Jan 24 2015
  • Re: Logos 6 Startup Time

    Loaded Logos Bible Software 6.0b (6.0.2.0042) and noted that the splash screen is now 20 seconds instead of 30 and the sync also went faster. Will continue to monitor.
    Posted to Logos 6 by Ken J on Fri, Jan 16 2015
  • Logos 6 Startup Time

    [Moved from the " Logos 6 is Slow " thread] The question is what is the expected startup time for Logos 6? I have a Windows 64 system, I3770K Quad Core CPU, 16GB of RAM, 256GB SSD C Drive, Logos 6 installed on a 1TB WD Caviar Black D drive, and a 50Mbps internet connection. This is a pretty high powered system. Just to make sure there wasn't any upgrade
    Posted to Logos 6 by Ken J on Wed, Jan 14 2015
  • Re: Logos 6 is Slow

    OK... Let's start with startup time. I have a Windows 64 system, I3770K Quad Core CPU, 16GB of RAM, 256GB SSD C Drive, Logos 6 installed on a 1TB WD Caviar Black D drive, and a 50Mbps internet connection. Just to make sure there wasn't any upgrade grunge hanging around, I totally uninstalled Logos6 and reinstalled using the current installer. My resource
    Posted to Logos 6 by Ken J on Tue, Jan 13 2015
  • Re: Logos 6 is Slow

    I think startup is slow as well - the splash screen is up for 15-20 seconds each time I start up. I have a pretty high powered desktop system - Win 64, I3770K cpu, 16GB Ram, SSD C drive, etc.
    Posted to Logos 6 by Ken J on Fri, Dec 19 2014
  • Re: Recent Changes to Upgrade Prices

    Above and beyond. As far as I was concerned, the transaction was complete when I clicked the the Order button. Thank you very much.
    Posted to Logos 5 by Ken J on Mon, Dec 3 2012
  • Re: Logos 5 Windows Upgrade

    Ah - thank you. I may bite the bullet and do a complete reinstall.
    Posted to Logos 5 by Ken J on Sun, Nov 11 2012
  • Logos 5 Windows Upgrade

    I just upgraded my Windows Logos4 to Logos5 using the starter package. In general, I've happy with the process, but do have one comment from a developer perspective: Unless you are intending to allow users to operate two versions of the software independently, it's not a good idea to build the version number into the folder names. After upgrading to
    Posted to Logos 5 by Ken J on Sun, Nov 11 2012
  • Re: Easiest Way To Import Libronix Resource?

    Fantastic - I was hoping it would be something like that. Thank you...
    Posted to Logos 4 by Ken J on Wed, Oct 26 2011
  • Easiest Way To Import Libronix Resource?

    I just purchased a CD of a resource in Libronix format from a third party. I no longer have Logos 3 installed on my computer and would like to avoid reinstalling it just to import this resource. Is there an easier way to get this into my Logos 4 account? Thanks, Ken
    Posted to Logos 4 by Ken J on Wed, Oct 26 2011
  • Re: J. Vernon McGee Collections

    It appears they've now pulled Lifeworks. The link posted above now refers to the more expensive edition with a note stating that a new version of Lifeworks is under development.
    Posted to General by Ken J on Sat, May 1 2010
  • Re: Where are the menus?

    Guess I'm a bit old school - looking for File / Exit!
    Posted to Logos 4 by Ken J on Wed, Jan 27 2010
  • Where are the menus?

    OK - I give up. I know there are keyboard shortcuts, but I can't find the menus. Eventually had to use ALT-F4 to exit.
    Posted to Logos 4 by Ken J on Wed, Jan 27 2010
Page 1 of 1 (16 items) |