Search

Search in sorted by
  • Re: Mac OS 10.15 (Catalina) as of June 25

    I recently upgraded to Public Beta 4. I hadn't used Logos in a little while so I downloaded the latest .dmg file and when trying to install/upgrade I received an error saying that the software couldn't verify the package was from a trusted developer. I went into SystemPreferences>Security on the General Tab in the bottom portion it was showing Logos
    Posted to Logos 8 by Stephen on Wed, Aug 7 2019
Page 1 of 1 (1 items) |