[closed] .NET Framework 5.4.2 download error

Page 1 of 1 (13 items)
This post has 12 Replies | 2 Followers

Posts 7
Brian H. Caple | Forum Activity | Posted: Sat, Jan 31 2015 6:29 PM

I cannot download the latest Logos update because the Windows .NET Framework 5.4.2 update will not install as a part of the Logos update. I have also tried updating it manually in Windows Updates, but it will not install that way either. It updated fine on my desktop (Windows 8.1), but I'm having trouble with my laptop (Windows 7 Home Premium, 64-bit). I've even tried turning off Norton Antivirus, but that didn't help either.

On the first five attempts, I got an error  Code 13EC. I tried a sixth time and got a Code 643. I have run the Windows Update troubleshooter and Microsoft FixIt. Neither fixed the original problem. The update troubleshooter apparently fixed some other issues, but it gives me a Windows update error 0x80070057 (2015-01-31-T-07_53_21P).

Windows forums have proven unhelpful so far. Any additional assistance would be greatly appreciated.

Posts 737
Scott E. Mahle | Forum Activity | Replied: Sat, Jan 31 2015 8:03 PM

Hi Brian!

See if these help you

https://community.logos.com/forums/p/93441/648576.aspx#648576

https://community.logos.com/forums/p/99711/691208.aspx

or

http://www.microsoft.com/en-us/download/details.aspx?id=42643

Logos Series X Pastor’s Library | Logos 3 Leader’s Library | 4 Portfolio | 5 Platinum | 6 Feature Crossgrade | 7 Essential | 8 M & W Platinum and Academic Professional | 9 Academic Professional and Messianic Jewish Diamond

Posts 7
Brian H. Caple | Forum Activity | Replied: Sun, Feb 1 2015 1:21 PM

Scott:

Thanks for the links. I had already tried the web installer, but tried it again. I got the same 'fatal error' message as before.

I think I understood the threads from the Logos forums.

1) I checked my update history. The last update installed was for version 5.4.1. I noticed the issue on that thread was Win 8.1. I'm running Win7, but assume the problem is the same regardless of Win version.

2) I ran the .NET Framework cleanup tool. I tried reinstalling the update after each step (I couldn't reboot because it told me to leave the window open in case I needed to proceed to the next step). Once the whole process was finished, it gave me a list of logs it would send to MS, saying they would contact me if they found a solution.

When possible, I have rebooted after every update attempt/cleanup/scan, but the update simply won't install.

I'm a little hesitant to uninstall .NET Framework completely, but am willing to try anything at this point. Is that an option?

Posts 737
Scott E. Mahle | Forum Activity | Replied: Sun, Feb 1 2015 2:09 PM

Hello again, Brian!

I was really hoping a reboot and reinstallation of Logos or 4.5.2 would fix the issue. You’ll need to wait until someone far more knowledgeable of the problem chimes in. Until then, you could search the forums for other possible solutions using Google and site:community.logos.com .net 4.5.2.

I’m sorry that didn’t work.

Logos Series X Pastor’s Library | Logos 3 Leader’s Library | 4 Portfolio | 5 Platinum | 6 Feature Crossgrade | 7 Essential | 8 M & W Platinum and Academic Professional | 9 Academic Professional and Messianic Jewish Diamond

Posts 26581
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Feb 1 2015 2:44 PM

Brian H. Caple:
I'm a little hesitant to uninstall .NET Framework completely, but am willing to try anything at this point. Is that an option?

I hope you have Windows 7 SP1. If you don't you should be able to to it from Windows Update! Then try the .NET 4.5.2 update.

Otherwise, uninstall .NET 4.5.1 from Programs and Features and try to install .NET 4.5.2 (ensure you have a restore point immediately before doing this)

Dave
===

Windows 10 & Android 8

Posts 7
Brian H. Caple | Forum Activity | Replied: Mon, Mar 23 2015 12:57 PM

Thanks, Dave. I do have SP1, but will try the uninstall and see if that does the trick. I think I've pretty much exhausted the Windows forums. Now I'm having trouble with the Update for Microsoft Visual Studio 2010 Tools for Office Runtime, too. Don't know if the two are related in any way...

Posts 26581
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Mar 23 2015 3:11 PM

Use Windows' Disk Cleanup and when it opens click the button to clean up System files. Get rid of large system files and temporary files.

Dave
===

Windows 10 & Android 8

Posts 7
Brian H. Caple | Forum Activity | Replied: Tue, Mar 24 2015 9:56 AM

Thanks, Dave. I run Disk Cleanup pretty regularly. Here's what I've done so far:

- Ran Microsoft Fit-it. Tried installing 5.4.2 manually, but it failed (Code 643)

- Ran Windows Update Troubleshooter, an got the following results:

     Windows update error 0x80070057 - not fixed

     service registration is missing or corrupt - fixed

     problem installing recent updates (the specific updates experiencing problems were not specified) - fixed

     problem installing recent updates (the specific updates experiencing problems were not specified) - fixed

- Tried installing 5.4.2 manually again but failed (Code 643)

- re-booted

- tried installing 5.4.2 manually again - failed

- went to remove 5.4.1 and noticed a 'repair' option, so I tried that

- re-booted, tried installing 5.4.2 manually - failed (Code 643)

- removed 5.4.1 and re-booted

- tried to install 5.4.2 from Windows Update - failed (Code 643)

I've looked up the codes in Microsoft Forums, but haven't had a lot of time to process what I'm reading.

Posts 26581
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Mar 24 2015 2:19 PM

Brian H. Caple:
I've looked up the codes in Microsoft Forums, but haven't had a lot of time to process what I'm reading.

Have you tried this MS forum suggestion?

BTW you are using  5.4.1, 5.4.2 instead of  4.5.1 & 4.5.2 as versions of .NET.

You may have to reload Windows 7 if none of these are working, or recover it from a Recovery disk

Dave
===

Windows 10 & Android 8

Posts 30
Diego Lara | Forum Activity | Replied: Wed, Mar 25 2015 9:30 AM

Try running the following tools

.NET REPAIR TOOL

http://www.microsoft.com/en-us/download/details.aspx?id=30135

.NET CLEAN UP TOOL  ( I would try this one and then try reinstalling again )

http://blogs.msdn.com/cfs-file.ashx/__key/CommunityServer-Components-PostAttachments/00-08-90-44-93/dotnetfx_5F00_cleanup_5F00_tool.zip

Logos 6 Platinum on Windows 10

Posts 7
Brian H. Caple | Forum Activity | Replied: Thu, Jun 4 2015 2:40 PM

Thanks to everybody who offered assistance. After trying everything else (most multiple times), I ended up wiping the drive and starting fresh. Both Windows and Logos updates all loaded without incident. Do I dare try to update to Logos 6? :o)

Posts 26581
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jun 4 2015 5:02 PM

First install .NET 4.5.2 from http://www.microsoft.com/en-au/download/details.aspx?id=42643
When you see Microsoft .NET Framework 4.5.2 in Programs and Features then you should try Logos 6.

Dave
===

Windows 10 & Android 8

Posts 26581
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Jun 7 2015 8:39 PM

Any progress, Brian?

Dave
===

Windows 10 & Android 8

Page 1 of 1 (13 items) | RSS