Please make logos load in under 5 seconds

Page 1 of 1 (9 items)
This post has 8 Replies | 3 Followers

Posts 1030
John Goodman | Forum Activity | Posted: Thu, Mar 26 2015 10:14 AM

We the undersigned challenge faithlife (in good humour and with respect) to improve the cold startup time of logos to under 5 seconds including web sign in on mid range computers ie. anything i5, 4gb ram, ssd or above & broadband speeds of 8mbit or above.

Please give your support to this long standing uservoice request. (not my own)

https://logos.uservoice.com/forums/42823-logos-bible-software-6/suggestions/2690871-optimize-startup-time

John

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 1006
Tom Reynolds | Forum Activity | Replied: Thu, Mar 26 2015 11:09 AM

I guess it depends on what you mean by load. Logos includes this info which might be taken as the baseline:

Info OurApp Showing main window at 68.323 seconds.

Perhaps we should compare this time from a cold start but I don't think it's possible to get that to 5 secs. I have an i7-4810, SSD, 24GB ram and a 27Mbps connection.

Posts 700
Jerry Bush | Forum Activity | Replied: Thu, Mar 26 2015 11:41 AM

I have a modest machine and when I added an SSD my load times went down significantly. I average around 10-12 seconds on my Windows machine at work.

I have a Mac at home and I never really timed it but it might be a little faster than that.

Jerry

Win7 - - Intel Core i3, 530 @ 2 .93GHz - - 6GB RAM ATI Radeon HD Samsung 500GB SSD

Burning Bush Ministries

Posts 700
Jerry Bush | Forum Activity | Replied: Thu, Mar 26 2015 11:43 AM

I just noticed that my SSD is not reflected in my signature. I don't remember how to update it.

Where do I go for that?

Win7 - - Intel Core i3, 530 @ 2 .93GHz - - 6GB RAM ATI Radeon HD Samsung 500GB SSD

Burning Bush Ministries

Posts 22227
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Mar 26 2015 11:46 AM

Jerry Bush:

my signature. I don't remember how to update it.

Where do I go for that?

Click on "edit" at the top of the browser screen to get to the edit page.

Posts 700
Jerry Bush | Forum Activity | Replied: Thu, Mar 26 2015 11:58 AM

How did I ever miss that? Wow - I feel really goofy.

Thanks Graham!

Jerry

Win7 - - Intel Core i3, 530 @ 2 .93GHz - - 6GB RAM ATI Radeon HD Samsung 500GB SSD

Burning Bush Ministries

Posts 1006
Tom Reynolds | Forum Activity | Replied: Thu, Mar 26 2015 12:58 PM

Jerry Bush:

I have a modest machine and when I added an SSD my load times went down significantly. I average around 10-12 seconds on my Windows machine at work.

Do you have logging enabled? If so could you check for the line: Info OurApp Showing main window at xx.xxx second

Mine takes 68.323 secs to get there so I find it hard to believe that you are fully loaded in 10-12 secs. Perhaps it depends on resources. Do you have very many?

Posts 645
Jim | Forum Activity | Replied: Thu, Mar 26 2015 4:25 PM

John Goodman:
We the undersigned challenge faithlife (in good humour and with respect) to improve the cold startup time of logos to under 5 seconds including web sign in on mid range computers

This would be absolutely wonderful. I'm guessing that the start-up time depends on the amount of resources, panes etc. that are loaded. When I've used the computers at Morris' seminars they load an change layouts very fast, but for my setup - on a recently purchased quad core i5, Logos takes 30 seconds minimum to load, another 10-15 seconds if I want to change layouts.

Furthermore, if I buy something from Logos, then after Logos starts, it wants me to restart it to load new resources with the additional time of "praparing the library" even when that is rather minimal. Since Logos WANTS me to "keep on buying" (present active indicative) new stuff, as far as I'm concerned (meaning I don't assume to speak for anyone else) it would be better to make loading new resources as invisible and painless as possible which is not the current case.

I hope some improvement in this area is being considered.

Have a great day,
jmac

Posts 5253
Dan Francis | Forum Activity | Replied: Thu, Mar 26 2015 5:35 PM

Fixed please ignore.

-Dan

Page 1 of 1 (9 items) | RSS