[ACK] Repeatable CRASH 6.4 Beta 5 - using secondary grouped library

Page 1 of 1 (10 items)
This post has 9 Replies | 0 Followers

Posts 10047
Forum MVP
NB.Mick | Forum Activity | Posted: Tue, Jun 16 2015 3:09 AM

Just using the secondary grouped library (first by new field license, then by type) opening/closing a group of reources will crash Logos

Error ID: 7021 / 4261
Error detail: ArgumentException: Width and Height must be non-negative.

This is repeatable (since the grouped library comes up at restart). Note: in the repeat crash, detection was still running, therefore the yellow info bar - in the first crash, not so. I include the beta install log in the first zip and the event log entries (third zip, German and English) as it seems to crash .NET

2541.6.4 beta 5.crash.zip

5287.6.4 beta 5 crash repeat.zip

2867.crash 6.4 beta 5.zip

Running Logos 8 latest beta version on Win 10

Posts 21928
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jun 16 2015 3:25 AM

I can't reproduce this in beta 5 on Windows 8.1

I don't have any temporary licences which may be a factor.

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Jun 16 2015 4:01 AM

I can't reproduce it on Windows, either.

Posts 10047
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Jun 16 2015 4:33 AM

Hm. Maybe it's an overtaxing of my weak graphics subsystem?

I tried to reproduce and it worked snappy and everything for several open / close /scroll operations and I just thought let it be when (I think) I clicked one open/close before it had displayed the prior operation and the crash was there.

1307.crash 3.zip

So for me - with some effort - still repeatable.

Will try to repeat without the licence field in the grouping 

EDIT: yes, crashes with first grouping edition, second grouping type, too.

I had a hard time crashing it (saw more of the white display than otherwise) - in the end I think all secondary groups were closed and it crashed when I wanted to collapse the primary edition Logos group.

8168.Crash 4.zip  

(Faithlife: when more eventviewer details are needed, please say so)

Running Logos 8 latest beta version on Win 10

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Tue, Jun 16 2015 10:27 AM

I am not able to reproduce this internally, I have created a ticket and we are looking into it.

Posts 10047
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Jun 16 2015 10:32 AM

Thanks, Steve.

Running Logos 8 latest beta version on Win 10

Posts 10047
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Jun 19 2015 12:44 PM

Steve Workman:
I am not able to reproduce this internally

I can reproduce this at will now in easy steps. Maybe a Win32 issue?

It crashes .NET and then the kernelbase.dll of Windows, see the txt file I made from events at crash #3 today: 8176.Crash .NET from EventViewer.txt 

Try those steps to reperform:

  1. Open the library in a floating window, in Details view 
  2. (if necessary, neutralize existing groupings by sorting, e.g. per title or last update)
  3. group by a column, e.g. Edition => the groups will all be collapsed
  4. expand one group, e.g. Edition Logos, select a resource (I do this to make sure secondary grouping works)
  5. Shift click another grouping column, e.g. Type => the subgroups headers within this group are expanded, the other groups are collapsed, no resource line is shown
  6. Collapse the group opened in step 4 => Logos crashes

Logs: 7725.LogosCrashes.zip

These are four crashes, the screenshot above is from #4

Running Logos 8 latest beta version on Win 10

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Fri, Jun 19 2015 1:20 PM

NB.Mick:
I can reproduce this at will now in easy steps. Maybe a Win32 issue?

I can reproduce this on a 32-bit machine, but not a 64-bit. I've updated the case with this info. Thanks, NB. Smile

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 10047
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Jun 19 2015 5:13 PM

Dylan Rondeau:

NB.Mick:
I can reproduce this at will now in easy steps. Maybe a Win32 issue?

I can reproduce this on a 32-bit machine, but not a 64-bit. I've updated the case with this info. Thanks, NB. Smile

Thank you, I hope to see this fixed (the first was involuntary as I checked the licence fix...)

Running Logos 8 latest beta version on Win 10

Posts 1471
Angela Murashov | Forum Activity | Replied: Mon, Jul 27 2015 10:07 AM

Dylan Rondeau:

NB.Mick:
I can reproduce this at will now in easy steps. Maybe a Win32 issue?

I can reproduce this on a 32-bit machine, but not a 64-bit. I've updated the case with this info. Thanks, NB. Smile

This should be fixed in 6.5 Beta 4. 

Page 1 of 1 (10 items) | RSS