[ACK] Mac app won't launch correctly after update to 6.4

Page 1 of 2 (30 items) 1 2 Next >
This post has 29 Replies | 7 Followers

Posts 1471
Angela Murashov | Forum Activity | Posted: Tue, Jun 30 2015 9:14 AM

Mac users who have the alias shortcut on their Dock (small black arrow in the corner) will not be able to launch the Logos app after updating to 6.4. The bad Dock icon contains an old framework that we later changed in 6.4 beta. Unfortunately, the old icon cannot be changed to the correct framework without running the update. 

Steps to get the app to launch correctly after 6.4 update:

1. Force Quit the Logos app

2. Open Logos from your Applications folder

This is a one-time requirement. After running from the Applications folder once, the Dock will be perfectly usable. Sorry for the inconvenience. 

We are currently investigating this issue to find an better solution for this.

Posts 2
Kerry Buttram | Forum Activity | Replied: Tue, Jun 30 2015 9:39 AM

Now I can't even get my Logos to force quit after this update.

Posts 506
Tim Taylor | Forum Activity | Replied: Tue, Jun 30 2015 9:55 AM

Thanks so much, this fixed it for me, I was starting to get worried. I'm glad you posted this! I was about to create a forum topic asking for help but then I found this, so now I don't have to because it's fixed! Thanks again. :)

Posts 2
Kerry Buttram | Forum Activity | Replied: Tue, Jun 30 2015 10:12 AM

All attempts to Force Quit have not been successful. I am not able to even reboot the Mac at this point due to Logos not allowing it.

Posts 1576
Forum MVP
Levi Durfey | Forum Activity | Replied: Tue, Jun 30 2015 10:15 AM

Kerry Buttram:
All attempts to Force Quit have not been successful. I am not able to even reboot the Mac at this point due to Logos not allowing it.

You can do a hard shut down by holding down on your Mac's power button until it shuts down. You will lose unsaved documents.

Posts 41
Edward Hatch | Forum Activity | Replied: Tue, Jun 30 2015 10:53 AM

I tried and my Logos 6 will not open from my applications folder.

Posts 2
Bernard Duchesne Jr | Forum Activity | Replied: Tue, Jun 30 2015 11:25 AM

Edward, my MacBookPro did the same thing.  Do a Spotlight search of the Logos application.  When I did that, it opened immediately and the icon was back on the task bar.  Hope this helps.

Bernard

Posts 41
Edward Hatch | Forum Activity | Replied: Tue, Jun 30 2015 12:22 PM

Thanks, Bernard

I tried it and it still didn't work.

Posts 10554
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Jun 30 2015 1:04 PM

Perhaps the download of 6.4 somehow became corrupted. Try installing 6.4 manually. The link should be contained in the release notes for 6.4.

Oops. Found this in the Release Notes

We have temporarily removed the 6.4 update for Mac while we investigate a solution for the broken Dock icon.  If you have already updated to 6.4 and are not able to launch the program from your dock, please open the software from either the Applications folder, Spotlight or Launchpad.

Try contacting Customer Service or wait for a Logos employee to address your issue.

Posts 3153
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Jun 30 2015 4:27 PM

Edward Hatch:

Thanks, Bernard

I tried it and it still didn't work.

Hi Edward,

Try deleting the application file from the Applications folder and download a new one from here https://www.logos.com/product/46767/logos-6-core-engine. I'm going to email you the link. 

 

Posts 3153
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Jun 30 2015 4:28 PM

Kerry Buttram:

All attempts to Force Quit have not been successful. I am not able to even reboot the Mac at this point due to Logos not allowing it.

You may need to kill Logos through the Activity Monitor (https://support.apple.com/kb/PH5147?locale=en_US). Then Start Logos from the Applications folder.

 

Posts 12
Bora Chheang | Forum Activity | Replied: Wed, Jul 1 2015 1:05 AM

Mine still does not work. I tried all that everybody mentioned but it still does not work. 

Posts 27684
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Jul 1 2015 5:37 AM

Bora Chheang:

Mine still does not work. I tried all that everybody mentioned but it still does not work. 

Please create a new thread and explain your issue clearly. You should be explicit about what you have tried.

OSX & iOS | Logs |  Install

Posts 41
Edward Hatch | Forum Activity | Replied: Wed, Jul 1 2015 7:38 AM

This worked, thanks!

Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, Jul 1 2015 2:55 PM

Angela Murashov:
We are currently investigating this issue to find an better solution for this.

This has been fixed in 6.4 SR-1.

Fixed crash on launch when starting the application on Mac from the old alias Dock icon. Using the alias Dock icon will now properly launch the app, and the alias will be removed upon next launch. 

  • Note: With this change, it is no longer necessary to run the app from the Applications folder after updating to 6.4.
Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, Jul 1 2015 2:55 PM

Angela Murashov:
We are currently investigating this issue to find an better solution for this.

This has been fixed in 6.4 SR-1.

Fixed crash on launch when starting the application on Mac from the old alias Dock icon. Using the alias Dock icon will now properly launch the app, and the alias will be removed upon next launch. 

  • Note: With this change, it is no longer necessary to run the app from the Applications folder after updating to 6.4.
Posts 12
Bora Chheang | Forum Activity | Replied: Wed, Jul 1 2015 6:22 PM

I'm currently downloading the file again. Yesterday, I did not even have that option. 

Posts 17
Mario Arias | Forum Activity | Replied: Thu, Jul 2 2015 3:15 PM

is failing for me too, and I don't have Logos on my dock. The application now just doesn't start.

Where I could find the link to downloaded it again? 

Posts 17
Mario Arias | Forum Activity | Replied: Thu, Jul 2 2015 3:23 PM

I found it, seems like is working now

Posts 3
Samuel Leonor | Forum Activity | Replied: Tue, Jul 7 2015 3:02 AM

Has this issue been resolved? My Logos 6 on MacBook Pro did not start this morning. Rebooted the computer but it is still completely dead. Should I delete the application and re install it? 

Page 1 of 2 (30 items) 1 2 Next > | RSS