Trouble downloading Logos 6 to windows device

Page 1 of 1 (2 items)
This post has 1 Reply | 0 Followers

Posts 13
Martin Scott Kemp | Forum Activity | Posted: Thu, Jul 9 2015 8:13 PM

Hi everyone,

I usually use logos on a mac. I've been trying to access logos on a new Microsoft surface. When I try and download the core engine it says that I already own it. I've tried following the link to the download page, but the link takes me to a page describing system requirements, with another link directing me to the store which then tells me that I already own the engine. I just cant seem to get to the download page.

I tried downloading the engine as a different user, and then logig in with my original account, this seemed to work, but I want to download it with my original account to lessen the messiness of the situation. So ive uninstalled logos 6 and am trying again, but am back to the same problem of not being able to find the down load page.

Any idea?

Posts 29718
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Jul 9 2015 8:34 PM

Please use your original thread: 

macOS, iOS & iPadOS | Logs |  Install

Page 1 of 1 (2 items) | RSS