System folder and Smart Tags in v6.7

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 25038
Forum MVP
Dave Hooton | Forum Activity | Posted: Sun, Nov 1 2015 1:46 AM

With a return to use of the System folder in the last beta Smart Tags registration appears to have gone backward as there is no Action in Word 2016. Can anyone use Smart Tags in 6.7 RC1 (probably in Word 2013 or earlier)?

Why the return to the System folder? Does it signify a change for Smart Tags to work in Office 2016?

Dave
===

Windows & Android

Posts 4628
Forum MVP
Fred Chapman | Forum Activity | Replied: Sun, Nov 1 2015 4:21 AM

Dave Hooton:
Can anyone use Smart Tags in 6.7 RC1 (probably in Word 2013 or earlier)?

I am running Win 10 and Office 2013. It works fine for me.

Posts 25038
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Nov 1 2015 12:08 PM

Thanks Fred.

I manually registered the Smart Tag (dll) and it is fully functioning in Word 2016 i.e. it now has "Replace with Passage".

Dave
===

Windows & Android

Posts 25038
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Nov 4 2015 10:17 AM

Dave Hooton:
Why the return to the System folder? Does it signify a change for Smart Tags to work in Office 2016?

Bump for Faithlife.

Dave
===

Windows & Android

Posts 1646
SteveF | Forum Activity | Replied: Wed, Nov 4 2015 7:07 PM

Dave Hooton:
Smart Tags in 6.7 RC1 (probably in Word 2013 or earlier)?

I cannot get it to work in Word 2010, nor in Word 2013.

["Smart Tags" does not even show as an option when you do the right click menu and click on "Additional Actions/options" etc]

I have tried the earlier suggestion to "repair."

I was unable to successfully  successfully completed the Command prompt suggestion this time. [Previous 'broken" smart tags were repaired that way.]

Thanks for working at a fix.

p.s. [I do not think that this should make a difference, but] I am running the new 6.7 on the "stable" [channel] etc [ie I did not participate in the 6.7 beta version]

[Edit] I was finally able to "register" the smart tag dll [it is now in the "system" drawer; Smart Tags are also a visible choice in the Additional Actions/options menu, BUT [with Word 2010 & or Word 2013 running] this feature does not work.

I had assumed that if I could finally see that it was an option in Word that it would work.Sadly "no"

I did close off all of these programs and re-boot [once] but that has not yet helped either. 

What step did I miss? Suggestions?

 

Regards, SteveF

Posts 9097
Forum MVP
Mark Smith | Forum Activity | Replied: Wed, Nov 4 2015 7:44 PM

I have it working in Word 2016 under Win 10 after repairing my Logos installation. It did not appear until I did that.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 1646
SteveF | Forum Activity | Replied: Wed, Nov 4 2015 8:33 PM

Well after getting the Smart Tag options to "appear" but not to work

I again  "repaired"  Logos in the control panel.

Bad move.

Now Smart Tags are again "missing" from the right click menu in both Word 2010 & Word 2013.

I have to assume that "repair" has "de-registered" the Smart tag. The dll is still visible in the System drawer.

2 hours of frustrating work down the drain ...

Regards, SteveF

Posts 13
David Grace | Forum Activity | Replied: Thu, Nov 5 2015 12:55 AM

Dave I lost my smart tags when I downloaded the 6.7! I get so frustrated with logos when they so call fix something and it takes away the best feature. I do not know really how to reinstall them if it can be done. please help

Posts 25038
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Nov 5 2015 2:41 AM

All

We have these registration steps for Smart Tags (32-bit Office) in 64-bit Logos/Verbum that were previously working:-

  1. “%LOCALAPPDATA%\Logos\Logos.exe” /register
  2. regsvr32 “%LOCALAPPDATA%\Logos\System\L4SmrtTg.dll”

Note the \Logos\ folder could be \Logos4\, \Logos5\ or \Verbum\ for your installation.

#2 is necessary. Please note the spelling of the dll and its location in the \Logos\System\ folder; a reversion to Logos 6.2 and earlier. If you have a custom installation then make sure the path to your Logos folder is correct.

Perform these command(s) in a Command Prompt that is "run as administrator".

If you have a problem please show the format of the command(s) you used e.g. a screen shot of the Command Prompt window.

Dave
===

Windows & Android

Posts 1646
SteveF | Forum Activity | Replied: Thu, Nov 5 2015 10:21 AM

Thanks Dave:

I'm still not sure how, but this finally worked for me.

Word 2010 = yes smart tags visible and working

Word 2013 = yes smart tags visible and working

Thanks

Regards, SteveF

Posts 13
David Grace | Forum Activity | Replied: Thu, Nov 5 2015 11:00 AM

Steve could you send what you did to get your smart tags back? I am not very computer smart so please give me common words. LOL

Posts 1646
SteveF | Forum Activity | Replied: Thu, Nov 5 2015 1:04 PM

It is not for the faint of heart.

It involves using the Windows "Command Prompt" utility in Administrator mode.

Mine was made more difficult by the fact that my Logos installation is not in the usual "C" drawer.

I typed in so many versions of the "code" that I am not really sure which was the final version.

Re the first line of Dave's suggestion: It does not help that due to the way Logos installs that many of us now have different names on our particular Logos drawer. Even though I am running Logos 6.7 Logos has named my program drawer Logos 5. I had to substitute the actual path name in place of the %LOCALAPPDATA% etc." so at the prompt  I typed D:\Steve Laptop\Logos5\Logos.exe  and then when I hit enter it told me that it had "registered."  [ie that it now knew where the program was located].

Dave's second line: that means you also have to get the name right. For example I had to add the number "5" as in Logos5\System etc.

I believe that the point of this 2nd line is to make the Smart tag operative.    so for my installation at the cursor I had to type in 

regsvr32 D:\Steve Laptop\Logos5\System\L4SmrtTg.dll

The good news: If you type it in "wrong" it just gives you an error message. I've never "broken"something doing this.

In one of the threads there is a link to similar instructions in the WIKI

It was also important to have had the "correct" Smart Tag dll [as you are probably aware there are different ones for 32 bit Office [which I have] & 64 bit office. There is also a different one depending on whether your Windows is 32 or 64 bit [like mine]. 

 There are a number of decisions/factors to solve when the Logos programmers "break" this "un-supported" feature. 

 I realize that this is not very helpful.

[Doing this from memory means that I still may have errors in those above lines]

Regards, SteveF

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Fri, Nov 13 2015 3:51 PM

Concerning Smart Tags on Windows, please try the updated PowerShell script RegisterSmartTags.ps1 discussed at https://community.logos.com/forums/p/105737/780081.aspx#780081.

Thanks,

Bryan

Page 1 of 1 (13 items) | RSS