L4 Beta 9, highlighting / visual filter refresh issue

Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 225
Michael Birney | Forum Activity | Posted: Wed, Feb 17 2010 3:24 PM | Locked

This is a little hard to explain.  If it is really confusing ask, I'll try again.

If I create a new style in highlighting, and then move to the visual filter and try to use that new style, it does not show up.  I have to close both the highlight tab, and the visual filter tab, and then open them back up to use my new style.  

Not a giant issue, it was just annoying while I was doing a new visual filter, and saw the "need" for a couple of new styles.

Was also able to crash L4 somehow while playing with this right now, actually my 3rd every crash - but opened right back up.

Posts 4508
Robert Pavich | Forum Activity | Replied: Wed, Feb 17 2010 3:26 PM | Locked

I noticed this...it's hard to make several styles at once and use them on the fly...

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 4077
Melissa Snyder | Forum Activity | Replied: Thu, Feb 18 2010 11:37 AM | Locked

Michael Birney:
Was also able to crash L4 somehow while playing with this right now, actually my 3rd every crash - but opened right back up.

If you can reproduce this, could you enable logging and attach the log file? You'll find instructions here: http://www.logos.com/L4/Support/DiagnosticLogging.

We'll look into the other issue.

Thanks,
Melissa

Posts 225
Michael Birney | Forum Activity | Replied: Fri, Feb 19 2010 5:05 AM | Locked

When it crashed it I did let it do it MS reporting, I am pretty sure you get those.  I have not been able to reproduce the crash.

Posts 19634
Rosie Perera | Forum Activity | Replied: Fri, Feb 19 2010 5:10 AM | Locked

Michael Birney:

When it crashed it I did let it do it MS reporting, I am pretty sure you get those.  I have not been able to reproduce the crash.

MS reporting goes to MS, not Logos.

If you're using 4.0b Beta 10 or later, the crash should have produced a file called crash.txt in your Logos Log Files folder. That might be useful to Logos in tracking down this bug.

Posts 9194
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Fri, Feb 19 2010 7:54 AM | Locked

Rosie Perera:

Michael Birney:

When it crashed it I did let it do it MS reporting, I am pretty sure you get those.  I have not been able to reproduce the crash.

MS reporting goes to MS, not Logos.

Microsoft provides a website where we can log in and see those crash reports. (It takes about a week for them to show up, and then they're grouped by crash site and sorted by frequency, so we can't find "your" crash, or easily trace a specific crash back to an individual user.) It is still helpful (for us) to submit the crash, because it lets us know what's commonly happening in the field, and does provide additional debugging information for hard-to-reproduce bugs.

Rosie Perera:

If you're using 4.0b Beta 10 or later, the crash should have produced a file called crash.txt in your Logos Log Files folder. That might be useful to Logos in tracking down this bug.

It will be called "Logos4Crash.txt" (the Indexer will produce Logos4IndexerCrash.txt) and it should help us identify the problem if you attach it here.

Posts 225
Michael Birney | Forum Activity | Replied: Fri, Feb 19 2010 8:56 AM | Locked

The only crashtext log I could find.  I never have reproduced this, so it is not a big deal to me.

 

Program Version: 4.0b Beta 11 (4.02.3.6685)

Windows Version: 6.1.7600.0

Time: 2010-02-18 17:41:45

Installed memory: 3,327 MB

Install path: C:\Users\Mike\AppData\Local\Logos4\System\Logos4.exe

Free disk space: 159,176 MB

Temp path: C:\Users\Mike\AppData\Local\Temp\

Free temp space: 159,176 MB

 

Error ID: 3093

Error detail: InvalidOperationException: Database is not open

 

System.InvalidOperationException: Database is not open

   at System.Data.SQLite.SQLiteCommand.InitializeForReader()

   at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)

   at System.Data.SQLite.SQLiteCommand.ExecuteDbDataReader(CommandBehavior behavior)

   at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()

   at Libronix.Utility.Data.PoolableConnector.ExecuteReader(String strText, Object[] aobjParameterNamesAndValues)

   at Libronix.DigitalLibrary.VisualMarkup.VisualMarkupManager.VisualMarkupManagerSql.GetCustomStyle(IConnector conn, String strId, Boolean bIsDeleted)

   at Libronix.DigitalLibrary.VisualMarkup.VisualMarkupManager.GetStyleByName(String strName)

   at LDLS4.Panels.VisualFilterPanel.VisualFilterDocumentUserVisualFilterManager.FilterCache.<RefreshWork>d__b.MoveNext()

   at Libronix.Utility.Threading.AsyncWorkerTask`1.EnumMoveNext()

   at Libronix.Utility.Threading.AsyncWorkerTask`1.ContinueExecution()

   at Libronix.Utility.Threading.AsyncAction.Continue()

   at Libronix.Utility.Threading.ThreadPoolAsyncAction.<Start>b__0(Object )

   at Libronix.Utility.Threading.GroupedThreadPool.ExecuteNextCallback(Object state)

   at System.Threading._ThreadPoolWaitCallback.WaitCallback_Context(Object state)

   at System.Threading.ExecutionContext.runTryCode(Object userData)

   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)

   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)

   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Feb 19 2010 9:52 AM | Locked

Michael Birney:
The only crashtext log I could find.  I never have reproduced this, so it is not a big deal to me.

Thanks--I've submitted the crash information.

Update:  The issue causing this crash will be fixed in the next release.

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Feb 19 2010 9:59 AM | Locked

Michael Birney:
If I create a new style in highlighting, and then move to the visual filter and try to use that new style, it does not show up.  I have to close both the highlight tab, and the visual filter tab, and then open them back up to use my new style.  

I find that I can leave the Highlighting panel open, but do have to close and reopen the Visual Filter document to choose the new style. I'll submit a request to make a new style available right away.

Thanks,
Melissa

Page 1 of 1 (9 items) | RSS