Linux version of Logos Bible Software

Page 66 of 71 (1406 items) « First ... < Previous 64 65 66 67 68 Next > ... Last »
This post has 1,405 Replies | 67 Followers

Posts 6
Henry Mathews | Forum Activity | Replied: Mon, Nov 15 2021 9:32 PM

I am on Linux Mint 20.2 Cinnamon. Cinnamon version 5.07. 

I am using wine installer 5.0.3 and wine package 5.0-3 ubuntu1.

Below is the error text that I saved.

Thank you for your help with this.

7774.Logos Error.txt

Posts 1261
John Goodman | Forum Activity | Replied: Tue, Nov 16 2021 3:13 AM

Henry Mathews:

I am on Linux Mint 20.2 Cinnamon. Cinnamon version 5.07. 

I am using wine installer 5.0.3 and wine package 5.0-3 ubuntu1.

Hi Henry, This version of wine is too old for Logos. I recommend 6.0.2 as the latest stable version or newer. There are are some issues with certain wine-devel or wine-staging releases because these are in effect alphas and betas. Otherwise go with the app image from the ferion script. That will not affect any other wine apps on your system. If you want the latest wine-devel which works well I think its 6.17. Current work is going towards trying to ensure wine 7 will be reliable when it comes out just after Christmas.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 6
Henry Mathews | Forum Activity | Replied: Wed, Nov 17 2021 10:27 PM

Thanks for the quick reply John. I didn't get a chance to check the message yesterday. Do you recommend uninstall and reinstall of Wine and Logos? If Wine 7 is going to be more stable then should I wait till then or does that make any difference? Sorry, I am limited when it comes to my knowledge of Linux. Thanks.

Posts 1261
John Goodman | Forum Activity | Replied: Wed, Nov 17 2021 11:23 PM

Your easiest option is to run the script again on choose to use the appimage. if you are distribution has it you could update wine via the package manager instead. 

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 6
Henry Mathews | Forum Activity | Replied: Thu, Nov 18 2021 10:22 PM

Hi John, just to clarify I am following the steps in the instructions below - is that right? Sorry, I am still getting my way around Linux.

https://github.com/ferion11/LogosLinuxInstaller

and follow the instructions of this little video:

There is a small video of the installation using the fast_install_AppImageWine_and_Logos.sh [by clicking here]. You can download the latest release [CLICK HERE].

Posts 1261
John Goodman | Forum Activity | Replied: Fri, Nov 19 2021 5:31 AM

Yes this is the one

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 2
Capulo, Filipe Paes | Forum Activity | Replied: Sat, Nov 20 2021 3:28 AM

Logos is no more showing pop-up when i put the mouse over some link or when i clik in a word or in the notification status. Is possivel solve it?

Posts 182
Paul Unger | Forum Activity | Replied: Sat, Nov 20 2021 7:49 AM

@ Capulo, Filipe Paes: Are you putting your mouse cursor right over the link or word you want to see? With my version of Linux (Wasta 20.04; Ubuntu derivative) and mouse (Microsoft Mobile Mouse 3500) I have to be off to the side a bit for the link to show it's active / ready to be clicked... It's something I've had to get used to, as I don't know any way to calibrate a mouse pointer. Maybe try moving your pointer around a bit to see if that works?

Posts 736
Frank Sauer | Forum Activity | Replied: Sat, Nov 20 2021 8:24 AM

Capulo, Filipe Paes:

Logos is no more showing pop-up when i put the mouse over some link or when i clik in a word or in the notification status. Is possivel solve it?

This is a known issue, as reported here - https://bugs.winehq.org/show_bug.cgi?id=51984

John appears to have found the regression that caused the issue, hopefully it gets corrected soon.

Posts 36
Jerry C. Wong | Forum Activity | Replied: Thu, Dec 16 2021 3:21 PM

3821.backtrace.txt

Hi John,

   I have been installing, deleting, reinstalling, trying different scripts - none works.  Here's my problem.  Following the video and using fast install, everything goes well until the Logos starts I can login just fine, but when it begins to download resources, the fatal error shows up and I can't proceed.  Any ideas?  I'm on Mint 20.2 Cinnamon.  Thanks.

Posts 1261
John Goodman | Forum Activity | Replied: Thu, Dec 16 2021 3:44 PM

Jerry, your version of wine is too old. I recommend using the appImage install option. best wishes, John

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 1261
John Goodman | Forum Activity | Replied: Thu, Dec 16 2021 3:49 PM

Frank Sauer:

Capulo, Filipe Paes:

Logos is no more showing pop-up when i put the mouse over some link or when i clik in a word or in the notification status. Is possivel solve it?

This is a known issue, as reported here - https://bugs.winehq.org/show_bug.cgi?id=51984

John appears to have found the regression that caused the issue, hopefully it gets corrected soon.

For now you can roll back to an earlier version of wine, I think that bug was introduced in 6.23. On the telegram group I posted a 'patched' build of 6.23 which you can use. The fix will not arrive in any official packages until 7.0 final is released. The bug is still present in the release candidate.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 2
Tim Souther | Forum Activity | Replied: Fri, Dec 17 2021 7:28 AM

John,

I am another neophyte w/Linux and especially w/trying to download and set up Logos. My Linux distro is Ubuntu 20.04 and I have Wine 6.0.2 (should I be using 6.19?).

So, when I view the video that demonstrates Logos installation, at the beginning the contents of Download are, "Logos-x86.msi", "wine-staging-linux-x86-v5.11-f11-86_64.AppImage" and "wine32_bottle.tar.gz". (Is it significant that each filename is a different color?) I assume I need to have these files. And, if so, how do I get them?

Warning, this may only be the beginning of allaying my confusion. Wink

Tim

Posts 1261
John Goodman | Forum Activity | Replied: Fri, Dec 17 2021 9:29 AM

Hi Tim,

No worries, it can be a lot to learn. Wine 6.0.2 works ok by my recollection. In general people are better off using the appImage because it will be a prepackaged and carefully selected version which Daniel will have tested for stability and may have patched with bug fixes etc. The script downloads the appImage and the wine bottle during installation. The wine bottle is essentially a directory which contains windows apps and configuration. It is generally best to have one app in each wine bottle as they can require different configurations. The downloaded one is preconfigured for font smoothing and a few other things which makes Logos run nicely.

I hope that helps?

John

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 2
Tim Souther | Forum Activity | Replied: Fri, Dec 17 2021 2:12 PM

Thanks John!

It's installed and seemed to work. Two issues though...

- There's a process that kept on running underr Terminal. It seems to have stopped but I'm not sure what that's about. Is it OK to just shut Terminal down?

- Now that I've closed Logos I don't know / can't seem to find where to go to open it again?

Posts 1261
John Goodman | Forum Activity | Replied: Fri, Dec 17 2021 2:22 PM

Open a terminal and go to

(From memory but you should find a folder with a similar name if not this. ~ is a shortcut which means home dir. e.g. /home/john

cd ~/LogosBible_Linux_P

To create a shortcut, run ./Logos.sh shortcut

Wine processes sometimes linger for longer than you'd expect but they do usually terminate ok. If not, then closing the terminal should be fine.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 182
Paul Unger | Forum Activity | Replied: Fri, Dec 17 2021 2:24 PM

Tim Souther:

Thanks John!

It's installed and seemed to work. Two issues though...

- There's a process that kept on running underr Terminal. It seems to have stopped but I'm not sure what that's about. Is it OK to just shut Terminal down?

- Now that I've closed Logos I don't know / can't seem to find where to go to open it again?

Hi Tim,

My struggles with creating a shortcut are found on page 62 of this thread. Maybe one of the suggestions there will help. Aside from that, there are some instructions on the ferion11 script page (in #23, way at the bottom), but I found them quite cryptic... I do have a shortcut in my Start menu now, but I can't tell you how I got it there... Maybe a restart is necessary?

Posts 36
Jerry C. Wong | Forum Activity | Replied: Fri, Dec 17 2021 2:46 PM

That did it.  Thanks John!!  Linux newbie and grateful for the help.  It's great to be able to prolong the usefulness of old equipment to save $$.  Thanks again.

Posts 1261
John Goodman | Forum Activity | Replied: Sat, Dec 18 2021 1:12 AM

I'm pleased you got it working. If you haven't found it yet, take a look at this page https://appdb.winehq.org/objectManager.php?sClass=version&iId=39484 which will give you an idea of what works and what doesn't. The big problems are media playback (use the web app instead) and printing (copy and paste to libreoffice instead). Printing is pretty close to a fix, the media playback functionality is being worked on but will likely take longer. In both cases, the work around is easy enough. I use Logos on linux most days and rarely run into any issues.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 1
Brian Wiles | Forum Activity | Replied: Sat, Dec 18 2021 8:04 AM

Hi John,

I can't tell you how much I appreciate your work on this! One question though: Would there be a way to edit the script so it will install the Verbum app instead of Logos? How should I go about that?

Thank you and God bless!
Brian

Page 66 of 71 (1406 items) « First ... < Previous 64 65 66 67 68 Next > ... Last » | RSS