Morph Visual Filters in Reverse Interlinears not working.

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 70
Robert le Clus | Forum Activity | Posted: Thu, Jan 21 2016 9:07 PM

It seems since Logos 6 my favourite visual filter no longer works on reverse interlinears like the ESV. I created a visual filter many years ago that highlights all the verb moods in the ESV using a morph filter.

For some reason it kept working in Logos 6 (after I upgraded) but I could not create any new ones that worked. Now I have Logos 6 installed on a new machine and my filter is there but it refuses to work in the ESV or NASB. It appears in the Documents drop down but not in the ESV Visual Filters drop down.

I have reindexed and no joy. The same visual filter works great on the NA28. Pity I can't read Greek properly yet.

This is either a bug or a serious loss in functionality. Neither option is very pleasing. Any thoughts from the forum?

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Jan 21 2016 11:36 PM

Please post a screenshot (using the paperclip icon) of your Visual Filter definition

Posts 32587
Forum MVP
MJ. Smith | Forum Activity | Replied: Thu, Jan 21 2016 11:52 PM

Greek or Hebrew? The reason I ask is I had to convert some Andersen-Forbes filters to Logos Hebrew morphology.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Jan 22 2016 12:09 AM

MJ. Smith:

Greek or Hebrew? The reason I ask is I had to convert some Andersen-Forbes filters to Logos Hebrew morphology.

I assume Greek with the reference to the VF working on NA28

Posts 70
Robert le Clus | Forum Activity | Replied: Fri, Jan 22 2016 12:11 AM

As you can see this is for Greek. The strange thing is it works on Mac (where my Logos has lived since the first Libronix for Mac was released) and I have upgraded in place. I created the visual filter a long time ago. I just tested and new filters work as well. On Mac. 

On the clean install on Windows, no visual filters show for ESV or the other reverse interlinears. The Greek texts (Those that support the morphology selected) work correctly. 

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Jan 22 2016 12:18 AM

Robert le Clus:
On the clean install on Windows, no visual filters show for ESV or the other reverse interlinears

Do other reverse interlinear features work - can you search on a Greek lemma for example?

What information do you get when you look at the "Support Info" for the ESV? (Click the "i" at the to-right of the resource and scroll down)

I have 

I'm wondering if some datasets have not downloaded correctly.

Posts 70
Robert le Clus | Forum Activity | Replied: Fri, Jan 22 2016 12:23 AM

I'll have to check when I get home. Its on the other laptop Sad 

I will check and let you know! The odd thing is I copied the resources directly from my Mac installation so one would assume if there was corruption it would exist in both environments. I didn't want to download 13gigs + of resources. My net connection while fast has a cap!

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Jan 22 2016 12:40 AM

My guess is that something in the copy didnt work correctly

I would recommend using the command "update resources" to check what you have against what you should have which will cause missing things to be downloaded.

But be careful if your Internet cap!

Posts 70
Robert le Clus | Forum Activity | Replied: Fri, Jan 22 2016 2:03 PM

Unfortunately that did not help. The resource info looks correct. I can do a lemma search and it seems to return the correct results. Also Update Resources ran and didn't update anything. Said I have all the resources.

Tried the LEB as well. Will not see the morph visual filter. It is most frustrating. I really don't want to be forced to redownload all my resources. Guess its my just desserts for buying a Windows machine again :(

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Jan 22 2016 2:10 PM

People reporting similar issues have found that the command "rebuild index" fixed it (see https://community.logos.com/forums/p/99299/686552.aspx#686552 and https://community.logos.com/forums/p/97366/674889.aspx#674889 for some examples)

Note this can take some time to run

Posts 70
Robert le Clus | Forum Activity | Replied: Fri, Jan 22 2016 2:15 PM

I tried rebuilding the Bible Index but that didn't seem to work. I can try your suggestion. Will post my results here, tomorrow :D

Thanks for the help!

Posts 70
Robert le Clus | Forum Activity | Replied: Sat, Jan 23 2016 12:21 AM

Thanks Graham. That appears to have been the ticket! Visual filters is working again :D

Posts 24778
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Jan 23 2016 12:09 PM

Excellent

Page 1 of 1 (13 items) | RSS