Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 2
Jay Ong | Forum Activity | Posted: Tue, Mar 29 2016 1:18 AM

Hi,

could anyone please explain to me why is the Logos Bible Android App (https://play.google.com/store/apps/details?id=com.logos.androidlogos) not compatible with my Samsung Tab S? I've installed it before, but now Google Play tells me its not compatible.

Posts 26535
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Mar 29 2016 1:24 AM

What level is your operating system? An obsolete operating system is the most likely reason for incompatibility.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 2
Jay Ong | Forum Activity | Replied: Tue, Mar 29 2016 1:35 AM

Hi Smith,

thanks for your reply. It's Andriod Version 5.0.2

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Mar 29 2016 3:40 AM

This seems to be a Google issue. There's a whole thread about it here: Android Suite 5.1.0 Stable Release

As a workaround, you might be able to install the beta version:Android Suite 5.2.0 Beta 1 Release Notes

Or you could install the APK directly: https://apkpure.com/bible/com.logos.androidlogos 

Posts 2408
David Ames | Forum Activity | Replied: Wed, May 8 2019 5:08 AM

declanmistry:

sometimes it happen to not only this app. Solution is installing apk file manually, I recommend you to visit apknite and search the app name

Welcome to the forums  

Per thread Android Reader Suite 8.3.0.0039 Stable Release Notes at:

https://community.logos.com/forums/t/181088.aspx  1.  

The current version is 8.3 or so  

Try reading     Logos 8 Mobile App at:

https://community.logos.com/forums/150.aspx 

Sometimes a new version of software requires features that just were not available in older versions on the operating system so are listed as not running on your old device. [[Your device works just as it did when you bought it but it is so old that the manufacturer will not update it to the current operating system.  Too old is often only two years old if you bought it at the end of its life cycle]]

 Please note that you replied to a post that was dated Mar 29, 2016

Page 1 of 1 (5 items) | RSS