"Not Responding" and LPT: Logos Performance Tool

Page 1 of 1 (10 items)
This post has 9 Replies | 2 Followers

Posts 99
JJ Miller | Forum Activity | Posted: Sat, Jul 23 2016 6:45 PM

Looking for some ideas.  Logos 6 has been freezing a lot... whole screen freezes so you can't scroll or choose a menu or shut it down.  The freeze time is anywhere between 2 minutes and 20 minutes.  

Now, for over a year Logos 6 has been "NOT RESPONDING" when used... it would give that error message and it wouldstall 30 seconds to 5 minutes.  I contacted Logos, they say there are NO problems with Logos, and that it must be my PC.  I would tend to agree, but I have Logos installed on 3 pretty good PC's and I know how to check for malware that could be slowing things down.  No, everything on all three PC's run just wonderfully...but not Logos.  It would give the NOT RESPONDING error message and then be unusable for a few minutes. 

But lately it has worsened to the point of unusable.  No longer do I get "NOT RESPONDING", the screen simply freezes... no response for 2 to 20 minutes.  So, knowing that Logos Tech support would just say, "It is not anything wrong with Logos." I downloaded the LOGOS PERFORMANCE TOOL.  Figured I needed some information for tech support and figured this app would give this. 

This LOGOS PERFORMANCE TOOL (LPT) has had an unusual effect:  When I run Logos 6, it still freezes (usually within a minute or two of starting), however, if I then start LPT to run some diagnostics or logging (whatever LPT does), Logos 6 immediately behaves itself.  

I have had stalls and NOT RESPONDING messages for over a year... now it freezes up... but regardless, if I run LPT, Logos immediately starts working just fine.  Why?  What is it doing? 

As far as I know, LPT is not designed to Correct any problems... so what could it be doing that causes Logos 6 to work flawlessly? 

Understand, if LPT is not RUNNING, then Logos 6 returns to stalling and freezing.  LPT does not fix the issue for good,... it does render the problem non-existent when LPT is running in the background. Ideas? 

It is a bit disconcerting, however.  I downloaded the LPT tool to get some diagnostics.... and of course, it is likely not gatthering any useful information for Tech Support because Logos6 runs perfectly when LOT is running.  Ugh.



Posts 2130
Robert M. Warren | Forum Activity | Replied: Sat, Jul 23 2016 8:37 PM

Hi JJ:

That's weird. Maybe the first step is to see if when LPT starts, does it end some process that is messing up Logos.

Start Logos. Give it a few minutes to misbehave.

Assuming you are running WIndows*, open a Command Prompt as Administrator. In Win10,  WindowsKey+X will open a list from which you can choose that. Win7 or 8 probably works similarly. If not, find Command Prompt in the Start menu and right-click and choose Run as Administrator. You'll likely have to click Yes on a nanny screen.

Next, type this in the command window:    tasklist >c:\process1.txt   This will produce a text file of all running processes in the root of your C: drive. This can be opened in Excel and sorted by process name.

Then, start LPT, give it a minute or two to settle in. and run the same command, except name it "process2.txt". Open #1 in Excel and sort it. Open #2 in Excel and sort it. Copy and paste #2 onto the same sheet as #1 in a nearby column. Check for differences. We know #2 will have one or more processes related to LPT. But what we're really interested in are any processes that are in #1, but not in #2. If so, for some reason, it might be a process that LPT kills that was retarding Logos. Make sure you run #2 ASAP after #1, in case some unrelated process ends on its own and clouds our issue.

It's a dice-roll, but you might discover something.

*BTW: It's a good idea to include your operating system in a post like this. Put it in your signature and you don't have to remember. If you're running a Mac, a McDude will have to chime in.

Win 10 [i7-4770; 32GB; SSD] | Android 12 | Fire OS 7

There are four lights

Posts 1130
Lee | Forum Activity | Replied: Sat, Jul 23 2016 9:22 PM

Hello JJ

First when you say 3 pretty good PC's can you be more detailed?

Are all the systems dual core intel systems or do you have a quad core system? How much Ram memory, do you only have HDD or have you upgraded to use a SSD.

Also important how big is your Logos Library.

When was the last full index run on your systems?

I had a problem with my system a few months back and after running a full index, and checking some complex layouts and cleaning them up some Logos returned to great performance.

Note: I am now using a MacBook Pro but i built PC's for years.

Before I upgraded to Mac i had an Asus i3 notebook as my main system I changed over the HDD for an SSD in it and it was like having new computer for over a year until I replaced it.

L4 BS, L5 RB, & L5 Gold, L6 Platinum & Reformed Platinum, L7 Platinum, L8 Baptist Platinum, L9 Baptist Platinum.
2021 MacBook Pro M1 Pro 14" 16GB 512GB SSD, running MacOS Monterey   iPad Mini 4,   iPhone 8.

Posts 99
JJ Miller | Forum Activity | Replied: Sat, Sep 17 2016 7:37 PM

Thanks, I can try this when I get time.  Thanks Robert!

Posts 99
JJ Miller | Forum Activity | Replied: Sat, Sep 17 2016 7:58 PM

Thanks, Lee.  

3 PC's include a dual core desktop....500GB hard drive, 32GB RAM.. The next one is an intel i5 Chip (i5-4210u @1.7GHz to 2.4Ghz top, 8GB ram ) notebook (ASUS) with 1 terabyte HD (No SSD on any PC) and running WIndows 10.(which is my main PC that I use). And the third one is a newer (couple months) Asus Notebook with an intel i7 chipset,  500 GB HD, plus DVD drive, Windows 10, 16GB Ram,

Library resources 5,693.  

Was running Logos 6 Portfolio Edition when I posted this.  Now upgraded to Logos 7 and LogosNOW.  And no appreciable difference.  Well, one difference: About a third of the time it will run without saying "Not responding" and/or freezing up. But when it does freeze up, it does the same thing as Logos 6 did.  

I do have a sizable library, but then I have been using Logos for many years... since it came on floppy disks (version 1).  So they were acquired over time.  And i know people who have larger libraries without  this problem.  

Thanks Lee. 


Posts 99
JJ Miller | Forum Activity | Replied: Sat, Sep 17 2016 8:27 PM

i am not sure what it means to run a full index.   if you mean to make sure that Logos has completely indexed it's library, I have done so many, many times.  This has no influence on behavior of Logos on my PC's. 

Rebooting or limiting "running apps" does not make a difference.  

It is strange, to be sure.  Logos freezes the most on my ASUS i5 Notebook, but also my Del Desktop *until I stopped using it for Logos recently). My newer Ausus i7 it runs the best, but still freezes up at least 50% of the time.


Posts 28007
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Sep 18 2016 2:09 PM

JJ Miller:
i am not sure what it means to run a full index.

The command Rebuild Index will rebuild all your resource indexes.


Windows 11 & Android 8

Posts 99
JJ Miller | Forum Activity | Replied: Thu, Sep 29 2016 8:01 PM

Rebuilding the Library Index (with command: REBUILD INDEX), worked very well.  Thanks for that insight.  I appreciate all the help! 

JJ Miller

Posts 915
Jack Hairston | Forum Activity | Replied: Fri, Sep 30 2016 6:57 AM

The more I look for "download performance tool," the more I can't find it.

If someone would provide the steps to get it, I would appreciate much.

Posts 99
JJ Miller | Forum Activity | Replied: Fri, Sep 30 2016 10:07 PM


It's the first result on the following search. 



Page 1 of 1 (10 items) | RSS