4b RC-1 crashes when switching between layouts created before

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 4508
Robert Pavich | Forum Activity | Posted: Mon, Mar 8 2010 4:56 PM | Locked

I was just switching between layouts, and I can get a repeatable crash.

These are layouts from quite a while ago....months.

log files attached.1563.Logos4Crash.zip

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Mar 8 2010 5:13 PM | Locked

Thanks for the crash text; I've reported this.

Posts 9043
Forum MVP
Mark Smith | Forum Activity | Replied: Mon, Mar 8 2010 5:33 PM | Locked

I tried switching layouts and got no crash but the process took about 6 full minutes. While it is never zippy to do this I'd guess this is 3-4 times longer than I experience in the SR-3 release of 4.0a. The log file attached shows an abundance of errors.

5314.Logos4 (2).zip

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 463
George Allakhverdyan | Forum Activity | Replied: Mon, Mar 8 2010 5:48 PM | Locked

Mark A. Smith:

I tried switching layouts and got no crash but the process took about 6 full minutes. While it is never zippy to do this I'd guess this is 3-4 times longer than I experience in the SR-3 release of 4.0a. The log file attached shows an abundance of errors.

5314.Logos4 (2).zip

Thanks Mark I have submitted this log to development.

Posts 4557
Forum MVP
Fred Chapman | Forum Activity | Replied: Mon, Mar 8 2010 9:14 PM | Locked

Mark A. Smith:

I tried switching layouts and got no crash but the process took about 6 full minutes. While it is never zippy to do this I'd guess this is 3-4 times longer than I experience in the SR-3 release of 4.0a. The log file attached shows an abundance of errors.

5314.Logos4 (2).zip

I did not experience a crash and the speed seems to be about the same as before on mine. I don't have a lot of real complex layouts so maybe that has something to do with it?

 

Posts 10449
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Mar 9 2010 3:27 AM | Locked

Fred Chapman:
I did not experience a crash and the speed seems to be about the same as before on mine. I don't have a lot of real complex layouts so maybe that has something to do with it?

I tried every layout in my system without incident. Some are simple, and some are rather complicated.  In fact, switching seemed faster. Running 4.0b RC-1 under Parallels on a Mac Pro.

Posts 3163
Dominick Sela | Forum Activity | Replied: Tue, Mar 9 2010 3:50 AM | Locked

I tried 4 or 5 of my more complicated layouts on a double screen and they are consistently 5-10 seconds to completely switch. I don't really have a problem with that as in my workflow I don't switch often.  I suspect like many things this can get optimized over time, but I wouldn't consider it a "bug" based on how it runs for me. Others may disagree of course...

Posts 4508
Robert Pavich | Forum Activity | Replied: Tue, Mar 9 2010 5:17 AM | Locked

Hmm....

Some faster, some slower, some crashing...

I might do a "time machine" on my Laptop tonight, and put it back to a known clean state, update Logos 4 to current RC1, then reevaluate....

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 3163
Dominick Sela | Forum Activity | Replied: Tue, Mar 9 2010 5:36 AM | Locked

That might not be a bad idea.  I recently did a fresh install of Logos 4.

We sometimes forget that testing beta software is not without risks.  There can be bugs, or side effects form bugs, that are never really flushed out due to the nature and realities of the process.  Many software vendors force a fresh install when someone goes from beta to gold version, because of this very issue.

Please report back if your system runs better after doing it, as it may help us suggest the same to others who report problems!  You may want to try just an uninstall/reinstall of Logos first, before you worry about the rest of your system. You can always try that at step 2 if needed.

Posts 6477
Forum MVP
Lynden Williams | Forum Activity | Replied: Tue, Mar 9 2010 6:47 AM | Locked

No crashes here. Could load a little faster, but or it could just be my impatience Smile Not a priority for me.

Everything ever written in Religion and Theology formatted for Logos Bible Software.Logos Youtube Channel

Posts 124
Randy Murphy | Forum Activity | Replied: Tue, Mar 9 2010 7:22 AM | Locked

Were can I get the 4.0b download at?

Posts 6477
Forum MVP
Lynden Williams | Forum Activity | Replied: Tue, Mar 9 2010 7:40 AM | Locked

Randy M:

Were can I get the 4.0b download at?

http://downloads.logos.com/LBS4/InstallerBeta/Logos4Setup.exe Happy testing.

Everything ever written in Religion and Theology formatted for Logos Bible Software.Logos Youtube Channel

Posts 463
George Allakhverdyan | Forum Activity | Replied: Tue, Mar 9 2010 10:36 AM | Locked

Mark A. Smith:

I tried switching layouts and got no crash but the process took about 6 full minutes. While it is never zippy to do this I'd guess this is 3-4 times longer than I experience in the SR-3 release of 4.0a. The log file attached shows an abundance of errors.

5314.Logos4 (2).zip

How many panels do you think were loaded in that layout that took six minutes to load? Did you load it multiple times during the test that produced this log?

Posts 9043
Forum MVP
Mark Smith | Forum Activity | Replied: Tue, Mar 9 2010 11:48 AM | Locked

George Allakhverdyan:
How many panels do you think were loaded in that layout that took six minutes to load?

Probably about 30. (I've loaded that same one before so I know it isn't zippy. Just not forever.)

George Allakhverdyan:
Did you load it multiple times during the test that produced this log?

No that was one load only.

I'll go back and try it again.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 9043
Forum MVP
Mark Smith | Forum Activity | Replied: Tue, Mar 9 2010 12:25 PM | Locked

Here is more definitive data. See the attached log file

I restarted Logos and it took approximately 3 minutes and 10 seconds to open to the point I had control. In the log file you'll see some errors during this time frame. The layout Logos opened to has 7 panes and 50 panels within those panes.

At about 15:10:50 or so I attempted to change layouts. It took about 5 minutes and 20 seconds to accomplish this. Again you will note errors in the log file. This layout has 7 panes and 44 panels.

4237.Logos4.zip

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 463
George Allakhverdyan | Forum Activity | Replied: Tue, Mar 9 2010 12:33 PM | Locked

Mark A. Smith:

Here is more definitive data. See the attached log file

I restarted Logos and it took approximately 3 minutes and 10 seconds to open to the point I had control. In the log file you'll see some errors during this time frame. The layout Logos opened to has 7 panes and 50 panels within those panes.

At about 15:10:50 or so I attempted to change layouts. It took about 5 minutes and 20 seconds to accomplish this. Again you will note errors in the log file. This layout has 7 panes and 44 panels.

4237.Logos4.zip

Thanks Mark we will be using this data.

Posts 1627
SteveF | Forum Activity | Replied: Tue, Mar 9 2010 1:04 PM | Locked
4b RC-1 crashes when switching between layouts created before
M$ error reporting Could not get to logs while everything was on screen - too frozen. was trying to delete old layouts so that this very thing would not happen.
After reboot: 7181.Logos4Crash.zip

Regards, SteveF

Posts 4508
Robert Pavich | Forum Activity | Replied: Wed, Mar 10 2010 3:05 AM | Locked

UPDATE!

I completely rolled back my laptop to an earlier config that's known working good and clean and let Logos update to current RC-1

I had deleted the offending layouts so I couldn't use them to test but I picked a few more and while switching between them...I got the same crash.

Logs attached.

7217.Logos Log Files.zip

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 4077
Melissa Snyder | Forum Activity | Replied: Wed, Mar 10 2010 7:06 AM | Locked

This should be fixed in 4.0b RC 2.

Posts 4508
Robert Pavich | Forum Activity | Replied: Wed, Mar 10 2010 7:32 AM | Locked

Thanks Melissa!

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Page 1 of 1 (20 items) | RSS