Page 1 of 1 (4 items)
This post has 3 Replies | 0 Followers

Posts 4264
Kevin Byford (Faithlife) | Forum Activity | Posted: Tue, Nov 22 2016 11:51 AM

The Android team is pleased to announce the 5.9.2 Stable release of the Bible, Biblia, FSB, Verbum, Vyrso and Noet apps.

The apps should be available soon in the Google Play store and sometime tomorrow in the Amazon Store.

If you discover any issues please create a new post and include the following info:

Description – How were you using the app when the problem occurred?
App Info – Which app you are using. (Bible, Biblia, Faithlife Study Bible, Noet, Verbum or Vyrso)
Device Info – (Nexus 7, Motorola Triumph, Droid Bionic, Kindle Fire HDX)
Android Version – (4.1, 4.2, 4.3, 4.4, 5.0, 5.1, 6.0, 7.0)

Versions in this release:

Biblia 5.9.2 (Build 076)
Bible 5.9.2 (Build 076)
Faithlife Study Bible 5.9.2 (Build 076)
Noet 5.9.2 (Build 076)
Verbum 5.9.2 (Build 076)
Vyrso 5.9.2 (Build 076)

Google Play direct download links:

Logos -  
Faithlife Study Bible - 
Biblia - 
Vyrso - 
Verbum -  
Noet - 

Amazon Store direct download links:

Logos -  
Faithlife Study Bible - 
Biblia - 
Noet - 


- Proclaim signal UI styling
- Verse of the Day now appears for anonymous users
- Repositioned the Text Comparison menu item to match iOS


- Android Community notes feature scrolls to top when touched
- Images can't be shared to other apps on some Android versions
- The Forgot your Password/etc links don't indicate the device must be online
- No fallback Bible for Proclaim Signals
- Verse Picker entry field navigation
- Text Comparison entry field navigation

Posts 50
Davy Wang | Forum Activity | Replied: Sun, Nov 27 2016 3:38 PM

Hey logos, I download the 5.9.2 version and installed in my Nokia N1 pad (Intel Atom Z3580, Android 5.1.1), then I tap the Logos icon want to open it, the logos screen shows, but within approx. 3 seconds, vanished and back to the original Nokia N1 homescreen. I tried several times still doesn't work. I reset my pad to factory default and only install Android 5.9.2 Logos App, still the same problem, cannot open it.

The previous Android Logos version works well, but this 5.9.2 cannot.

Could you please check and probably a new Logos Android version could release out.

Thank you very much.

Best regards.


Posts 24763
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Nov 28 2016 12:20 AM

Hi Davy

Sorry to hear you are having problems.

So it can be tracked properly please start a new thread regarding this problem with the information Kevin requested in his post at the top of the thread.

Thanks, Graham 

Posts 50
Davy Wang | Forum Activity | Replied: Mon, Nov 28 2016 4:02 PM

Sorry, my mistake.

I posted a new thread.

Page 1 of 1 (4 items) | RSS