Clean Install? Completely Delete

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 46
Pastor Josh Monda | Forum Activity | Posted: Fri, Feb 24 2017 9:42 AM

I am trying to do a clean install of Logos 7 but that seems impossible.  This is my last resort after months of sermon editor not working and then thinking perhaps upgrading my Mac to Beta software would somehow fix it well it didn't.  Hours on the phone with logos and of course after I upgrade to beta I get told oh we don't support that.  Well that was not the problem when it stopped working originally.  Anyway I have followed the instruction on the WIKI and it still is not giving me a clean install.  I need to know how to complete delete every trace of Logos on my Mac so it is like it was never there.   Then redownload and install if anyone knows how to do this let me know.  Really would like to get sermon editor working it is one of the main reasons I upgraded to 7 in the first place and now I have not been able to use it since November but Logos does not seem to care.  

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Feb 24 2017 9:52 AM

josh monda:
Anyway I have followed the instruction on the WIKI

Suggest using Logos wiki steps => Uninstalling Logos for Mac followed by solutions 2 and 3 => https://www.logos.com/support/logos6/mac/crash then install => https://www.logos.com/install

Keep Smiling Smile

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 10:04 AM

thanks for the info solutions 2 and 3 I looked at both no problem with fonts and no issues with read and write privileges.  I still can get a clean install those instructions are the instruction I followed and I still did not get a clean install of logos.  

Posts 301
LogosEmployee
Brandyn Whittington | Forum Activity | Replied: Fri, Feb 24 2017 11:24 AM

Hey Josh! I went ahead and reviewed the case you have open with us regarding this. It looks like there's still a couple questions, and an open case regarding a bug that we reported from your first contacts with us. Sadly as our most recent email to you stated, we cannot ensure Logos will function on beta versions of operating systems, and looking at your touch points it looks like you're still on 10.12.4. Once you get back to 10.12.3, we can keep troubleshooting as to what the core issue may be. 

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 11:59 AM

I understand that however it quit working before I upgraded to beta.  I upgraded to beta because I had gone so long without having the issue fixed I thought that I may try something else.  So I might as well upgrade to beta to see if it fixes the issue.  Which it did not.  It is a real pain to try to downgrade  and not something I am willing go through.  Interestingly enough it sounds like when apple releases their update then logos may have real problem with the Mac users that update if that really is the problem.  

This still does not solve the problem of trying to get a clean install of logos onto my Mac to see if perhaps that might fix it. 

Posts 301
LogosEmployee
Brandyn Whittington | Forum Activity | Replied: Fri, Feb 24 2017 12:40 PM

The steps detailed by Keep Smiling should assist you with removing both the Logos.app file, and the Logos4 directory that contains all data pertaining to Logos at ~/Library/Application Support. 

While we do certainly understand and apologize that the error was being experienced prior to your moving to the macOS beta channel, there's a very good chance that doing so could have exacerbated the issue outside of what we would be able to handle, as well as creating other issues due to being in a beta environment. I again want to voice my sincerest regret that we were not able to fully assist you when the issue was first reported.

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 1:08 PM

Yeah I followed the WIKI exactly as given and it does not fully remove logos I will try it once again but last night it did not remove it fully.  This was evidence as when I redownloaded logos I it started up as if nothing had been deleted only difference being I had to re sign into the program.  I am not sure why it does not delete it entirely.  Like I said I will try again.  

I regret the issue was not resolved either especially since it is effecting one of the main elements I wanted in logos 7.  

Posts 30529
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 24 2017 1:11 PM

You should call customer service and allow them to assist you. If that doesn't work, let us know and we will rattle some chains 

macOS, iOS & iPadOS | Logs |  Install

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 2:30 PM

I was on the phone with customer service for over 3 hours and I heard I have not seen anything like this before.  They asked me to run logs and send them in so I did.  I waited and waited and waited.  I was the told to delete chrome and reinstall it?  I did this.  Did not fix the issue again I waited and waited and waited I emailed never heard back emailed again sent logs again and then was told oh we see that you are running beta we can't do anything.  Well thanks I have spent well over a grand on software to have a feature that I want to use I can't use.  Lovely.  

Posts 30529
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 24 2017 3:59 PM

Did you call to have them help you remove Logos? 

macOS, iOS & iPadOS | Logs |  Install

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 4:34 PM

No but I was able to do so earlier and it did not fix the problem Crying

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Feb 24 2017 4:58 PM

josh monda:
This was evidence as when I redownloaded logos I it started up as if nothing had been deleted only difference being I had to re sign into the program.

Sounds like Logos4 folder in user's "Application Support" folder within user's Library had not been deleted.

Mac default is user's Library hidden from view in Finder while the system Library is visible.

josh monda:
Yeah I followed the WIKI exactly as given and it does not fully remove logos ...

After following WIKI steps to delete, please open a Terminal followed by running these list commands to verify deletion. Any files and folders listed means deletion not done:

ls -l ~/Library/Caches/com.logos.L*

ls -l ~/Library/LaunchAgents/com.logos.L*

ls -l ~/Library/Preferences/com.logos.L*

ls -l ~/.mono/registry/CurrentUser/software/l*

ls -l ~/.config

ls -l ~/Library/Application\ Support/Logos4

Note: if want to completely delete Verbum, the list commands to check are:

ls -l ~/Library/Caches/com.logos.V*

ls -l ~/Library/LaunchAgents/com.logos.V*

ls -l ~/Library/Preferences/com.logos.V*

ls -l ~/.mono/registry/CurrentUser/software/v*

ls -l ~/.config

ls -l ~/Library/Application\ Support/Verbum

Keep Smiling

Posts 30529
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 24 2017 5:09 PM

josh monda:
No but I was able to do so earlier and it did not fix the problem 

Your comments above suggest otherwise. If you reinstalled the app and there was stuff still there, you didn't delete it all. 

macOS, iOS & iPadOS | Logs |  Install

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 5:24 PM

I followed the wiki to the point where I deleted the logos 4 file.  I did this a few hours ago.  I then went a re downloaded logos.  when I logged in it started downloading all my resources over again this is what it look like currently and indexing is at 5%  So I was thinking that I got everything 

Screen Shot 2017 02 24 at 7 14 25 PM

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Feb 24 2017 5:58 PM

josh monda:
I followed the wiki to the point where I deleted the logos 4 file.  I did this a few hours ago.  I then went a re downloaded logos.  when I logged in it started downloading all my resources over again this is what it look like currently and indexing is at 5%

Concur downloading of resources means previous user Library folder had been deleted. Indexing can take hours; personally use a laptop cooler when indexing lots of resources.

Keep Smiling Smile

Posts 46
Pastor Josh Monda | Forum Activity | Replied: Fri, Feb 24 2017 6:39 PM

My indexing is nearly done I just wish the clean instal would have fixed the problem guess I could not have been so fortunate

Posts 30529
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 24 2017 7:24 PM

josh monda:

My indexing is nearly done I just wish the clean instal would have fixed the problem guess I could not have been so fortunate

If your indexing isn't finished, how do you know its not working? What is the issue anyway? 

macOS, iOS & iPadOS | Logs |  Install

Page 1 of 1 (17 items) | RSS