Perpetually Preparing Library

Page 1 of 1 (12 items)
This post has 11 Replies | 2 Followers

Posts 41
Gabriel Powell | Forum Activity | Posted: Tue, Apr 6 2010 7:11 AM

I launched A16 last night in hopes that it would upgrade to A17. It began downloading 300MB+ and after it finished downloading it didn't do anything. I closed and re-opened Logos and it wouldn't do anything. So I rebooted, opened Logos, and now it's been Preparying my Library for over 7 hours. What should I do next?

Laptop: Windows 7 Professional x64, Intel Dual-Core, 2GB RAM, Radeon X1600

Home: Vista Ultimate x86,  AMD Quad-Core, 4GB RAM, GeForce 8400 GS 512MB

Work: Windows 7 x64, Intel Dual-Core, 8GB RAM, Radeon X1300/X1550

Posts 1246
David Mitchell | Forum Activity | Replied: Tue, Apr 6 2010 8:29 AM

Do you have any logs that you could upload?

David Mitchell
Development Lead
Faithlife

Posts 1
Morgan Floyd MacPherson | Forum Activity | Replied: Tue, Apr 6 2010 8:50 AM

My computer has been going strong for 16 hours now.  Not sure what I should do because I need to use my program for sermon prep.

Posts 8666
TCBlack | Forum Activity | Replied: Tue, Apr 6 2010 8:57 AM

Morgan,

Since I'm a PC and not a MAC I may have a solution that won't work but.....

In the Win version, you can right click the indexer Icon in the system tray and pause indexing for up to four hours (at which time you can pause it again if you need...)

I offer this in hopes that this feature has made it to Mac.

Hmm Sarcasm is my love language. Obviously I love you. 

Posts 1246
David Mitchell | Forum Activity | Replied: Tue, Apr 6 2010 9:10 AM

MorganFloydMacPherson:
I need to use my program for sermon prep.

Morgan:

If you follow the instructions in the FAQ and post logs here, we may be able to be of some assistance.

That said, if you don't have a backup application for sermon prep (the Windows product running in Parallels/Fusion, perhaps?), the Alpha may not be your cup of tea.

Alpha products are incomplete and often have stability issues (just take a look at a number of the threads in this forum). When Logos 4 for Mac is complete, we will of course make an announcement and encourage everyone to use it; for now, however, it's mainly for adventurous users who have backup plans for when things go wrong.

David Mitchell
Development Lead
Faithlife

Posts 72
Andrew | Forum Activity | Replied: Tue, Apr 6 2010 11:47 AM

hi David, I don't know how to "report" with technical info, but I too am having issues with A17.  It took several attempts to update properly, several forced quits, and now it won't open at all, though I do have an icon in the top right(ish) of my screen saying "Logos bible software is indexing (2h 11m remaining)."  The time remaining fluctuates, but doesn't seem to make sense - it's been 2 hrs remaining for over an hour.  hope this helps!  in the mean time, i'll head back to Libronix.  Thanks for all your work, and may you know God's help as you fix stuff.  Will happily try A18, but need to work with something in the meantime for Sunday's message.  Thanks again, Andrew

Posts 3196
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Apr 6 2010 1:50 PM

Andrew:

Just let it keep indexing regardless of the time. If it starts going for days then there maybe an issue. A few things to make sure of. Don't let your computer go to sleep while you see that icon, if it does the indexer stops operating (it is okay for the monitor to sleep, just not the computer as a whole).  If you are serious about trying the Mac version out (if only with spare time) you might want to check out the link in my signature that points to a thread about  taking log files and how to post them. Thanks.

 

Posts 35
Lloyd Lee | Forum Activity | Replied: Wed, Apr 7 2010 6:56 AM

Exactly the same problem for me. L4 has been preparing library for around 6 hours now.

Please find my logs below. Thanks in advance!

1346.Archive.zip

Posts 3196
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Apr 7 2010 11:56 AM

Lloyd:

To be clear, you updated to Alpha 17?

 

Posts 35
Lloyd Lee | Forum Activity | Replied: Thu, Apr 8 2010 6:53 AM

Actually, Tommy, I wasn't updated when I wrote the previous message but have since downloaded it manually so it's moved on to Alpha 17 and no longer preparing my library!

Thanks all the same.

Posts 2
Tim Norman | Forum Activity | Replied: Fri, Apr 9 2010 3:00 PM

I had the same issue and have reported it. Your indexer.log file shows that the indexer crashed. This seems to leave the 'preparing your library' state hanging. I went to bed and the message was still there the next day. 

Posts 3196
LogosEmployee
Thomas Ball | Forum Activity | Replied: Mon, Apr 12 2010 10:39 AM

Tim:

What version of the Alpha do you have installed? Can you attach your log files? (instructions linked from my signature).

 

Page 1 of 1 (12 items) | RSS