High Sierra Ready?

Page 1 of 2 (22 items) 1 2 Next >
This post has 21 Replies | 3 Followers

Posts 2085
Forum MVP
John Fidel | Forum Activity | Posted: Tue, Sep 26 2017 9:31 AM

Please confirm that Logos for Mac 7.9 is ready for High Sierra, or do we need to wait for 7.10?

Posts 26328
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Sep 26 2017 11:14 AM

I asked for official word. Crickets!

I <think> it is fine... but I have had a non-Logos related issue on 10.13 which would cause me to recommend “wait” to my friends. Redownloading 10.13 now, per Apple, and have a scheduled phone call for tonight or Thursday. 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 2659
Forum MVP
PetahChristian | Forum Activity | Replied: Tue, Sep 26 2017 11:39 AM

alabama24:
I have had a non-Logos related issue on 10.13 which would cause me to recommend “wait” to my friends

What issue did you run into?

Posts 26328
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Sep 26 2017 5:33 PM

When I add files to a folder, and the "sort by" is set to "none," the folder becomes corrupted and can't be opened. I have the same issue on two separate computers. 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 321
Brad | Forum Activity | Replied: Tue, Sep 26 2017 6:55 PM

alabama24:

When I add files to a folder, and the "sort by" is set to "none," the folder becomes corrupted and can't be opened. I have the same issue on two separate computers. 

That sounds pretty scary, Alabama.  Did you find a "work-around" or were you eventually able to get back into the corrupted folders?  Can you still see the files in the appropriate directories in a terminal window?

Posts 26328
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Sep 26 2017 7:04 PM

Brad:
Did you find a "work-around"

Yes. As I was on the phone with Apple Care, I had an idea which turned out to work. I changed the sort from "none" to something else (I think any of them work, but I chose "sort by name"). This hinders my work flow, but at least I am able to work. 

Brad:
were you eventually able to get back into the corrupted folders?

Unfortunately not. 

Brad:
Can you still see the files in the appropriate directories in a terminal window?

I don't know how to do that and dont have any folders currently to check. One of the steps we did go through, however, was to boot into "safe mode." I also reinstalled the OS and also created a new user account. None of those steps worked. it really does look like a genuine bug. Tongue Tied 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 321
Brad | Forum Activity | Replied: Tue, Sep 26 2017 7:09 PM

Well, I'm glad I waited on the OS update, but I'm sorry for your woes, Alabama!  Thank you for the info.

Posts 228
Charles | Forum Activity | Replied: Tue, Sep 26 2017 10:59 PM

Concerning the upgrade to High Sierra:

Everything seems to be working except it appears that the "services" "Replace with Passage" is no longer available.  However, The "Copy Bible Verses" is still working from the services menu for both Word and Pages.

I don't have an SSD in my iMac so things are still a bit sluggish as far as Logos goes.  Standard hard drives and Fusion drives do not get converted to APFS so that also makes a difference in speed.  Those folks with all Flash Storage should see a nice increase in speed.

In Christ,

Charles

 

2017 27" iMac 5K, Mojave, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, iOS 12.0  

Posts 1936
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Sep 27 2017 11:09 AM

Charles:

Concerning the upgrade to High Sierra:

Everything seems to be working except it appears that the "services" "Replace with Passage" is no longer available.  However, The "Copy Bible Verses" is still working from the services menu for both Word and Pages.

Charles,

"Replace with Passage" is working on my machine. It might need to be re-enabled by going into System Preferences > Keyboard > Shortcuts > Services and it's under the Text section. 

If this does not work, please let me know.

Posts 1065
Lee | Forum Activity | Replied: Fri, Sep 29 2017 4:11 AM

Hi, I'm just on Serria, I have not upgraded yet. 

Is it ok to upgrade? 

L4 Bible Study, L5 Reformed Bronze, & L5 Gold, L6 Platinum & Reformed Platinum, L7 Platinum, L8 Baptist Platinum.
2015 rMBP 15" 2.2GHz 16GB 256GB SSD, running macOS Mojave   iPad Mini 4,   iPhone 6.

Posts 26328
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Sep 29 2017 5:36 AM

Lee:
Is it ok to upgrade?

As far as Logos goes, you should be "ok." My non-logos related issue remains. 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 228
Charles | Forum Activity | Replied: Sat, Sep 30 2017 9:09 PM

Philana R. Crouch:

Charles:

Concerning the upgrade to High Sierra:

Everything seems to be working except it appears that the "services" "Replace with Passage" is no longer available.  However, The "Copy Bible Verses" is still working from the services menu for both Word and Pages.

Charles,

"Replace with Passage" is working on my machine. It might need to be re-enabled by going into System Preferences > Keyboard > Shortcuts > Services and it's under the Text section. 

If this does not work, please let me know.

The "Replace with Passage" was already checked off.  I tried unchecking it, shutting Logos down, Word down, and restarting both and then check it off again. The only service that appears is "Copy Bible Verses".

I'm running High Sierra and the latest update of Word 2011 and Pages 6.   My version of Logos is 7.9.0.0021 SR-1.

Thanks.

In Christ,

Charles

2017 27" iMac 5K, Mojave, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, iOS 12.0  

Posts 649
Armin | Forum Activity | Replied: Sat, Sep 30 2017 10:02 PM

Brad:

Well, I'm glad I waited on the OS update, but I'm sorry for your woes, Alabama!  Thank you for the info.

Same here. I couldn't afford to lose files. Glad I have waited so far and will continue to do so until the first fixes come out.

Posts 1065
Lee | Forum Activity | Replied: Sun, Oct 1 2017 12:16 PM

I updated to High Serria, so far i have not had a problem.

I checked the disk speed access before & after the upgrade, write was 1,157 Mbps before now 1,179, and read was 1,765 Mbps before & 1,868 now. So it did speed up a little.

So far I have had no problems. Logos running great it looks a little faster, but not sure.

L4 Bible Study, L5 Reformed Bronze, & L5 Gold, L6 Platinum & Reformed Platinum, L7 Platinum, L8 Baptist Platinum.
2015 rMBP 15" 2.2GHz 16GB 256GB SSD, running macOS Mojave   iPad Mini 4,   iPhone 6.

Posts 228
Charles | Forum Activity | Replied: Mon, Oct 2 2017 10:43 PM

Charles:

Philana R. Crouch:

Charles:

Concerning the upgrade to High Sierra:

Everything seems to be working except it appears that the "services" "Replace with Passage" is no longer available.  However, The "Copy Bible Verses" is still working from the services menu for both Word and Pages.

Charles,

"Replace with Passage" is working on my machine. It might need to be re-enabled by going into System Preferences > Keyboard > Shortcuts > Services and it's under the Text section. 

If this does not work, please let me know.

The "Replace with Passage" was already checked off.  I tried unchecking it, shutting Logos down, Word down, and restarting both and then check it off again. The only service that appears is "Copy Bible Verses".

I'm running High Sierra and the latest update of Word 2011 and Pages 6.   My version of Logos is 7.9.0.0021 SR-1.

Thanks.

In Christ,

Charles

Looks like this last update fixed the problem.  Was able to use "Replace with passage" while doing my sermon this morning. Sure makes it easy rather than copying Bible verses. Thanks for the quick fix.  

In Christ,

Charles

2017 27" iMac 5K, Mojave, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, iOS 12.0  

Posts 16
Jeremiah Ketchum | Forum Activity | Replied: Tue, Oct 3 2017 9:07 AM

I just upgraded to 10.13.1 (beta). Don't do it! Logos home page won't load, can't open any books, layouts, etc. It's my own fault for going with a beta!

Posts 4387
Forum MVP
Mike Binks | Forum Activity | Replied: Tue, Oct 3 2017 11:17 AM

Strange that! It is working fine here.

I wonder if it is anything to do with permissions.

One person solved it by applying solution 2 from here: https://www.logos.com/support/logos6/mac/crash

Posts 16
Jeremiah Ketchum | Forum Activity | Replied: Tue, Oct 3 2017 11:56 AM

I'm having the problem on my laptop now and I have not upgraded to Beta (just running 10.13). Any ideas? It won't index either (remaining at 0%).

Posts 16
Jeremiah Ketchum | Forum Activity | Replied: Tue, Oct 3 2017 4:36 PM

Problem solved. I shut down the indexer in the activity monitor, downloaded a fresh version of Logos 7 and reinstalled it. Fired up and indexing like a champ!

Posts 321
Brad | Forum Activity | Replied: Sat, Nov 18 2017 7:30 PM

alabama24:

When I add files to a folder, and the "sort by" is set to "none," the folder becomes corrupted and can't be opened. I have the same issue on two separate computers. 

Alabama, has an OS update release fixed that High Sierra bug for you yet?

Page 1 of 2 (22 items) 1 2 Next > | RSS