Erratic highlighting display

Page 1 of 1 (12 items)
This post has 11 Replies | 1 Follower

Posts 26
John Bengtson | Forum Activity | Posted: Mon, Feb 12 2018 9:24 AM

For more than a year now, I've noticed already-existing highlighting in various resources often doesn't show up unless I do something to force it -- like clicking the "Interlinear" button.

My daily experience:  I open Logos with a layout that includes ESV, ESV Study Bible, and NIV84 in a Multiple Resource window.  Both the ESV and NIV84 have many years of highlighting.  On startup, either the highlighting in those Bibles appears instantly, or it never does (10+ minutes of waiting) until I click "Interlinear" at which point it instantly appears.  I can also force pre-existing highlighting to instantly appear by highlighting something new, or un-clickin and re-clicking "Notes and Highlights" in visual filters.

This is happening on three different computers I own:  an older desktop, a slightly-old Dell laptop, and a brand-new Dell XPS13 2-in-1.  All of them have plenty (8+ GB)of RAM, SSDs, 100+ MB/s Internet connection, and are never busy (CPU/disk access/anything) when this behavior exhibits itself.  All are running the same latest version of Logos 7.

Logs from this morning's startup attached.  I started the app, chose my typical layout, and instantly had highlighting show up in ESV.  Waited about 20 minutes, highlighting never showed up on NIV84.  At 9:05 I finally clicked on the "Interlinear" button, and the highlighting instantly showed up on NIV84.

Thanks -- John

15500.Logos Log Files.zip

Posts 22820
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Feb 12 2018 2:29 PM

John Bengtson:
Both the ESV and NIV84 have many years of highlighting.  On startup, either the highlighting in those Bibles appears instantly, or it never does (10+ minutes of waiting) until I click "Interlinear" at which point it instantly appears.

John Bengtson:
I started the app, chose my typical layout, and instantly had highlighting show up in ESV.  Waited about 20 minutes, highlighting never showed up on NIV84.  At 9:05 I finally clicked on the "Interlinear" button, and the highlighting instantly showed up on NIV84.

Interesting, as the action provoked was to get preferences for the guest resources which had also happened about 20 min. before!

But we will have to wait for Faithlife to get any further with this. It may be connected with the "many years"/large amount of highlighting. Is there any difference when loading the resources in separate panels?

Dave
===

Windows & Android

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 5:43 AM

Dave -- no difference when I start up with a clean interface & load individually from there into separate panels.  I wondered as well if the amount of highlighting I've done over the years was a factor, but I think not:  if it was a factor, I expect I wouldn't be able to instantly bring up the highlighting with a click.  And the highlighting that DOES show up on startup is there right as the text itself first displays...no discernible delay.

Posts 25306
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Feb 13 2018 5:52 AM

John Bengtson:
And the highlighting that DOES show up on startup is there right as the text itself first displays...no discernible delay.

How many (highlighting) note documents do you have? How have you organized them? The document that is slow to load, how many pages would it take to print? The document which is quick to load, same question? 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 8:17 AM

JT,

I have three documents related to highlighting:  "Highlighter pens", with 213 pages if I printed it; "Highlight", with 13 pages; and "Emphasis markup", with 10 pages.

Both the highlighting that immediately shows up in my ESV panel, and the highlighting that does NOT show up on NIV84 are almost always contained in the same "Highlighter pens" note document. So clearly the document is being successfully read & displayed on one part of my screen while at the same time its highlighting content is not being displayed on another part of the screen.

Posts 25306
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Feb 13 2018 10:29 AM

John Bengtson:
I wondered as well if the amount of highlighting I've done over the years was a factor, but I think not:  if it was a factor, I expect I wouldn't be able to instantly bring up the highlighting with a click.

...but you have to wait some time, right? I mean, you can't start the app and 5 seconds later click the button to get them to show, can you? 

John Bengtson:
And the highlighting that DOES show up on startup is there right as the text itself first displays...no discernible delay.

Turn the other two note documents off within both resources. DO you know how to do that? Then, restart and see if your results are the same. 

John Bengtson:
"Highlighter pens", with 213 pages if I printed it

That's quite a bit! 

John Bengtson:
Both the highlighting that immediately shows up in my ESV panel

For clarification: Is it only the NIV84 which has the "slow highlights"? 

John Bengtson:
So clearly the document is being successfully read & displayed on one part of my screen while at the same time its highlighting content is not being displayed on another part of the screen.

These aren't the same highlights, are they? You do know that when you make a highlight in one resource, it doesn't show up in any others (without a special trick). In other words, I just want to make sure that if you are looking for a highlight in "John 3:16" in the ESV that you know that (under normal conditions) you have to have a different highlight note in the NIV84. 

OSX & iOS | Mac Logs | PC LogsInstall

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 3:43 PM

...but you have to wait some time, right? I mean, you can't start the app and 5 seconds later click the button to get them to show, can you?

I don't have to wait any time to force the highlights to show up.  As soon as I start the app, I can immediately click the button & they show up immediately.  There is no appreciable delay.  That's what I do every time I start the app -- I click the button before moving on, and everything is good until I start the app the next time & have to do it again.  I'm just tired of having to do that every time I start the app.

For clarification: Is it only the NIV84 which has the "slow highlights"?

It's the only document exhibiting that behavior right now.  Over time, it's been different documents.  The ESV also had "slow highlights" for a while.  Really, it's not "slow" highlights, it's "never" highlights for whichever document is affected--the highlights never show up even after 20+ minutes of waiting, then immediately show up if I click the button.

These aren't the same highlights, are they? You do know that when you make a highlight in one resource, it doesn't show up in any others (without a special trick). In other words, I just want to make sure that if you are looking for a highlight in "John 3:16" in the ESV that you know that (under normal conditions) you have to have a different highlight note in the NIV84.

No, they aren't the same highlights, they're simply the same passage separately highlighted in two different translations, that happen to be stored in the same notes document.

Turn the other two note documents off within both resources. DO you know how to do that? Then, restart and see if your results are the same.

I'll try that when I get a chance and let you know what happens.

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 4:53 PM

Turn the other two note documents off within both resources. DO you know how to do that? Then, restart and see if your results are the same.

Results of turning off the other two (smaller) note documents:  no effect.  Results are the same.  I turned off one, then the other (independently), then both, and in no case did NIV84 highlighting show up on restart.

Posts 25306
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Feb 13 2018 4:56 PM

John Bengtson:
in no case did NIV84 highlighting show up

A long shot, but what is the resource info for the NIV84? Is this what you see? LLS:1.0.10
2017-12-08T00:56:53Z
NIV.logos4?

OSX & iOS | Mac Logs | PC LogsInstall

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 5:11 PM

Some new behavior I noted:  when I start the app with ESV and NIV84 opening in separate panes, highlighting shows up as it should immediately in both (see first screenshot).  When I start app with ESV and NIV84 opening in same "multiple resources" pane, the goofy behavior occurs (no highlighting in NIV84 unless I click button).

So apparently this may only occur while using multiple resources type display setup.

Posts 26
John Bengtson | Forum Activity | Replied: Tue, Feb 13 2018 5:13 PM

Yes, that is what I see for that resource.

Posts 25306
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Feb 13 2018 6:25 PM

John Bengtson:
So apparently this may only occur while using multiple resources type display setup.

Thanks for the clarification. I didn't catch that to begin with.

OSX & iOS | Mac Logs | PC LogsInstall

Page 1 of 1 (12 items) | RSS
Copyright 1992-2015 Faithlife / Logos Bible Software.