Page 1 of 2 (21 items) 1 2 Next >
This post has 20 Replies | 0 Followers

Posts 423
Lewis Harper | Forum Activity | Posted: Mon, Mar 5 2018 11:11 PM

Indexer has been on all night and appears to be stuck at 9%.  Had no previous problem with indexing with 7.14 Beta 1.  Here are the logs

MacBook Pro. MacOS 10.13.4.  I have restarted program with the same results.

2705.LogosLogs.lewisharper.20180306-010324.zip

Posts 10551
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Mar 6 2018 5:24 AM

Confirm Indexer freeze Early 2018 27" iMac Mac OS 10.13.3 Logos 7.14 Beta 2

Activity Monitor Sample

3771.Sample of LogosIndexer.txt

LogosLogging Sample

5758.Sample.LogosLogs.jackcav.20180306-081902.zip

Quit Logos Indexer from Activity Monitor

7485.LogosLogs.jackcav.20180306-082011.zip 

Posts 8015
LogosEmployee

Thanks for the bug report. I've added this to the Known Issues https://wiki.logos.com/Logos_7.14_Beta_2 and we'll investigate for Beta 3.

Posts 49
LogosEmployee
Matt Preucil | Forum Activity | Replied: Tue, Mar 6 2018 8:44 AM

I'm looking through the provided logs and samples and am not seeing a sample of the hung indexer process (Just of Logos, which does not appear to be hung).

I'm also not immediately reproducing the issue, so if anyone experiences this hang and can provide a sample of LogosIndexer (along with the other logging and .map files), that could be very helpful. Thanks!

- Matt

Posts 423
Lewis Harper | Forum Activity | Replied: Tue, Mar 6 2018 9:48 AM

Matt here is another log sampling along with the indexer showing 10% since the update on yesterday.

8156.LogosLogs.lewisharper.20180306-114709.zip

Posts 49
LogosEmployee
Matt Preucil | Forum Activity | Replied: Tue, Mar 6 2018 9:53 AM

Jack Caviness:

Confirm Indexer freeze Early 2018 27" iMac Mac OS 10.13.3 Logos 7.14 Beta 2

Activity Monitor Sample

3771.Sample of LogosIndexer.txt

Sorry, Jack, I missed seeing this indexer sample.

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, Mar 6 2018 10:11 AM

Mine is hung too, on 15% now but it's been at least 4 hours. Let me know if you need another set of logs...

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, Mar 6 2018 11:07 AM

Is there a workaround for this? I tried closing down, killing the indexer process, and restarting, but it appears hung again. Or are we dead without indexing until the next beta?

Posts 10551
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Mar 6 2018 12:00 PM

Don Awalt:
are we dead without indexing until the next beta?

This may only be an indication bug. Although the Indexing notification is still present, search still works properly, and there is no warning of incomplete results as is normally present during indexing. Searched for "the" in 15k+ resources and received valid results in a half-minute. Looks like indexing may be complete with the indication hung.

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Mar 6 2018 12:08 PM

Jack Caviness:

Don Awalt:
are we dead without indexing until the next beta?

This may only be an indication bug. Although the Indexing notification is still present, search still works properly, and there is no warning of incomplete results as is normally present during indexing. Searched for "the" in 15k+ resources and received valid results in a half-minute. Looks like indexing may be complete with the indication hung.

Jack and Don,

We are still investigating this. Jack, thanks for mentioning the lack of the missing message on the search panel.

Posts 10551
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Mar 6 2018 12:12 PM

Philana R. Crouch:
Jack, thanks for mentioning the lack of the missing message on the search panel.

I also believe that the return of valid search results is significant. I tried this with several searches—Basic, Bible & Morph—all with quick, valid results.

Posts 177
Andrew Zoll | Forum Activity | Replied: Tue, Mar 6 2018 3:39 PM
Experiencing here as well. Please let me know if you need more examples.

💻MacBook Pro (15-inch 2018) | 2.9 GHz i9 6 core | 32GB RAM | Radeon Pro Vega 20 4 GB Graphics | 1TB SSD💻
💾MacOS Catalina 10.15 Beta (19A4871)💾
🎁Logos 7 Portfolio🎁
⌨Logos 7 Extended Feature Set⌨
🌐Logos Now🌐

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Mar 6 2018 3:52 PM

Andrew Zoll:
Experiencing here as well. Please let me know if you need more examples.

Thanks for letting us know you are also having problems. We've do have an open case, we'll update this thread when we are able to ship a fix.

Posts 8015
LogosEmployee

This is technically a (major) performance regression, not a hang; admittedly, it's slow enough it might as well be a hang. 

All new/updated resources are indexed into a "supplemental" index; the merge of this into the main index is extremely slow on macOS in Beta 2. However, the application will search across both the main and supplemental indexes so no search results will be missing in the application.

The indexer performance bug will be fixed in Beta 3.

Posts 423
Lewis Harper | Forum Activity | Replied: Wed, Mar 7 2018 4:17 AM

Thanks Bradley,

Looking forward for Beta 3

Posts 10551
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Mar 7 2018 4:59 AM

Thanks for the explanation Bradley. Even greater appreciation for the upcoming fix.

Posts 17963
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Mar 7 2018 11:44 AM

Don Awalt:
Is there a workaround for this?

One work around is building library index, which can take hours. With Logos closed, personally deleted all files in LibraryIndex folder so launching indexer caused entire Library index to be built.

FYI: Thankful for a friendly MacBook Air (MBA) swap. Completely building Library Index using 2011 MBA with 1.7 GHz i5 (4 GB RAM) took 15.7 hours using 7.13 RC 1 on OS X 10.12.6 while 2013 MBA with 1.7 GHz i7 (8 GB RAM) took 6.5 hours using 7.14 Beta 2 on OS X 10.13.3 (first rebuild reduced Library Index size by ~2 GB)

Keep Smiling Smile

Posts 10551
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Mar 7 2018 1:17 PM

My system finally finished merging the indices sometime while I was away from my Mac this afternoon.

Posts 8015
LogosEmployee

Keep Smiling 4 Jesus :):
Completely building Library Index using 2011 MBA with 1.7 GHz i5 (4 GB RAM) took 15.7 hours using 7.13 RC 1 on OS X 10.12.6 while 2013 MBA with 1.7 GHz i7 (8 GB RAM) took 6.5 hours using 7.14 Beta 2 on OS X 10.13.3

The hardware's not the only thing that changed between those two systems (just sayin').

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Mar 12 2018 11:13 AM

Lewis Harper:

Indexer has been on all night and appears to be stuck at 9%.  Had no previous problem with indexing with 7.14 Beta 1.  Here are the logs

MacBook Pro. MacOS 10.13.4.  I have restarted program with the same results.

2705.LogosLogs.lewisharper.20180306-010324.zip

This performace bug has been fixed in 7.14 Beta 3.

Page 1 of 2 (21 items) 1 2 Next > | RSS