7.14 (7.14.0.0024) is Now Available

Page 1 of 6 (107 items) 1 2 3 4 5 Next > ... Last »
This post has 106 Replies | 10 Followers

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Posted: Mon, Apr 2 2018 11:30 AM

To immediately update to the current stable version enter the Update Now command. Otherwise, the app will automatically update the next time it's scheduled to check for updates.

Release Notes

Download Link

Note: As announced in this forum post, we have dropped support for macOS 10.10. Logos 7.14 will only install on macOS 10.11 and above.

Posts 1250
Veli Voipio | Forum Activity | Replied: Mon, Apr 2 2018 12:02 PM

Well, I am not sure what is going on ...

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 8.1

Posts 64
MikeG53 | Forum Activity | Replied: Mon, Apr 2 2018 12:09 PM

So I just updated to 7.14.0.0024 and it says that Atlas is only available online.  I did have an Atlas tool that worked in the past, but now that is "grayed out".  Do I need Verbum Now to use Atlas under the new release?

Posts 159
Daniel Radke | Forum Activity | Replied: Mon, Apr 2 2018 12:46 PM

I just upgraded to 7.14.0.0024 on my Mac and now the the Atlas icon is no longer displayed under Tools in Logos. I must admit I rarely used this tool, but I do not understand why I now lost access to a tool that I previously owned. If the new Atlas tool must be used online only, can there be at least a link to it within Logos?

eChristianResources.com - Connecting Christians With Quality Evangelical Resources Available For FREE On The Internet (including links to free Logos/Vyrso resources!)

Posts 955
Yasmin Stephen | Forum Activity | Replied: Mon, Apr 2 2018 12:55 PM

MikeG53:

So I just updated to 7.14.0.0024 and it says that Atlas is only available online.  I did have an Atlas tool that worked in the past, but now that is "grayed out".  Do I need Verbum Now to use Atlas under the new release?

I find that you can click on 'Atlas' even if is greyed out. It opens up a window with a more information plus a video ...

Posts 64
MikeG53 | Forum Activity | Replied: Mon, Apr 2 2018 12:59 PM

Yasmin,

Thanks, that seems to be a video of the Atlas tool when it was active under the software on your computer, i.e., the old help video.  The new tool seems to be different and also only seems to be available online - and not working either.

Posts 955
Yasmin Stephen | Forum Activity | Replied: Mon, Apr 2 2018 1:00 PM

And I'm not seeing any maps at all Huh?

Posts 955
Yasmin Stephen | Forum Activity | Replied: Mon, Apr 2 2018 1:05 PM

Yasmin Stephen:

And I'm not seeing any maps at all Huh?

Not even in the web app am I seeing any maps Confused

Posts 15
Bobby Bosler | Forum Activity | Replied: Mon, Apr 2 2018 1:06 PM

I also have lost all access to the Atlas tool in my tools menu. It is not grayed out; it isn't even there. I am online, but have a slow connection.

Posts 64
MikeG53 | Forum Activity | Replied: Mon, Apr 2 2018 1:09 PM

And I don't want to jump the gun here, but if this enhancement/update to the Atlas tool is going to require us to switch back and forth between desktop software and the Web App or even "Verbum/Logos Now" I would not consider that much of an upgrade.  It seems that changes such as this will slowly force us to shift from a PC or Mac based package to an online version or a subscription version.  And after spending thousands on a PC/Mac package, I wouldn't want to have to start paying for resources I previously had already paid for.

Or maybe it's just a glitch in the update!

Posts 955
Yasmin Stephen | Forum Activity | Replied: Mon, Apr 2 2018 1:09 PM

Bobby Bosler:

I also have lost all access to the Atlas tool in my tools menu. It is not grayed out; it isn't even there. I am online, but have a slow connection.

Are you on a Mac? Daniel also said he's not seeing it at all and he's on a Mac so I'm wondering if it removed totally for the Mac people.

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Apr 2 2018 1:12 PM

Bobby Bosler:

I also have lost all access to the Atlas tool in my tools menu. It is not grayed out; it isn't even there. I am online, but have a slow connection.

The maps need to index and this has to be done online. If your internet is slow it could take a little bit of time to show up.

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Apr 2 2018 1:14 PM

Daniel Radke:

I just upgraded to 7.14.0.0024 on my Mac and now the the Atlas icon is no longer displayed under Tools in Logos. I must admit I rarely used this tool, but I do not understand why I now lost access to a tool that I previously owned. If the new Atlas tool must be used online only, can there be at least a link to it within Logos?

Daniel,

You should not have lost access, there is some indexing work that needs to be done while online so that it can work. This can take longer depending on your internet connection and speed.

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Apr 2 2018 1:19 PM

Yasmin Stephen:

I'm wondering if it removed totally for the Mac people.

This feature it available on macOS and Windows, as mentioned earlier it might take a few mintues depending on your internet connection to show up.

Posts 15
Bobby Bosler | Forum Activity | Replied: Mon, Apr 2 2018 1:22 PM

Philana R. Crouch:
The maps need to index and this has to be done online. If your internet is slow it could take a little bit of time to show up.

Thanks for the quick reply, but is there any indicator of this "background indexing" that is going on? I have no indication that anything is happening in my UI.

Posts 1804
Randy W. Sims | Forum Activity | Replied: Mon, Apr 2 2018 1:25 PM

I get the same message I saw during beta:"We couldn't connect to the internet. Please check your connection and reopen Atlas." Indexing or whatever cause, it should display something useful and correct so it doesn't look broken.

Forum ThemeEnhanced Forum Search

Custom PC: Core i7; 32GB RAM; GeForce GTX 970; Win 10 Pro
Google Pixel XL | Apple iPad pro 9.7

Posts 955
Yasmin Stephen | Forum Activity | Replied: Mon, Apr 2 2018 1:28 PM

Randy W. Sims:

it should display something useful and correct so it doesn't look broken.

I agree. And I didn't even get any message about being unable to connect to the internet; I'm simply seeing no maps at all.

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Apr 2 2018 1:30 PM

Bobby Bosler:

Philana R. Crouch:
The maps need to index and this has to be done online. If your internet is slow it could take a little bit of time to show up.

Thanks for the quick reply, but is there any indicator of this "background indexing" that is going on? I have no indication that anything is happening in my UI.

Hi Bobby,

I'm sorry, this is actually a different issue than I first thought. There is an issue with with an internal server that we are getting fixed. We'll get it up and running soon.

Posts 15
Bobby Bosler | Forum Activity | Replied: Mon, Apr 2 2018 1:34 PM

Philana R. Crouch:

Hi Bobby,

I'm sorry, this is actually a different issue than I first thought. There is an issue with with an internal server that we are getting fixed. We'll get it up and running soon.

Yes Thanks!

Posts 1720
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Apr 2 2018 1:44 PM

Everyone,

Thank you for your patience, the Atlas Tool should be working properly now.

Page 1 of 6 (107 items) 1 2 3 4 5 Next > ... Last » | RSS